How to play DVD ISO files on Vero 4K +

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Are they encrypted?
Logs will help


Most of my ISO files are from DVD-A or DVD-V discs, with a few SACD ISO files. I thought I might be able to navigate menus, choose sound outputs, etc., as when playing the discs in a player. Different ISO files presented different playback problems, so instead of running logs for each separate problem, I decided to convert the ISO files to their separate flac files. I don’t get the video or options, but I really just want to play the best audio from each disc, anyway.

If you are doing that, why not use MakeMKV to rip the audio and video? You will not lose any audio quality doing that.

I didn’t know you can use MakeMKV to rip audio and video from DVD-Audio files. I know you can’t with SACD files, but they don’t really have video, anyway. I have used it to rip audio and video from my Bluray audio discs.

Seems that Vero is not compatible with the ISO files. I searched the forum and found a guy who met the similar problem here Vero 4K playing 4k ISO


I’ve removed the link from your post, as the system was flagging it possibly as spam. I’m in agreement with @bmillham, that makemkv is probably the better solution.

Thanks Tom.

It’s hard to advise without more info from the poster.

As I tried to explain in an earlier post, these ISO files do not exhibit the same problem when I try to play them. Some don’t play at all, others don’t let me access menus, etc. Rather than running logs to submit for each type of problem, I decided to just rip the audio from most of these files, which is all I really care about, anyway. If I want to access the video, I use Makemkv.

I really appreciate this forum, but my experience with another problem is another reason I’d rather not run logs for each type of problem with these ISO files, which, even if solutions were provided, I would then have to apply on a case-by-case basis to the ISO files. I had a problem with cutouts when playing files with 44.1 kHz. I asked if there was a setting I needed to change, and I was asked to provide a log. I did, and I was told there was no error in the log that explained the cutouts. I was asked to provide a sample file, and I was told that there were no cutouts playing the sample on their end. Finally, someone who had not analyzed the log provided a setting change that fixed the problem.

One of my challenges as a new user of Kodi on the Vero 4K+ is the lack of a comprehensive resource for settings and FAQs. I understand the usefulness of running logs to submit in many situations, but I also suspect that for new users like me, there might be simple solutions that more experienced users already know.

Well, that’s of course up to you. Without logs, I can’t tell you why the files aren’t playing.

The idea would be to give you a solution for all files, not something that needs to be applied on a ‘case by case basis’

As a start, I’d set MPEG2 acceleration to HD and up instead of Always and see if that helps

Okay, I set MPEG2 acceleration to HD and up, enabled logging, rebooted, and then tried to play 3 different ISO files. On the first one, a DVD-Audio ISO, I eventually got it to play, but I could not access any of the menu options, such as choosing audio. On the second one, An SACD ISO, it wouldn’t play at all. The third one, another DVD-Audio ISO, would not play either.

This is the URL:


The log does not load.

Try this one:

So I guess either the log did not supply information about the problems I’m having playing ISO files, or, for whatever reason, a decision has been made not to reply to my post. I’m okay either way. Overall, I’ve been very satisfied with my Vero 4K+ and the support I have received on this forum.


Sorry - not sure how I missed this. Will check shortly.

Can you please change:

Accelerate MPEG2 to never and see if it helps?

Otherwise, I’ll need to grab an ISO off you to fix this.


That didn’t work. I’m trying to remember how I supplied a FLAC file for a previous problem.

How large is the ISO?

I have one that won’t play, and it’s about 2.4 GB.

Unfortunately I can’t provide you with an upload link to accomodate such a large file at this time. You could use a service like MEGA, Google Drive or Dropbox.