How to (properly) completely reset my movie library

Due to a filesystem problem I had to manually delete a bunch of files and directories from my NFS mounted NAS via ssh and now would want OSMC to start reindexing what survived without any “dangling” movie entries.

Tried reading but it doesn’t seem to cover my case.

What’s the best/fastest/safest way?


PS Tried deleting the NFS mount from the Videos->Files and then recreating the same mount but am seeing serious inconsistencies :frowning:

To give more details on the problem I’m experiencing after having tried to reset as above.

I am listing the movies I have on my NAS via NFS from my Mac using TinyMediaManger which I use to keep my movie collection in order. I also use TMM to download all the .nfo and images for each movie and in OSMC have chosen to show the movies only via their .nfo local files.

In my movie list for example I see on TMM a Pixar short called “Bao” but I do not see it in OSMC’s movie list, but if I SEARCH the Movies in OSMC, a [Movie]Bao shows up as it should, but if I click it I get on shown the movie list but Bao is not there :frowning:

This happens for quite a few others too. TMM lists 95 movies while OSMC only lists 71. All of the 95 do seem to have the proper .nfo and artwork files along with the video file itself.

Not sure I should mention this but when I re-added the movie NFS mount I selected the check box saying that the movies are kept in separate directories, but this is not always the case. Some are but several other are not and share the topmost directory. This does not seem to correlate with which movies are shown and which are not.

I APOLOGIZE :slight_smile: LOL :slight_smile: Feel so dumb !!!

Had the “Hide Watched” option flagged …

For the sake of completeness for others who may stumble across this thread and were looking to get a completely clean library without affecting the rest of their install…


NOTE: The following is non-reversable. Backup beforehand if you think you may need your old library.

systemctl stop mediacenter
cd ~/.kodi/userdata/Database
rm MyMusic*
rm MyVideos*
rm Textures13.db
rm -r ~/.kodi/userdata/Thumbnails
systemctl start mediacenter


Great addition. Thanks