How to properly install SABNZBD on Vero4k +

Without installing sabnzbd, it’s difficult to say, but you ran pip3 install puremagic, which is for python3. See if pip install puremagic (for python2) helps.

Hi,

Yeah, I had tried that too but no go.

I checked out the thread you linked to and I see that you are unable to see puremagic even when you’re inside python3. I don’t have that problem:

osmc@osmc:~$ pip3 install puremagic
Collecting puremagic
  Using cached https://files.pythonhosted.org/packages/d5/6e/62d1cef9a0d8edf2d9c44b0a1b91b0b29b66fb693c94af278a0c76ddfd8c/puremagic-1.10-py3-none-any.whl
Requirement already satisfied: argparse in ./.local/lib/python3.7/site-packages (from puremagic) (1.4.0)
Installing collected packages: puremagic
Successfully installed puremagic-1.10
osmc@osmc:~$ python3
Python 3.7.3 (default, Jan 22 2021, 20:04:44) 
[GCC 8.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import puremagic
>>> puremagic.__file__
'/home/osmc/.local/lib/python3.7/site-packages/puremagic/__init__.py'
>>> puremagic.__version__
'1.10'
>>>help('puremagic')
Help on package puremagic:

NAME
    puremagic - # -*- coding: utf-8 -*-

PACKAGE CONTENTS
    __main__
    main

DATA
    magic_footer_array = [PureMagic(byte_match=b'\x00\x00\x01\xb7', offset...
    magic_header_array = [PureMagic(byte_match=b'\x00\x00\x00\x00\x00\x00\...

VERSION
    1.10

AUTHOR
    Chris Griffith

FILE
    /home/osmc/.local/lib/python3.7/site-packages/puremagic/__init__.py

(END)

Clearly, something is a bit borked on your instalation. Try to uninstall and reinstall the puremagic module.

1 Like

Really don’t know. Tried as suggested.

osmc@HTPC:~$ pip3 uninstall puremagic
Found existing installation: puremagic 1.10
Uninstalling puremagic-1.10:
  Would remove:
    /home/osmc/.local/lib/python3.8/site-packages/puremagic-1.10.dist-info/*
    /home/osmc/.local/lib/python3.8/site-packages/puremagic/*
Proceed (y/n)? y
  Successfully uninstalled puremagic-1.10
osmc@HTPC:~$ pip3 install puremagic
Defaulting to user installation because normal site-packages is not writeable
Requirement already satisfied: puremagic in /usr/local/lib/python3.8/site-packag                                                                                        es (1.10)
Collecting argparse
  Using cached argparse-1.4.0-py2.py3-none-any.whl (23 kB)
Installing collected packages: argparse
Successfully installed argparse-1.4.0
osmc@HTPC:~$ python3
Python 3.7.3 (default, Jan 22 2021, 20:04:44)
[GCC 8.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import puremagic
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'puremagic'

You didn’t use sudo did you?

Okay. Got it:

osmc@HTPC:~$ python3 -m pip install puremagic
Collecting puremagic
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/d5/6e/62d1cef9a0d8edf2d9c44b0a1b91b0b29b66fb693c94af278a0c76ddfd8c/puremagic-1.10-py3-none-any.whl
Collecting argparse (from puremagic)
  Cache entry deserialization failed, entry ignored
  Using cached https://files.pythonhosted.org/packages/f2/94/3af39d34be01a24a6e65433d19e107099374224905f1e0cc6bbe1fd22a2f/argparse-1.4.0-py2.py3-none-any.whl
Installing collected packages: argparse, puremagic
Successfully installed argparse-1.4.0 puremagic-1.10
osmc@HTPC:~$ python3
Python 3.7.3 (default, Jan 22 2021, 20:04:44)
[GCC 8.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import puremagic

1 Like

ive been searching around the forums and i cant quite understand the autostart in debian. can someone explain how to autostart sabnzdb. i did see the wiki but im not understanding im a Arch user typically.

To make the service autostart it would be
sudo systemctl enable sabnzbdplus

1 Like

success! :slightly_smiling_face:

i did see that command and tried it before but it didnt work. this time i ran the command and did a restart right away and it loaded this time.

thanks

just wanted to share my sabnzbd experience on the Vero4k box.

im just using the debian repo version which i think is 2.3.7. no issues. would be nice to have current version but im ok for now.

it does fine processing files. even very large files of course not fast but it gets the job done and even while im watching movies i dont notice any lag.

for a easy way to set options in sabnzbd i seen a few instructions on editing files but i think the best way is to just open a browser and type in your verok ip/port/sabnzbd and set them all thru your browser. make sure to launch sab 1st by ssh in to your box and type sabnzbd.

anyone have experience running several services like radar and sonar all that once? any issues watching movies while all those are running in background?

im still having some issues with the autostart of sabnzbd. i have to retype sudo systemctl enable sabnzbdplus every so often. overall if i dont restart the box it holds.

overall this is a great setup to have. vero4k is one of my best purchases ive made :sunglasses:

1 Like

Thank you for your kind words.

1 Like

I run sab/sonarr/radarr and sab can cause OOM when downloading/unraring large 4k files. I tend to pause jobs when watching content to try to avoid this. Sonarr & radarr seem to have little effect on the 4k.
I would update Sab iif I were you as latest versions use python3 and therefore use less sys resources.
Check on Sab forums regarding autostart

1 Like