How to properly install SABNZBD on Vero4k +

#1

Hi guys,

So my Vero4k arrived this week and it has been a constant reading marathon since I am a total Linux/OSMC nub :frowning:

In the pastI had a HTPC before with OPENELEC running. SABNZBD suit would download anything on the HDD of the HTPC and I’d have 2 external HDD’s attached also.

This HTPC died.

I externalized the HTPC HDD giving me 3 HDD’s with media on them and one still with a download folder, movie folder, etc. relating to SABNZB.

Those 3 are now hooked up to my VERO and I can play all my media as if my HTPC was still alive.

However getting SABNZBD up and running seems to be quite a hassle. I tried all the things in here: How to Install Sabnzbd, Sickbeard, CoachPotato and Samba on Pi2

And I have gotten so far as to run the standard SABNZBD 1.1.1. When actually running this I do not get a connection when opening http://[Your Pi’s IP]:8080/wizard/. So this already is a problem next to the issue that I cannot seem to update to the latest version, which I would like to.

I also have a feeling I should do something with the HDD I intent to get my media on as it is know purely a read HDD used for accessing the media on it and not so much for writing stuff on there via SABNZBD. What I should do there exactly remains a mystery to me.

Basically I just want to get the latest SABNZBD up and running and able to download stuff onto 1 dedicated HDD. The other ones are just there for relocating media and playing it.

I have Putty via which i access my Vero, I messed around a bit with the commands I came across in the topic mentioned, but that’s as far as I got and I really need some help since my skills are 0. Are there any good guides out there or is it really trying a lot and getting to know how debian works? I can follow guides, I just cannot program for shit.

#2

Your most useful resource presently will be the ‘history’ command, which will show you which commands you’ve run before.

1 Like
#3

My *nix skills are only at a 0.2 but I Just now followed that guide you linked to and when I went to http://192.168.254.224:8080/wizard/ the wizard popped right up.

You might start by making sure you can ping your Vero’s IP and if your can take a look (or temporarily disable) your firewall on your PC.

Also SABNZBD 1.1.1 is the most current version available for OSMC.

1 Like
#4

Double check Kodi’s web configuration and make sure that it’s not trying to use port 8080 also.

1 Like
#7

Go into sab config via web, then ‘folders’ and set ‘temp download folder’ and ‘completed download folder’ on seperate drives. There’s a tutorial on here to set it up.

1 Like
#8

Here it is:

1  passwd osmc
2  contrib
3  /etc/apt/sources.lst
4  sudo apt-get update
5  sudo apt-get install sabnzbdplus
6  sabnzbdplus
7  git clone https://github.com/sabnzbd/sabnzbd.git
8  cd sabnzbd
9  git checkout master

10 [deleted]
11 sabnzbdplus
12 echo “deb http://ppa.launchpad.net/jcfp/ppa/ubuntu lucid main” | tee -a /etc/apt/sources.list
13 apt-key adv --keyserver hkp://pool.sks-keyservers.net:11371 --recv-keys 0x98703123E0F52B2BE16D586EF13930B14BB9F05F
14 apt-get update && apt-get dist-upgrade
15 echo “deb http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial main” | tee -a /etc/apt/sources.list
16 echo “deb http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial main” | tee -a /etc/apt/sources.listecho “deb http://ppa.launchpad.net/jcfp/ppa/ubuntu xenial main” | tee -a /etc/apt/sources.list
17 sabnzbdplus
18 sabnzbdplus --server 0.0.0.0
19 sudo nano /etc/apt/sources.list
20 sudo apt-get update
21 mkdir ~/unrar-nonfree && cd ~/unrar-nonfree
22 sudo apt-get build-dep unrar-nonfree
23 sudo apt-get source -b unrar-nonfree
24 sudo dpkg -i unrar_1:5.3.2-1+deb9u1.deb
25 sudo dpkg -i unrar_1:5.3.2-1+deb9u1
26 sudo dpkg -i unrar_1:5.3.2-1.deb9u1
27 sudo su -
28 ls -l /dev/disk/by-uuid/
29 sudo mkdir /media/usb
30 sudo chown -R pi:pi /media/usb
31 sudo chown -R osmc:osmc /media/usb
32 sudo mount /dev/sda1 /media/usb -o uid=pi,gid=pi
33 sudo mount /dev/sda1 /media/usb -o uid=osmc,gid=osmc
34 mount
35 sudo apt-get install python-openssl
36 E: Type ‘Reading’ is not known on line 13 in source list /etc/apt/sources.list
37 E: The list of sources could not be read.
38 E: Type ‘Reading’ is not known on line 13 in source list /etc/apt/sources.list
39 E: The list of sources could not be rea
40 /etc/apt/sources.list
41 sudo /etc/apt/sources.list
42 sudo etc/apt/sources.list
43 sudo nano /etc/apt/sources.list
44 sudo apt-get install python-openssl
45 sudo apt-get install unrar
46 sudo apt-get install par2
47 sudo apt-get install python-yenc
48 sabnzbdplus --server 0.0.0.0
49 sudo apt-get install sabnzbdplus
50 sabnzbdplus --server 0.0.0.0

#9

And here is what I get when I run sabnzbdplus --server 0.0.0.0:

2019-09-14 14:56:30,488::INFO::[sabnzbdplus:1218] ------------------------------ –
2019-09-14 14:56:30,490::INFO::[sabnzbdplus:1219] sabnzbdplus-1.1.1 (rev=33a7874 416d8a8cc6a0d1e3f8d1e4042f2762d81)
2019-09-14 14:56:30,491::INFO::[sabnzbdplus:1220] Full executable path = /usr/bi n/sabnzbdplus
2019-09-14 14:56:30,492::INFO::[sabnzbdplus:1232] Platform = posix
2019-09-14 14:56:30,493::INFO::[sabnzbdplus:1233] Python-version = 2.7.13 (defau lt, Sep 26 2018, 18:42:22)
[GCC 6.3.0 20170516]
2019-09-14 14:56:30,494::INFO::[sabnzbdplus:1234] Arguments = /usr/bin/sabnzbdpl us --server 0.0.0.0
2019-09-14 14:56:30,496::INFO::[sabnzbdplus:1236] Preferred encoding = ANSI_X3.4 -1968
2019-09-14 14:56:30,497::INFO::[sabnzbdplus:1284] Read INI file /home/osmc/.sabn zbd/sabnzbd.ini
2019-09-14 14:56:30,650::INFO::[init:946] Loading data for rss_data.sab from /home/osmc/.sabnzbd/admin/rss_data.sab
2019-09-14 14:56:30,652::INFO::[init:946] Loading data for totals10.sab from /home/osmc/.sabnzbd/admin/totals10.sab
2019-09-14 14:56:30,658::INFO::[postproc:89] Loading postproc queue
2019-09-14 14:56:30,659::INFO::[init:946] Loading data for postproc2.sab fro m /home/osmc/.sabnzbd/admin/postproc2.sab
2019-09-14 14:56:30,661::INFO::[init:946] Loading data for queue10.sab from /home/osmc/.sabnzbd/admin/queue10.sab
2019-09-14 14:56:30,663::INFO::[init:946] Loading data for watched_data2.sab from /home/osmc/.sabnzbd/admin/watched_data2.sab
2019-09-14 14:56:30,665::INFO::[init:946] Loading data for Rating.sab from / home/osmc/.sabnzbd/admin/Rating.sab
2019-09-14 14:56:30,667::INFO::[init:949] /home/osmc/.sabnzbd/admin/Rating.s ab missing
2019-09-14 14:56:30,669::INFO::[scheduler:180] Setting schedule for midnight BPS reset
2019-09-14 14:56:30,710::INFO::[init:330] All processes started
2019-09-14 14:56:30,712::INFO::[sabnzbdplus:343] Web dir is /usr/share/sabnzbdpl us/interfaces/Glitter
2019-09-14 14:56:30,713::INFO::[sabnzbdplus:343] Web dir is /usr/share/sabnzbdpl us/interfaces/Config
2019-09-14 14:56:30,774::INFO::[sabnzbdplus:458] _yenc module… found!
2019-09-14 14:56:30,775::INFO::[sabnzbdplus:466] par2 binary… found (/usr/bin/ par2)
2019-09-14 14:56:30,775::INFO::[sabnzbdplus:471] par2cmdline binary… found (/u sr/bin/par2)
2019-09-14 14:56:30,776::INFO::[sabnzbdplus:474] UNRAR binary… found (/usr/bin /unrar)
2019-09-14 14:56:30,777::INFO::[sabnzbdplus:480] unzip binary… found (/bin/unz ip)
2019-09-14 14:56:30,778::INFO::[sabnzbdplus:487] 7za binary… NOT found!
2019-09-14 14:56:30,779::INFO::[sabnzbdplus:491] nice binary… found (/usr/bin/ nice)
2019-09-14 14:56:30,780::INFO::[sabnzbdplus:495] ionice binary… found (/usr/bi n/ionice)
2019-09-14 14:56:30,781::INFO::[sabnzbdplus:500] pyOpenSSL… found (True)
2019-09-14 14:56:30,782::INFO::[sabnzbdplus:1345] SSL version OpenSSL 1.1.0k 28 May 2019
2019-09-14 14:56:30,783::INFO::[sabnzbdplus:1346] pyOpenSSL version 16.2.0
2019-09-14 14:56:30,784::INFO::[sabnzbdplus:1347] SSL potentially supported prot ocols [‘SSLv23’, ‘TLS’, ‘TLSv1’, ‘TLSv1_1’, ‘TLSv1_2’]
2019-09-14 14:56:30,786::INFO::[sabnzbdplus:1348] SSL actually supported protoco ls [‘v23’, ‘t12’, ‘t11’, ‘t1’]
2019-09-14 14:56:30,790::INFO::[sabnzbdplus:1495] Starting web-interface on 0.0. 0.0:8080
2019-09-14 14:56:30,801::INFO::[_cplogging:217] [14/Sep/2019:14:56:30] ENGINE Bu s STARTING
2019-09-14 14:56:30,810::INFO::[_cplogging:217] [14/Sep/2019:14:56:30] ENGINE St arted monitor thread ‘_TimeoutMonitor’.
2019-09-14 14:56:30,914::INFO::[_cplogging:217] [14/Sep/2019:14:56:30] ENGINE Se rving on http://0.0.0.0:8080
2019-09-14 14:56:30,916::INFO::[_cplogging:217] [14/Sep/2019:14:56:30] ENGINE Bu s STARTED
2019-09-14 14:56:30,928::INFO::[panic:269] Launching browser with http://127.0.0 .1:8080/sabnzbd
2019-09-14 14:56:30,930::INFO::[sabnzbdplus:1567] Starting sabnzbdplus-1.1.1
2019-09-14 14:56:30,933::INFO::[dirscanner:318] Dirscanner starting up
2019-09-14 14:56:30,935::INFO::[urlgrabber:71] URLGrabber starting up
^C2019-09-14 14:56:47,911::warning::[init:166] Signal 2 caught, saving and e xiting…
2019-09-14 14:56:47,912::INFO::[nzbqueue:258] Saving queue
2019-09-14 14:56:47,913::INFO::[init:922] Saving data for queue10.sab in /ho me/osmc/.sabnzbd/admin/queue10.sab
2019-09-14 14:56:47,915::INFO::[init:922] Saving data for totals10.sab in /h ome/osmc/.sabnzbd/admin/totals10.sab
2019-09-14 14:56:47,917::INFO::[init:922] Saving data for rss_data.sab in /h ome/osmc/.sabnzbd/admin/rss_data.sab
2019-09-14 14:56:47,919::INFO::[init:922] Saving data for watched_data2.sab in /home/osmc/.sabnzbd/admin/watched_data2.sab
2019-09-14 14:56:47,921::INFO::[postproc:83] Saving postproc queue
2019-09-14 14:56:47,922::INFO::[init:922] Saving data for postproc2.sab in / home/osmc/.sabnzbd/admin/postproc2.sab

So what am I doing wrong?

#10

How do you ping correctly? I tried ping [VERO IP] and got:

PING [VERO IP] ( [VERO IP]): 56 data bytes

— [VERO IP] ping statistics —
22 packets transmitted, 0 packets received, 100% packet loss

#11

You don’t have to redact your local IP address of any devices within your LAN, these are private and not accessible from outside. It’s not a security concern, my IP of this device is 192.168.0.10, yours is probably similar but we are all protected by the firewall on our routers. Allowing us to see exactly what IP addresses you are trying to interact with can help us see any issues.

1 Like
#12

Microsoft Windows [Version 10.0.18362.356]
© 2019 Microsoft Corporation. All rights reserved.

C:\Users\darwi>ping 192.168.254.224

Pinging 192.168.254.224 with 32 bytes of data:
Reply from 192.168.254.224: bytes=32 time=1ms TTL=64
Reply from 192.168.254.224: bytes=32 time=1ms TTL=64
Reply from 192.168.254.224: bytes=32 time=1ms TTL=64
Reply from 192.168.254.224: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.254.224:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\Users\darwi>

If your Vero is not responding to a ping then you would have to figure out why. If you can’t get it to respond to a ping that is most likely the reason why the wizard did not pop up. The most common reasons why you might have issues is IP address not in the same subnet, VPN, Firewall, child safety software.

1 Like
#13

Well I have been messing around with my router and everything seems to be working now. Ping worked and I have been through the wizard and eveything is set up. Download folder is a dedicated HDD.

Only thing I need to set then is the automatic start if my Vero should restart once in a while?

Thanks for all the help!

Edit:

And I found out that if I kill the Putty session, SABNZBD also stops running :frowning:
Easy way to prevent this?

#14

I think it is more likely that SABNZBD is still running but perhaps your PC has something running that is allowing the connection to your Vero only when Putty is open. Check your firewall on your PC.

1 Like
#15

I really have no idea how to do this. When I have Putty open and type in sabnzbdplus I can access this via the laptop or phone/tablet. Whenever I close Putty or try to something else in Putty (which causes sabnzbd to close) there is no connection possible anymore. Open Putty again and/or type in sabnbdplus again and everything starts…

#16

sabnzbdplus --server 0.0.0.0

You can think of ssh a bit like when you log into an account with a Windows PC. Any programs running when you are logged in get closed as soon as you tell it to log off. There are other programs that still run in the background as part of the system, and not the user. When you opened that program without the extra arguments you were running it as part of that user session. When you log out of ssh then you close that user session and anything that was running in it.

1 Like
#17

Result is the same, or should I replace the zero’s with my IP? IP change also does not matter…

#18

eefonky had a guide on here about how to install and autostart sab - have a search

1 Like
#19

Sorry I didn’t look up the command arguments first to see what it was actually doing (that is only setting a parameter). It looks like you will need to start it up as a system service.

(I did say I was only at a *nix skill level 0.2 :smile:)

1 Like
#20

Yeah I followed those guides and filled in User=osmc. However this does not do anything for me. The test command also comes out blank:

sudo service sabnzbdplus start

Does not result in anything.

Edit: Leaving out the start gives a result with multiple possibilities. I tried restart instead of start and that seemed to work. Everything is now accessible without Putty running.

#21

The proper way on a modern Debian based system to start a service is:

sudo systemctl start sabnzbdplus

and you can check the status of the service:

sudo systemctl status sabnzbdplus
2 Likes