How to properly use Samba as a server on Vero 4K

I am going to move my older Vero 4K to my mom’s house with a direct HDD connected to it. I have my external HDD formatted as ext4 which works fine on the Vero 4K itself, installed samba, but cannot reach the shares. I used the guide in the Wiki, but kept Samba to version 3, have that on my OpenWRT router too and works flawlessly, though on the Vero it just doesn’t want to connect from the same Windows PC.

I am using \ (which is 100% correct, I am connecting through SSH with that IP address perfectly fine) and it just says to check the spelling of the name blabla.

Is it an existing installation with the samba server or a reinstall?
share logs and we can help

How do you want me to make/share logs?

It is on a freshly installed Vero 4K with the latest OSMC version.

The samba server is fresh and according to services in the app store settings, running. I didn’t touch the samba config file yet.

Via MyOSMC - Log Uoloader and share the URL

Hope this provides enough info! Thanks

Looks good, as you are connected via SSH let’s check the basics from OSMC

sudo apt install smbclient
sudo systemctl status samba
smbclient -L localhost

Post the output of the last 2 commands

* samba.service - Samba Server
     Loaded: loaded (/lib/systemd/system/samba.service; enabled; vendor preset: enabled)
     Active: active (exited) since Sat 2024-01-27 13:01:39 CET; 1h 19min ago
    Process: 3025 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
   Main PID: 3025 (code=exited, status=0/SUCCESS)

Jan 27 13:01:39 osmc systemd[1]: Starting Samba Server...
Jan 27 13:01:39 osmc systemd[1]: Finished Samba Server.
osmc@osmc:~$ smbclient -L localhost~
do_connect: Connection to localhost~ failed (Error NT_STATUS_NOT_FOUND)

Just localhost, I think you made a mistake when pasting

Stupid! This is what it comes up with:

osmc@osmc:~$ smbclient -L localhost
Enter WORKGROUP\osmc's password:

````osmc@osmc:~$ smbclient -L localhost
Enter WORKGROUP\osmc's password:
Anonymous login successful

        Sharename       Type      Comment
        ---------       ----      -------
        osmc            Disk      OSMC Home Directory
        IPC$            IPC       IPC Service (Samba 4.13.13-Debian)
        MediaPlayer  Disk      Auto-mount Volume
SMB1 disabled -- no workgroup available

Looks good. Now on Windows what does

net use o: \\\osmc /U:osmc

gives you?

That gives me the warning that the password is wrong, thought I am a 100% sure it isn’t.

C:\Windows\system32>net use o: \\\osmc /U:osmc
Geef het wachtwoord voor 'osmc' op om te verbinden met '':
Systeemfout 86.

Het opgegeven netwerkwachtwoord is onjuist.

How can I make sure Samba isn’t running as v1? In the settings menu it only gives the smbclient option. In the My OSMC settings, there is no such setting at all.

Now I am getting a different result with the default osmc as password:

C:\Windows\system32>net use o: \\\osmc /U:osmc
Geef het wachtwoord voor 'osmc' op om te verbinden met '':
De opdracht is voltooid.

Will have to change the sambapassword and it works after this!

Will reboot and check if I have to redo the netuse command every time. Weird that I have to use that command in the first place, but must be a logical explanation for it of course, just not known by me lol.

Did you change the password? Otherwise obliviously it is the default one.

Well you don’t have to use the command in the first place, I assume it was a password problem in the first place and using the command line shows you that quicker.

I never even got to enter the user name or password in the first place when trying to access it from the file explorer through \ at that moment I just got an error. While that works with my OpenWRT samba server, so (probably incorrectly) assumed it would work the same.

What is the normal way to get to a samba share in Windows to the Vero/OSMC samba server? The wiki doesn’t say.

I had to change the samba password with smbpasswd -a osmc
I forgot that those passwords are different from each other, and changed it, but it is strange that it only worked when using the net use command and not from file explorer.

Because of the wrong password stored in Windows Database

There was no password for it stored anywhere, but I found the answer to my own question.

The reason my OpenWRT Samba worked immediately, was because my PC had the same username as my samba user. I just added the user osmc for this source in Windows references (if that is the English translation for what I see in Dutch) and it works from the file explorer. Learned something new today! :wink:

Thanks for your help!

1 Like

In the address bar of Windows Explorer typing two backslashes followed by the ip address or device name is a good place to start. If you right click on your share your wanting to transfer from/to you can pin a shortcut to the sidebar if you use that or just copy and then go to your desktop or wherever and tell it to paste a shortcut for easy access. You could map it as a drive letter but that can make Windows try to access the drive when it doesn’t need to.

The issue was, that when typing in \ or \\osmc I just blatantly got an error, so I couldn’t click anywhere. When adding the credential in “Credential Manager”, it started to work.
It gave me this error:

Windows can not access \\
Check the spelling of the name. Otherwise there might be a problem with your network.  To try to identify and resolve network problems, click Diagnose.

Error code:0x80004005 Unspecified error

That was my whole issue from the getgo.