How to reset forgotten password on osmc


I´m newbe here, I have RPi2 for a week.
So, as one of first things I did reset osmc user password, suddenly a week later, I cannot login anymore. Password worked OK 2 days ago, then I did update in My OSMC to the 2015-11-02 version and osmc, neither root password working.

I spent yesterday on Google to searching for “How to reset forgotten password on osmc”, but I did not succeed.

Please can somebody advise how to reset these passwords?
Thank you very much in advance.

Can you clarify a couple of points, as your original post doesn’t seem to make sense (there is no password reset facility in OSMC).

  • did you change the password for OSMC, and, if so, how did you do that?
  • did you change the root password?
  • how are you trying to log in?

There is no root password by default in OSMC - you should be logging in as osmc.

You need to clarify how you are trying to log in, whether via SSH or via the local console.

Have you done lots of configuration to it? If it’s pretty much a vanilla untouched install then might be easiest all round to simply reinstall. Obviously this is not really that appealing if you’ve done a whole load of customisation to it.

Hi all,

thank you for replies…

  1. I login as osmc and changed password: sudo passwd osmc
  2. I ran: sudo su - and then passwd root
  3. I use Putty for login to the RPi2

Both passwords works OK till I ran update from My OSMC in the Kodi GUI…
I´m used to work as root, same as in the work, once Sysadmin, forever sysadamin :smile:
Is there something similar like on the full Linux the single user mode?

I ran, actually still running, the MCM over the video files on the NAS and I did not done any major configuration on the RPi2, so I guess overwrite the flash disk with OSMC imaage will the the fastest solution, isn´t it?

Ok so rather than a forgotten login it might just be an SSH problem. I don’t know if this is possible but can you try uninstalling SSH and reinstalling it via the app store?

If it was me, i’d just reinstall but i have a pretty straight forward install as well as an installation script of my setup steps so that i can be up and running again in 20mins (Except scraping my library which i can leave it doing).

The SSh is running, as per OSMC stated this…

I got this when I trying login…
login as: osmc’s password:
Access denied

and same for root :frowning:

OK, I will try reinstall the SSH in the OSMC GUI… if it won´t help, then I will do fresh install…
ehm, just yesterday I put RPi2 with fan to the box, I hoped I will not take it out for looooong time :cry:

MCM still progressing all the Video files, so I guess I have still plenty of time, I never realized how many movies have same name :worried:

I uninstall SSH in the My OSMC and then installed it back…
Suddenly,it did not help :sob:

So, I´m gonna wipe the FlashSD and start over from scratch again :rocket:

Didn’t think it would help but had to be worth a try.

To be honest there are plenty of solutions how to reset the root password but the question is if they are worth the effort as you simply could create a backup (from MyOSMC) and reimage the SD Card.

OK, so SDcard wiped by SDFormatter…
Downloaded the latest image OSMC_TGT_rbp2_20151129.img.gz
Installation is running…

Then I will do the update first…

So, this topic can be closed with solution: Not possible to reset osmc/root password easily, the fastest way is to complete reinstall.

Thank you all for advises.