[HOW-TO ] retrOSMCmk2: a RetroPie installer on the Vero4K

It seems to be an upstream issue. There’s something ongoing that has been reported for the RPi which sounds similar enough. They froze at v3.3 on RetroPie because of it. I’ve had to go back to v3.1.3.1 for us.
I’m having issues updating the download, but I’ll report back when it’s done.

Do you mean upstream RetroPie or Amiberry? Any link to the issue in question?

FYI, I just received an update popup for retrOSMCmk2 and installed it. Quickly checked Amiberry and it’s (still) at 3.3. Guess the update was unrelated then.


It’s an issue with Amiberry. So RetroPie have frozen at a last good version. Ours seems to be an earlier one. I don’t have a link. I just searched their forums for the issue you’d described.

When the new binary is available you’ll just need to update Amiberry from RetroPie. Although it’s an older version its a newer build, so it’ll download. As I said, I’ll let you know when it is available.

The update you installed was for the addon itself and it read

URGENT: Prepare for Python 2 to 3 migration

That is because Kodi 19 will break the addon as it moves us onto newer python. There will be an update on the day of release, BUT users won’t get that update if the addon is already broken by the newer python version… The update protects against that deadlock and they’ll only have to reboot to fix it.

Thanks for the details. Sorry, completely forgot about the update’s message in the meantime - duh!


Today OSMC offers an upgrade to Kodi 19. This brings a few changes affecting addons, including a move to Python 3.

The retrOSMCmk2 addon introduced an update notification system on 22-Nov-2020.

  1. Users who installed or updated since then will have received a notice on 21-Jul-2021 URGENT: Prepare for Python 2 to 3 migration in preparation for this big move, to prevent breakage of the addon. After you upgrade to Kodi 19 you may just need to reboot for the addon to work. As of today a further update is offered, titled URGENT: Kodi 19 migration fixes. You should install this after you have updated to Kodi 19.

  2. Users on an outdated version, or who otherwise find the addon broken will just need to run the retrOSMCmk2 setup script and select Manage retrOSMCmk2 -> Update retrOSMCmk2 instead. Then reboot.

I hope the update process runs smoothly for you. Enjoy Kodi “Matrix” 19!

1 Like

Hi there,
I’m having a hard time trying to install retrOSMCmk2 on a Raspberry Pi 4.
I’m using a fresh unmodified install of the latest OSMC release. There are a lot of error messages during installation and the launcher from inside kodi doesn’t work.
Here are the screenshots from the error messages ( I used ssh and putty for installation):

Have you used the installer on your RPi4 previously?

I’ll run this through my old RPi3 again, see if anything has changed since my last test.

I tried several times using different installation options inside the RetroPie installer
(Basic installation vs. Manage packages-> Manage core packages-> Install all core packages), each with the same result. All done on a fresh OSMC installation from yesterdays update. I haven’t tried this on a previous build. A fresh install with only RetroPie works normally.

On a freshly installed RPi3B+ setup.sh is providing the addon zip in the home directory. That installs successfully from within Kodi and starts ok. I can access its settings page. The launch button is there, but without installing EmulationStation that obviously won’t do anything at this stage…

RetroPie-Setup is interesting. First I found gpg wasn’t installed by default. Rerunning after installing that I got:

gpg: key F1B030906A3B0D31: public key "RetroPie Project <retropieproject@gmail.com>" imported                                                                                                 
gpg: failed to start agent '/usr/bin/gpg-agent': No such file or directory                                                                                                                    
gpg: can't connect to the agent: No such file or directory                                                                                                                                    
gpg: Total number processed: 1                                                                                                                                                                
gpg:               imported: 1    

I don’t believe we need the agent installed and doing so anyway changed nothing. I wonder if you were having a problem connecting to the Ubuntu keyserver at that time?
Even so, for me the package menus show nothing available as “install from binary”. Only “install from source”. That is odd.

I am going to try installing from an older OSMC image and see how that rolls.

The kodi addon is generated and starts on my system, too. I meant it would’t start RetroPie with the launch button, after the RetroPie setup finished.
I also have no option to install from binaries.

No binaries?
Your error messages implied that the binaries had been downloaded, but that gpg key verification failed. If I try to do a core install it just tries to build from source. So it did seem to acknowledge them on yours. It would be interesting to read pastebin of the relevant log, from retrOSMCmk2/submodule/RetroPie-Setup/logs

Thanks for those. I’m working through the problem now. I’ll let you know if I need anything else checked.

now that the 4.9 kernel was released I gave this another shot and I have only 1 issue right now.
Because my TV announces it can handle 1080i retropie defaults to that, but it comes with an unfixable overscan, which is why I would like to set it to 1360x768.

I ran fbset

while running kodi:

mode "1360x768"
    geometry 1360 768 1920 4410 32
    timings 0 0 0 0 0 0 0
    rgba 8/16,8/8,8/0,8/24

while running retropie:

mode "1920x1080"
    geometry 1920 1080 1920 2160 32
    timings 0 0 0 0 0 0 0
    rgba 8/16,8/8,8/0,8/24

So it is working for you in Kodi now which is good to know.
We have a new version of the mode setting menu, which should handle many new resolutions including yours. I specifically wanted you to test it so I’m glad you’re still about.
I would have had it available already, but I’ve been held up fixing the RPii KMS package issues. Nearly there.

I started getting “failed to add service - already in use?” when starting retropie after I updated OSMC. Retropie setup also started giving me a warning about an experimental GL driver being enabled and to disable it. I tried deleting and commenting out “dtoverlay=vc4-fkms-v3d” from setup.txt but that stops OSMC from loading all together. I also tried using raspi-config but the prompt said to edit using My OSMC. When I tried that there were no options I could see that were related to the driver.

Yes, the new drivers on the RPi are here to stay. They can not be disabled. The errors you see are because you have installed packages that were built against the old style drivers.

Note - This does not affect the Vero4k/4K+, for which this addon was originally intended to support.

RetroPie themselves are only supporting the RPi4 in this, I assume as it’s the newer platform. As you read, there may be issues using the GL drivers anyway.
I am finishing some changes so that on RPi4 we use their new KMS/GL packages, so binary install options will be restored.

For your convenience I have now rebuilt all of the core and main packages, plus a few optional emulators for use on the RPi2/3, so for retrOSMCmk2 users we can still provide a binary install option, which RetroPie do not. There may be issues with some of them as warned, but that is the state of play (I haven’t noticed anything with my initial tests but I don’t use all of them myself and my time is limited).

When I finish my changes you will be able to update the addon and install the RetroPie provided packages on RPi4 and the retrOSMCmk2 provided packages on RPi2/3.

I will report back here when it is ready.

First of all, many thanks to @hissingshark for this wonderful installer. After moving to an Apple TV 4K for my video needs, I’ve been able to repurpose my Vero 4K to a fantastic retro gaming system. Install went fine, and playing a number of systems without issues. One question though, I was hoping to use a ‘CRT-style’ shader - however, when doing so performance is really bad - Has anyone had any experience with shaders? Is the Vero 4K a little underpowered? Could anyone recommend any CRT-style shaders which have worked on a Vero 4K?

Any help most appreciated!

I dabbled with the shaders, particularly CRT, a few years back. It did impact on performance then, but it will on any platform. I think rather than go with presets I experimented with layering my own.

The Vero4k has run beasts like PPSSPP in a way they would never have done on the RPi, so it has a definitely has power.

However, RPi fares a little better for CRT shaders. As with many things that seem to do better on it, there have have been specific optimisations to make it happen. RetroPie being what it is, the platform has been the focus of development attention.

As our hardware is comparable to the ODROID-C2 there is sometimes shared experience with those users on the RetroPie forum. Probably worth a Google.

1 Like

How’s the dreamcast emulation running on the 4k+?