[HOW-TO ] retrOSMCmk2: a RetroPie installer on the Vero4K

#1

There’s a new installer for RetroPie on the Vero4K! It still supports the RPi, so it’s been imaginatively called…

retrOSMCmk2


What does this installer add?

  1. Binary install options for the Vero4K for all of the tested emulators, so you’ll be up and running in minutes rather than hours;
  2. Provides a new launcher addon as standard;
  3. Fixes the popup menus on the Vero4K when you start a game (you may not have noticed but previously they didn’t display at all, so you couldn’t select the default core for a ROM etc, or TV mode);
  4. Runs Emulationstation as a proper service.

Thanks to:
@DBMandrake - popup menu fixes and the startup service.
@joakim_s - TV mode selection fixes.
@mcobit - the original name that I really couldn’t improve upon.
@sam_nazarko - hosting the binaries.


Installation is via:

sudo apt-get install git
cd
git clone https://github.com/hissingshark/retrOSMCmk2.git
cd retrOSMCmk2
sudo ./setup.sh

Just select RetroPie-Setup from the menu and proceed as normal.

You will need to install all of the core packages:
Manage packages->Manage core packages->Install/Update all core packages from binary

Then start installing the individual emulators you want to try under:
Manage packages->Manage main/optional/experimental packages

Only installing one at a time the packages you intend to use is more sensible, but if you really are going to use most/all of the main emulators you could save a few clicks by running:
Basic install which will install the Core and Main packages from binary in one step.


Currently tested:

EmulationStation

Amiberry
Mupen64Plus
PPSSPP
Reicast
ScummVM
VICE

Retroarch and the 27 “main” cores including:
lr-fuse
lr-gambatte
lr-genesis-plux-gx
lr-mgba
lr-nestopia
lr-pcsx-rearmed
lr-snes9x2010
lr-mame-2003-plus

ADVISORY:

  1. If you encounter problems with the above supported subset, try again with a clean OSMC install.
    90% of the problems encountered by new users have related to systems contaminated by previous experiments and configurations. You will save a lot of time if you try this first. Then if there is a problem we are at least all on the same page. I want you gaming as quickly as possible!
  2. Not all emulators are tested as yet. Some may not work or building them may break others. Adding one at a time and checking how things are is the way to go!

Please report back with your findings! Good or bad.

5 Likes
[HOW-TO / TESTING] RetroPie on Vero4k
#2

Good work.

Moved to HowTo.

#3

Hi there

Does this work for a Vero 4k+? I have tried it on a vanilla install and I get the following:

Thanks

#4

Thanks for testing.

Yes it’s certainly meant to. Looks like Kodi didn’t stop there for you. We’ll take a look at that for you.

#5

If you wait a bit longer, does it work?
Do you have PVR enabled?

@hissingshark maybe Kodi is taking a bit of time to exit.

#6

I’ve tried doing this manually via systemctl (stopping mediacentre and starting emulationstation) and I get the same result unfortunately.

Is there anything I can get from my vero 4k that will help?

#7

I originally tried this with my Vero 4k with it configured, and I did have IPTV (if thats the same as PVR). But this image is from a vanilla install, no configuration changes made.

#8

What version of OSMC are you on?

#9

I installed using this image:

OSMC_TGT_vero3_20190808.img.gz

#10

It’s odd that with your manual attempt Kodi was still there. To be sure, Kodi did stop there for you first? It’s mediacenter and not mediacentre, in case that typo was consistent.

Also if I manually start Emulationstation without stopping Kodi first it just takes ever the screen. There isn’t a clash of the two. You’ll only get Kodi displayed if you use the remote and even then ES redraws over it moments later.

That triple vision thing is also interesting. Is your TV 4K resolution or 1080p?

#11

Sorry that was a typo.

Either way I stop/start emulationstation I get that screen unfortunately.

It is a 4k TV, I was wondering if it could be that with the weird multiple…

#12

OK, and when you then manually started ES did you sudo systemctl start emulationstation, or did you just run the command emulationstation? Do try both as they may behave differently, although not here.

#13

I was running sudo systemctl start emulationstation but have just stopped it and ran emulationstation with the same result.

I do have a 1080p TV, is it worth me trying it there?

#14

Well that’s excluded that then.

You could try the other TV, if only to clarify the cause of the repeated display. I’d be surprised if it fixes the actual startup fault though.

#15

I’ve just tried it on a 1080p TV and it is working correctly through the RetroPie addon. So its a 4k resolution issue.

Is there a work around?

Do you need more info (type of TV)?

#17

Please do. Then we have all the pieces, such as it is.
No workaround right now, but thank you for narrowing this down.

#18

OK, its a Samsung, but I think its a model only sold in New Zealand/Australia. The model is UA55KU7000SXNZ.

Is it working in 4K resolution normally? Just want to know in case I need a TV upgrade :wink:

Thanks for all your help and maintaining this

#19

Cheers.
I’ve not had the pleasure of trying it myself as I most definitely need a TV upgrade! And I shall certainly want it working!

#20

Got another 4K TV tested, an LG one. Appears its the resolution not the type of TV.

#21

Do you mean you have the GUI set to 4k?