How to use CEC with 2 HDMI cable?

Hi,

I have two HDMI cable connected to my tv, 1 on my satellite decoder and the other on my RPi.

The problem is that the remote no works with 2 cable plugged, I must remove the one connected to the decoder.

Thx !

Hi,

Try this:

Power off your pi, tv and the decoder for 10 minutes.

Power back on the TV & the pi and make sure cec is working. Then reconnect the decoder and check if cec is still working?

Thanks Tom.

I do not understand the manipulation, but it does not work ?!

Hi,

I take it the cec is still working on the pi, if the decoder is disconnected?

Does the decoder support cec?

Thanks Tom.

Hi,

Yes it is disabled, but even activating it does not change anything. the only way and unplugged the cable from the decoder.

When I start kodi, it only works for a few seconds. It has something to do in the settings of the adapter ? or in config.txt ?

Hi,

Try powering all the kit off again for 10 mins. Then power on the TV and the decoder, then add the pi last. What happens now?

Also have you tried different HDMI cables?

Thanks Tom.

I tried the same installation on another TV (Samsung) with another RPi plugged into it. I do not have any problems.

It’s only with my TV (Philips). Apparently he can not manage 2 cables

Still, with the decoder I have no problem to use the remote ???

EDIT: I did the installation on my Samsung TV.

Do I have to do it on the Philips TV ?

Hi,

You may just need to play with the easylink settings on the Philips:

https://www.philips.ca/c-f/XC000010078

If you haven’t tried different hdmi cables I would advise doing so.

Thanks Tom.

I have tried almost everything. Same problem with other cables.

By elimination the decoder would be the problem.

1 / I activate the CEC in the decoder and it works, but the decoder crashes.
2 / I remove the HDMI cable connected to the decoder, it works, but I do not have a decoder anymore.