Howto edit config / skin-config files from cli


i have a up to date vero4k with osmc skin and need to change some settings from the comand line.
Adding some shortcuts to new sources by editing the files does not to work for me.

When i setup the vero some time ago i made shortcuts in the submenus of the movies, music, and pictures via the skin settings with the remote. Now i need to add new shortcuts to new sources, but can not do it with the remote.

I stopped the mediacenter, edited the xml files [favourites, mediasources, passwords and sources] and can access the contents when opening movies/files, music/files, etc.
As the osmc skin schortcuts seem to be located in .kodi/addon_data/script.skinshortcuts/videos.DATA.xml , music.DATA.xml, pictures.DATA.xml and i modified them also but after restarting/rebooting the mediacenter the new shortcuts do not apear in the submenus.
What am i missing?

The second thing i need to change is the displaying of the pictures in the background while browsing the directories. How to turn this off?

And one last thing. How to set the Listview as default view for everything [videos, music, pictures, games, etc]? Not only for the unvisited but also for the visited directories if possible?

Why not change this directly via the UI?
Changing things related to the skinshortcuts script is not trivial… But I believe you’d have accessed the correct files to do this already. Not sure though as I haven’t written the script and I haven’t dug into how this can be done via commandline before.

Has the Writing home menu… notification shown when initially booting up Kodi?

This should be the HideFanart setting you have to set to True. You’ll find this in home/osmc/.kodi/userdata/addon_data/skin.osmc/Settings.xml.

I’m not sure this is trivially possible. Maybe some other team members have an idea.

Thank you @Chillbo.
I used your nfs howto (nfs it’s so fast! :smile:) to change the locations of my mediashares and did not want to change the shortcuts with the remote, as it is very slow, but have now successfuly changed the skinshortcuts after finding the correct files*.
For unknown reasons pictures.DATA.xml in the .kodi/addon_data/script.skinshortcuts directory was the correct location for pictures but videos.DATA.xml and music.DATA.xml were not used. In my case the files were named 2.DATA.xml and 3.DATA.xml.
The correct name can be looked up in the file mainmenu.DATA.xml between the <label> tags.

I stopped the mediacenter with sudo systemctl stop mediacenter, edited the files with nano .kodi/addon_data/script.skinshortcuts/2.DATA.xml and started the mediacenter with sudo systemctl start mediacenter. A short time after restarting the Writing home menu… appeared and the new shortcuts were in place.

*(I have also disabled the option to share the skinshortcuts between compatible addons in the configuration of the skinshortcuts addon which can be reached via settings/system/addon dependecies (not sure about the exact path) but it should work with this option enabled also, just edit the correct tags)

Unfortunately setting HideFanart to true in the home/osmc/.kodi/userdata/addon_data/skin.osmc/Settings.xml did not work for me. I still see the pictures in the background of the directory which makes it hard to read. Have to look further. (will update this post when i find a solution in time)

To set Listview als default i have changed the order of the numbers in the views tag , 50 first, in /usr/share/kodi/addons/skin.osmc/16x9/MyVideoNav.xml as suggesited by some posts i found. Unfortunately having set Listview for all the directories by hand now and lacking new content i can not test it.

If anyone can share some info regarding the second and third part, it will be appreciated.

Glad to hear you got the skinshortcuts part working. Just out of interest: Why are you doing all of this through command line?

I’ve checked this again and the setting is indeed not working properly. I’ve made some changes to the background includes responsible for this when working on the v18 skin. Maybe I’ve messed up this setting. Will check next week and fix it, if possible :slightly_smiling_face:

It’s linux so command line is the right way to do it :wink: No, but i have quite some mediashares and changing them all from smb to nfs(fstab) is faster on the command line. It’s copy and paste with some editing which is faster than working with the remote controll. And i must admit i have more fun that way. So it’s more about the process than the results.
Thank you for looking into this, take your time. Browsing works this way too and it’s only aesthetics.