[HowTo] Moonlight-Embedded (former Limelight) using Luna Launcher


#145

That’s a wonderful news :smile:
I have a small request however.
I know that this is not moonlight related “issue” but would it be possible to include an automated method of switching between xboxdrv configs (kodi and moonlight for example)? Or if anyone could suggest me how to run xboxdrv in daemon mode. Maybe that would be better option.

Anyway, I tried to use moonlight service to switch between those configs but with no success. I wonder if I’m the only one who has this kind of problem.


#146

So you’re using your Xbox pad to control Kodi? I don’t know if enough people do this to write code specifically for that purpose. The plan is using systemd units to load/unload controllers. You could probably hack that to do what you want once that is implemented.

Edit: I use xpad for my Xbox pad. The stuff I write will use xpad. I don’t think xboxdrv is even being actively developed.


#147

Sometimes yes, whenever controller is plugged in when OSMC starts.
Anyway I will wait for the new release.

The reason why I’ve used xboxdrv is that most guides describe how to use it with Kodi, Moonlight or even RetroPie.
Regarding driver development I think it’s still alive. While version available for OSMC stopped at 0.8.5, the latest version is from 9th Nov.
http://pingus.seul.org/~grumbel/xboxdrv/


#148

Have y ever experienced any jittering/fps drop with moonlight app?? I get all the time fps jittering (wired ethernet) and i dont know if the problem relies on nvidia (drivers) or on client (moonlight) side…


#149

@dodslaser updated the guide since snd modules isn’t needed anymore you should do the same use the dtparam instead.

as for the profile on wiimote is pretty much done

created a simple snippet for those that have issues with audio not working

#!/bin/bash
if [ $USER != root ]; then
        echo  "Error: must be root"
        exit 0
fi
if grep -Fxq "dtparam=audio=on" /boot/config.txt
then
	echo \"dtparam=audio=on\" is present in config.txt
else
	echo "dtparam=audio=on" >> /boot/config.txt
	echo \"dtparam=audio=on\" is added to config.txt
fi

#150

thanks tomorrow i will test this on mi OSMC. I will try to configure My rumblepad cordless 2, now When i write

dmesg

My output is:

logitech: probe of 0003:046D:C219.0001 failed with error -1

and dont respond :frowning:
Lets see tomorrow with your guide.

Thanks for your effort :wink:


#151

thats missing in the kernel its gonna be included in the kernel in the future so right now its impossible to get your logitech controller working


#152

You save me lot of time and effort making it run :wink: THANKS A LOT my friend :wink:

ETA on that update?


#153

no idea, Sams on a holiday with Christmas coming up and the holidays its hard to say ill check and get back once i have an ETA


#154

Meanwhile ill be working on Steam Controller profiles for this project getting that to work should be fun.


#155

@Toast Hello! I tried your updated guide again but I keep getting an error about the packages (last step):

“The following packages have unmet dependencies:
moonlight-osmc : Depends: moonlight-embedded but it is not installable
E: Unable to correct problems, you have held broken packages.”

repo-dodslaser.rhcloud.com’ is in the sources.list. I can’t install moonlight-osmc.


#156

ill investigate and come back


#157
osmc@osmc:~$ sudo -s
root@osmc echo "deb http://repo-dodslaser.rhcloud.com/ wheezy main" > /etc/apt/sources.list.d/moonlight.list
root@osmc:/home/osmc# apt-key adv --keyserver keys.gnupg.net --recv 4A1C897B
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.6HgxULkGC1 --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyserver keys.gnupg.net --recv 4A1C897B
gpg: requesting key 4A1C897B from hkp server keys.gnupg.net
gpg: key 4A1C897B: public key "Erik Lundgren <eriklundgren93@gmail.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
root@osmc:/home/osmc# sudo apt-get update
Ign http://ftp.debian.org jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease                                                                                                  
Hit http://security.debian.org jessie/updates InRelease                                                                                             
Ign http://archive.itimmer.nl jessie InRelease                                                                                                      
Get:1 http://repo-dodslaser.rhcloud.com wheezy InRelease [1730 B]                                                                                   
Hit http://apt.osmc.tv jessie InRelease                                                                                                             
Hit http://ftp.debian.org jessie Release.gpg                            
Ign http://archive.itimmer.nl jessie Release.gpg                        
Hit http://ftp.debian.org jessie Release          
Hit http://archive.itimmer.nl jessie Release      
Ign http://archive.itimmer.nl jessie/main armhf Packages/DiffIndex
Get:2 http://ftp.debian.org jessie-updates/main armhf Packages/DiffIndex [367 B]
Hit http://ftp.debian.org jessie-updates/contrib armhf Packages                 
Hit http://ftp.debian.org jessie-updates/non-free armhf Packages
Hit http://ftp.debian.org jessie-updates/contrib Translation-en
Hit http://security.debian.org jessie/updates/main Translation-en                                          
Hit http://ftp.debian.org jessie/contrib Translation-en                                                    
Hit http://ftp.debian.org jessie/main Translation-en                                                                               
Hit http://ftp.debian.org jessie/non-free Translation-en                                                                           
Hit http://security.debian.org jessie/updates/non-free Translation-en                                      
Ign http://repo-dodslaser.rhcloud.com wheezy/main Translation-en
Ign http://apt.osmc.tv jessie/main Translation-en
Fetched 4561 B in 23s (197 B/s)                                                                                                                     
Reading package lists... Done
root@osmc:/home/osmc# apt-get install moonlight-osmc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  moonlight-osmc
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 3972 B of archives.
After this operation, 43.0 kB of additional disk space will be used.
Get:1 http://repo-dodslaser.rhcloud.com/ wheezy/main moonlight-osmc all 0.2.3-1 [3972 B]
Fetched 3972 B in 0s (8421 B/s)    
Selecting previously unselected package moonlight-osmc.
(Reading database ... 30937 files and directories currently installed.)
Preparing to unpack .../moonlight-osmc_0.2.3-1_all.deb ...
Unpacking moonlight-osmc (0.2.3-1) ...
Setting up moonlight-osmc (0.2.3-1) ...
Generating configuration file...
Enter the desired streaming resolution (1080 or 720) [1080]:
1080         
Enter the IP of the streaming PC:
<redacted>
Enter any additional arguments for moonlight:

Works just fine here


#158

found the issue there needs to be an additional line in the moonlight.list file

deb http://archive.itimmer.nl/raspbian/moonlight jessie main

gonna add it to the guide although this repo cant be authenticated so you will get a question if you want to install the packages anyways


#159

Don’t use my repo (the rhcloud one). It is outdated. Use the package from github instead.


#160

so just irtimmer package ?


#161

Yes.


#162

@dodslaser @Toast Thank you! I’ll try with the new repo.


#163

added luna to the howto as an alternative to the one me and dodslazer is working on


Can I install other Programs, and when how?
#164

@Toast It’s ok now with your updated guide but can’t run Moonlight Launcher:
ERROR:Package moonlight-osmc is not installed

Luna is working and paired with Geforce Experience but can’t start to play a game:

ERROR: "Control 61 in window 10147 has been asked to focus, but it can’t"
WARNING: "CreateLoader - unsupported protocol(plugin) in plugin://script.luna/games/folder.jpg"
WARNING: "CreateLoader - unsupported protocol(plugin) in plugin://script.luna/games/launch/GameName/folder.jpg"
etc…