[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

have you tried pairing from within OSMC? That’s how I paired mine.

this earlier post from me may also help steer you to some success. Although its not really about the initial pairing but the steps that follow.

Yes, I was able to pair the controller, but still emulationstation says ‘No gamepad detected’.

When I click on your link I get a message that the topic was either removed or is under moderation. What do I have to do from here

Steps so far: Boot Raspberry Pi -> MyOSMC -> Pair Controller -> Launcher AddOn for Retrosmc -> No gamepad detected

Not sure why the link broke. try this:
http://forum.8bitdo.com/thread-475-1-1.html

Thanks jboy! The udev rules did the trick. Now I just need to figure out how to configure the controller in the various emulators. It seems to work in emulationstation itself, but I wasn’t able to play any of the port games with it.

Done that! thanks… just have to look for the UI Cancel button…

Happy holidays!

Hi mcobit, I would like to share with you all some of my findings. I hope they will be somehow useful to you
0. At start I would like to make a note that I have bluetooth audio streaming enabled → [TESTING] Bluetooth audio streaming (A2DP) - #145 by Dilligaf

  1. you have a small typo in your installation script - line 120.
    wget --no-check-certificate -w 4 -O /home/osmc/RetroPie/scripts/retropie_watchdog.sh.1 https://raw.githubusercontent.com/mcobit/retrosmc/**´**master/scripts/retropie_watchdog.sh
  2. As I wrote earlier amixer set PCM 100 command doesn’t work for me. This one however does amixer set 'Master',0 100%
  3. I’ve encountered also some issues with pulseaudio, especially when it is running (confirmed via ps -A)
    a) when I go to retropie-setup script and go to audio options (menu 300 Configure audio settings) whatever option I choose I got na ERROR message. Options from 1 to 3 give me “ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied. amixer: Control default open error: Connection refused
    and option 4 (mixer) gives me “ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied. cannot open mixer: Connection refused”.
    BUT when I kill pulseaudio, this menu seems to be working fine.
    b) if pulseaudio is killed, it is executed automatically again together with launching emulator. This is causing that emulator is stuck on black screen. In es_log file I can see “lvl2: req sound [basic.launch]/ lvl2: (missing)”. However once pulseaudio is killed again, emulator continue to load and game can be played
    c) for instance in GBA I can hear clear music from games :). Unfortunately in SNES not
    d) when I quit emualtor and go back to ES, suddenly sounds when changing options in ES can be heard. Once pulseaudio is killed from SSH, silence is back.

in general, there are huge issues with pulseaudio. Whenever emulator freezes, kill pulseaudio solves the issue, game can be loaded and played

I hope the above findings will help you in solving issues reltae to sound :slight_smile:

Thanks for this report. Unfortunately this is a pretty special usecase and I am not even sure if a normal RetroPie distro will handle pulseaudio well.
If it uses it as default sink and has problems with it I can only suggest to disable or uninstall it for now.
Also I am not able to test this myself right now as I don’t have a bluetooth audioplayer.

The alsamixer command works for me but that is only using the internal soundcard of the pi.

I understand that. I’m just curious if other users have the same issues as me.
Anyway I will describe my issues in the topic mentioned earlier as well.

thanks :slight_smile:

fyi, I don’t know maybe it is a placebo effect, but because of curiosity and some minor issues, after retropie instalation I had “updated” retroarch, emulationstation, sdl1 and sdl2 from sources and now despite the issue with pulsseaudio, music and gameplay seems to be much better.

Dear Friends,

I would ask if those bluetooth controller that works with Android phones and tablets will works on Retrosmc?
I have a bluetooth dongle working on OSMC, even i use my bluetooth headset without problems…

Not sure as it depends on the support in the os and controller type. When you try, let us know if it works.

Be sure to completely remove your ~/RetroPie folder before launching install-retrosmc.sh.

Hi all,
was anybody successful to run one of the PSP emulators in Retrosmc?

None of the Roms work with any of the two emulators for me (PPSSPP and LR-PPSSPP), despite they are on the RetroPie Wiki compatibility listed of running…

I am using the RetroSMC version installed with script 0.007. Other emulators work fine (PSX, all N64 emulators).

Reinstalling the PPSSPP emulator via the Retropie menu did not change anything.

Two Runcommand logs below, one for PPSSPP and one for LR-PPSSPP:


PPSSPP Error runcommand log:

40:29:319 Core/Config.cpp:907 I[LOAD]: Loading controller config: /home/osmc/.config/ppsspp/PSP/SYSTEM/controls.ini
e[0me[91m40:29:319 Core/Config.cpp:912 E[LOAD]: Failed to read /home/osmc/.config/ppsspp/PSP/SYSTEM/controls.ini. Setting controller config to default.
e[0mpure virtual method called
terminate called without an active exception
/opt/retropie/supplementary/runcommand/runcommand.sh: line 691: 17390 Aborted /opt/retropie/emulators/ppsspp/PPSSPPSDL “/home/osmc/RetroPie/roms/psp/lfc-lumi.iso”


Libreto PPSSPP Error Log:

glGetError 0x500
pure virtual method called
terminate called without an active exception
/opt/retropie/supplementary/runcommand/runcommand.sh: line 691: 16330 Aborted /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-ppsspp/ppsspp_libretro.so --config /opt/retropie/configs/psp/retroarch.cfg “/home/osmc/RetroPie/roms/psp/ggl-gtalcsv3e.iso” --appendconfig /tmp/retroarch.cfg

Seems that this is also a Libretto Problem. Also the Libretto Emulator for N64 has the same issue. It worked under the chroot environment (install script 006) but not with install script 007. Has anybody else the same issues?

N64 works for me. Do you run hyperion by any chance?

Is this log from runcommand.log?
Also do you have a log for n64 too?

I must say … I’m quite pleased :grinning:

Since I was still running with the previous version 0.006, I was a bit hesitant …
Ran the setup like mentioned on a new system … it took ages I must say … but well … a lot of stuff to install off course :wink:
I saw some errors about libsdl1 and libsdl2 like mentioned here before.

By accident I ran the install again … ahhh well … lets see if it installs libsdl1/2 now … and it did!
Like mentioned before … again it took ages :stuck_out_tongue:

When that was finished I immediately tried the ps3 install/pair … it installed … sweet :blush:
The pairing worked as well, but I saw in the log … no bluetooth … forgot to enable Bluetooth :sweat_smile:
I pressed the PS button and it connected … started RetroPie and saw that it was detected!
Looks like my install guide for the PS3 controllers is no longer needed :ok_hand:

Like mentioned before … quite pleased :+1:

Hello, i have installed latest retrosmc and all it’s ok but i have a problem.
When i install the addon script can’t appear il PROGRAMM ADDON…
why ?
I have re-ttyed 3 time…
nothing.
ThanX

Is there any error shown while installing it?
Scroll up after selecting the addon install to see the output and paste it here or to pastebin.

no error…

Didn’t get Launcher addon to install either, said “Addon installed.” but nothing new in Kodi-interface.
Removed it and tried again, just “My OSMC” under program menu in Kodi.

Tried staring it from ssh and it worked like a charm, just have to reconfigure the Gamepad I used.

Please scroll up one or two screens more. I’ll have a look, too when I get home.