[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

retrosmc beta 0.007

I got something for the brave who want to test it:

Disclaimer and other useful information. Read BEFORE installing!

First things first: I am NOT responsible if this does any harm to your system!

  • I suggest only to install this on a system that the old installer wasn’t run on already.

  • You should have at least 2 GB of free space on your sdcard.

  • If you update from a previous version, be sure to save your configfiles if you altered them, also Roms and Bios files

  • Please report bugs and don’t expect everything to work.

  • This is now a full RetroPie installation based on latest github version, all scripts and files should be present

  • This will install to your base system as all dependency problems should be solved by now.

  • You will not be able to simply uninstall this anymore, but it should not harm your system.

  • This will only work on a Raspberry Pi 1, 2 or 3! NOT on the Vero

  • if you need to edit configurationfiles manually: You can find them in the normal retropie path now: /opt/retropie

  • Syncing roms from a USB Stick will not work like it does in the retropie image!
    You need to copy them via Kodis filemanager, samba, ftp or ssh.


If you want to update an older installation, please uninstall the old version first via the script:


Then delete the old installscript:

rm /home/osmc/install-retrosmc.sh

Then follow the instructions below.

SSH into your osmc installation.

Download the installation script to your osmc home directory:

cd /home/osmc
wget https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh

Make it executable by running:

chmod +x install-retrosmc.sh

As Emulationstation needs to be built at install, you probably want to run the following commands, as the RAM on the RPIs might not be sufficient:

sudo touch /enable_swap sudo reboot

After reboot ssh in again and run the installscript:


You will see a pretty selfexplanatory menu.

Choose what you want to do and wait for a while.

If you choose to install retrosmc, be sure to select “Basic install” when the RetroPie-Setup script pops up and press enter.

After the RetroPie-Setup script finished the installation and you are back at the main RetroPie menu, choose “Exit”!

It is normal, that fbi and omxplayer cannot be installed.
They would install the retropie splashscreen if they would.

You can exit the menu by choosing Cancel at the bottom after every task.

If you have installed the Launcher Addon, you will find your shortcut in the Programaddons in kodi.

If you want to create a custom menuitem, here is a little symbol for you, that I hope, matches the OSMC skin style.

The link should contain the following command:


If you have problems with CEC, like you have KODI set to switch off the screen, when it is closed, you can set “CECFIX=1” without the quotemarks in /home/osmc/RetroPie/scripts/retrosmc-config.cfg

If you have HYPERION installed and the TV has problems switching modes with this, you can set “HYPERIONFIX=1” in /home/osmc/RetroPie/scripts/retrosmc-config.cfg

Have fun!


If you find any bugs, please report them in this thread!

Problems with running snes roms

  • Please update the lr-snes9x-next emulator with the retropie-setup script or choose a different snes emulator.

Problems when switching from kodi to retrosmc

  • Try to delete /home/osmc/RetroPie/scripts/video.sh and try again

Problems with controller configuration

  • Now really fixed in alpha 0.005
    (Unfortunately we need to reset your configfiles for this update)

Configurationfiles are overwritten by a reinstallation/update

  • Should be fixed in alpha 0.003

Preconfigured es_input.cfg should be removed for new setups.

  • Should be fixed in alpha 0.003

Because of a problem with the emulationstationscript, there could be no sound.

  • Should be fixed with alpha 0.002


alpha 0.001

  • First release

alpha 0.002

  • Added ScummVM to the emulators
  • Used symlinks for libs to save sdcard space
  • Optional installation of jcnventura’s addon to start emulationstation from Kodi (Thanks a lot!)
  • Updated all emulators and emulationstation to latest RetroPie version

alpha 0.003

  • backing up and restoring configfiles when updating
  • automatic update ability for the script (you still need to download the script for alpha 0.003 manually)
  • Not shipping default es_input.cfg file anymore

alpha 0.005

  • Really fixed the controllerconfigurationissues now
    This update will reset your configfiles though

alpha 0.006

  • Completely new approach with a chroot environment
  • Now this is a full RetroPie installation
  • Option to install it on any linux filesystem (nfs-share, usb-stick etc.)
  • RPI 1 support added

beta 0.007

  • Based on upstream RetroPie again and installs directly into the system
  • No chroot needed anymore
  • Old installations need to be uninstalled first!


  • RetroPie (Took some scripts and binaries from the RetroPie project - You guys rock!)

  • OSMC (Our beloved platform this is running on - Keep up the good work!)

  • jcnventura for the launcher addon - Just works :slight_smile: )

  • Thanks to all testers!


For updating from .001 to .002, we can just redownload the install script, or should it work when we run the same install script we got with the first download?

1 Like

For now, delete the old installscript and redownload.

Edit: Added this to the first post.

Hi and Thanks for the script, it worked nicely :smile:
You should remove the file /.emulationstation/es_input.cfg in order to make the system ask for a new controller values
I’m still fighting to configure ma PS controller for pacman but it’s a start :smiley:

Thanks so much for this! I was able to install and run with out too much trouble.

When I tried to make a shortcut on my home menu to run the addon, it would launch EmulationStation rather than create the shortcut. With a small amount of troubleshooting and problem-solving, I opened the addon directory from an SSH connection and renamed addon.py to default.py. Afterwards, I was able to create the home menu shortcut. This might be a nice tweak to make it easier to setup for others.

Another request that I wish I could resolve myself would be an icon the matches the OSMC style for the home menu shortcut. This is another small touch that would be nice. I’d even help out if I knew the first thing about making icons.

I second michael’s suggestion of removing es_input.cfg to force the configuration on first boot.

I love the direction this is moving in and only wish I could help out more!

1 Like

I also love the way this thing is moving. Amazing up to now and i guess as more emulators gets in things will be much more exiting.

Congrats and cudos.

As for my quote. Since you added scummvm and i have some files that are quite big is there anyway to have those files in external harddrive and somehow symlink them to .emulationstation\gamelists\scummvm?

Thanks in advance.

Is there anything changed to the menu link? I wouldnt add it automaticly cause it destroys my structure the last time, so i added it manually.

For upcomming updates it will be nice if files like the input ones wouldnt be overwritten. Cause there is not only the es_input.cfg overwritten. Also de retroarch.cfg in /opt/retropie/configs/all will be overwritten. Hard to handle but hopefully you will find a way around it.

It changed, so that no menulink is created with the script. The script can now install an Addon, that launches Emulationstation like the shortcut before, but it will be listed under Program Addons with a pretty picture and all.
You can add that to the homescreen or to your favorites.
If you already have a shortcut created manually, you can keep using it of course as the position of the scripts did not change.

For the configfiles:
It would be helpful if somebody could come up with a list of all configfiles, that would be modified frequently.
I can exclude those from the update procedure then if they already exist.

Of course you can just symlink a directory or file to your external Harddisk, but the Harddisk has to be formatted with a filesystem, that can use those links (I think), like any linux filesystem.
Fat32 or NTFS might not work.

I myself linked some romfolders to my NAS, that has a mounted folder in the filesystem via NFS.

I made a litte symbol in the style of the other icons from the OSMC skin.
Attached here. You can use it for the menu if you like.

Edit: Added this to the first post.


This would be everything in “/opt/retropie/configs/” and everything in “~/.emulationstation/”

I dont know what happens to “~/RetroPie/roms/”, if it deletes saved roms. I had installed an softlink to my server where all the roms are stored. The softlink was deleted, but this has no effect to the files in there. In “~/RetroPie/BIOS/” nothing changed.

There are also config files in “/opt/retropie/emulators/retroarch” where you could configure your controller settings.

Thanks for that.
I will not ship the .emulationstation and the default controller configs with the next update.

They should be created anyway on first launch and not be overwritten if they already exist then.

I will backup and restore the /opt/retropie/configs directory with an update though.

As there are no roms in my installationfile, it will not overwrite any roms you put in after installation anyway.
The softlink (if you are using such a configuration) needs to be recreated after update I’m afraid, as there is no way tar could know what to do with it.

Updated first post for alpha 0.003.

New installations will not get a default es_input.cfg file and you can now update without loosing changes to configurationfiles in /opt/retropie/configs or /opt/retropie/emulators/retropie/configs.

Be sure to delete the old install-retrosmc.sh script before starting over the installation.

There will be an automated update procedure in the future.

Integrated an update functionality for the alph 0.003 script. Please redownload it one last time to get it.
From then on it will search for new updates itself.

Thanks for this great add on.

My wired xbox360 controller was recognised by retroarch without any set up, which was a pleasant surprise.

I set up that controller with emulation station also, using the emulation station menu. However, after exiting emulation station and going back in again the set up seems to have been lost.

Can someone tell me what I am doing wrong.


Are there any errors in /home/osmc/.emulationstation/es_log.txt ?

Somebody here,

who successfully connected XBOX 360 Wireless Controllers
and could help?
There are so many tutorials, but every i have found results in problem, w/o some solutions.

So, somebody could provide a link or some help for a working emulationstation
with those wireless xbox controllers?!

kind regards,

I think I have found and fixed a bug with the inputmapping of emulationstation.
RetroPie adds some stuff to the es_input.cfg file for mapping controls to retroarch. Need to fix the file and some paths in the inputconfiguration script itself.

Will fix it for the next version.

Maybe try to check if there is a difference in the config files, if so rename the new config to .new?
That is how a lot of Linux packages work

Benefit is that people can merge them with their old configs themself, if needed.

will do something like that.
But the next release will most probably overwrite the old es_input configfile for consistency.

Only thing you have to do is reconfigure your joypad. Don’t think this will be a dealbreaker for anyone.

This is an alpha release, remember?
Things are expected to break when new features are added.