[HowTo] Installing RetroPie alongside OSMC RC (the easy way)


If you have a PI 2 and want to test a new and safer way, please see this post:

Old post for reference and documentation:


I tried a lot of stuff to get RetroPie installed on OSMC on a Pi 2 as it is using Debian Jessie from main armhf repo, not Raspbian.

I made a script, that is able to install everything by using Raspbian packages where needed.

Also it will update some stuff to make it easy for you to add a shortcut to the KODI menu that will stop KODI and start Emulationstation. After you quit out of Emulationstation, KODI is started again.

It may be rough around the edges, but it worked for me on a fresh install of OSMC RC.

Here is how you use it:

Ssh into the pi or get on a commandline as user osmc. I only tested this on PI 2. It might work on the 1 but I am not sure.

You need to stop Kodi before running emulationstation as the input will be grabbed by kodi otherwise.

Note: Everything you do with this is on your own risk!

On a shell go to the osmc home directory:

cd /home/osmc

Download the script:

link removed

Run the script:


Wait a long time and pray.

If you see the dialog of the RetroPie-Setup script, choose Binary installation!!!

If you see it again, ignore uninstallable packages and select cancel afterwards. The rest of the script will continue.

If you want a launcher in KODI, you have to setup a custom menu shortcut with “System.Exec(/home/osmc/retropie.sh)”. The custom scripts should already be in place.

You can create the shortcut from the script now.

If you exit emulationstation when you started from the script, you should be back in KODI again.

Good luck!

1.4 - From now on, the script (from version 1.4 upwards) will update itself with every run.

1.13 - It has a nice dialog frontend now.

1.15 - (hopefully) fixed dependency problems with apt-get

2.06 - New way to handle dependencies, no unneeded dev packages will be installed
Should also be safe for Pi 1 users as it restores previous sources.list

2.09 - Fixed automatic menu shortcut creation and some stuff that could cause the script to hang also added the raspbian repository key to get access.

Please test and report any problems you find.


this might seem like an idiot thing to ask, but I am trying to find where I place the “system.exec(/home…” line for a custom menu shortcut. where do I type it in? or do i do it from command line?

Please read this before you mess something up:

The menushortcut can be made in the skinsettings.

Can’t find it in the Confluence skin, too.
It works in OSMC skin and in a lot of others.

Maybe someone else can help?

edit: This seems to have the files needed to edit at least you should put the command instead of Activate.Window…

The file in question could be:

so before i figure out that confluence custom menu thing, i just want to note that i just played quake 3 arena (one of my all time favorite fps’s) using my 3rd party xbox 360 afterglow controller. it mapped really easily, which retropie never did before. I’m blown away here! that was amazing! time to load the roms!!

That’s great!

Good to hear that it works for others, too.

For the retroarch controls you might need to setup your controller first by running the RetroPie-Setup script again from commandline and running “register retroarch controller” from it.

It should be the same procedure like with normal RetroPie then.

confirmed that, with a sweet game of megaman X on snes! SO good. Couldn’t have been easier.

@mcobit - On line 22 of the mediacenter script, you have an extra “sudo”. Is that supposed to be there? I’m assuming not.

just used the script, all seemed to go well, except there is no retropie.sh file at /home/osmc/retropie.sh?

Have i missed a step?

*edit, in the retropie setup certain options try and install something everytime. says
Could not install package(s): mc.
Could not install package(s): fbi.

maybe this is the issue?

*edit 2, re ran the script, canceld instead of installed binarys and it fixed anything that was missing so nvm!

Those missing packages are not in the repositories of raspbian or debian. They should not keep retropie from working though.
I might try to compile them myself and add them manually later.

I guess you rebooted instead of canceling out of the RetroPie-Setup script.
This is the only human interaction in the process. Probably I could try to start the needed scriptparts automatically so this cannot happen.

Thanks for spotting.
I’ll change that but it shouldn’t matter right now.

Amazing work mcobit, i need to test it but I modified the skin maximinimalism to show me the game menu and launch the retropie.sh and works like a charm.
I’ll try to play some game later :slight_smile:

Probably a stupid question, but how can I stop Kodi? Tried some commands found on google but non of them work.

sudo initctl stop kodi
initctl: command not found

OSMC is using systemd;
Stop Kodi: sudo systemctl stop mediacenter
Start Kodi: sudo systemctl start mediacenter

Oh. Seems to work with service … stop though. Will change that then.

I must be the unluckiest guy in the world…
First of all i run the emulator and it says no systems were found.
I am pretty sure everthing went fine with the installation…i selected binary then in the end i also got the:
Could not install package(s): mc.
but i re-executed the script then selected cancel.

I even tried manually from the script to install mame for example…same thing.

Also the script uninstalls my vnc server dependencies :confused:

Any input please.?

You installed and ran it as user osmc right?
That is important. You do not need to reexecute anything as long as it ran through and you selected cancel.

Of course it can mess with some packages. Thats why I would recommend to install it before you install anytging else.

Did you run emulationstation from KODI? Or from commandline?

from console, but i did do it from kodi as well with the Advanced Launcher addon to execute the .sh file.
Now that you mention it…i think i installed the script under root lol…
I’ll be restoring my backup image and try again :smile:

You need to be in /home/osmc when you start the script.

You can have a look into /root directory. I guess it installed the stuff there and thinks your normal user n

Can i install individual emulators instead of the 1st choice ? Just to make sure i mean that it works on my setup rather than wait for it do get all the emulators.