xbox360 controller works in kodi,emustation but not in retroarch

I’m new in the forum and hope to find some help regarding my controller issue.

I’ve just installed RetroPie on my OSMC RaspPi2 following the tutorial on this forum ( [HowTo] Installing RetroPie alongside OSMC RC (the easy way) )

Went quite well and I can now launch emulationstation from kodi and getting warped back when emulationstation quits works like a charm.

I can even use my controllers in emu-station and I can configure them in the “RetroPi” menu where it saves the configuration I enter.

However, once I launch a game in retroarch I am getting no reaction whatsoever to the controller – it is as if it didn’t exist.

I have tried a bunch of things now for two days and none have worked. The route that looked most promising for a while was killing the xboxdrv process that is loading with the xbmc.ini adapted to kodi and starting a clean xboxdrv process as according to retropie’s “how to xboxdrv”… but nothing there either.

Relying on your help - any ideas/input on how to solve this? Much appreciated!

Thanks in advance!

did you ever get this to work?

Well… kind of. I am not using the controllers to control kodi anymore but using my phone with kodi remote instead. So I can now configure them to work as intended with emulationstation instead.

The big issue was that I wanted them to work with either which apparently was a lot to ask :wink: