Retro OSMC Android controll

Hi there,

i’ve tried to get retro OSMC connected with my android device via this software https://github.com/miroof/node-virtual-gamepads

I first got there via this page.

Unfortuantely I haven’t been succesful.
What I’ve tried is

  1. reinstall retroosmc ([HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC)
  2. install node.js via Installing Node.js via package manager | Node.js
  3. install virtual gamepads via https://github.com/miroof/node-virtual-gamepads
    unfortunately I get an errormessage when installing.

Error 1 make: Leaving directory '/opt/retrosmc/home/pi/RetroPie/roms/node-virtual-gamepads/node_modules/ioctl/build' gyp ERR! build error gyp ERR! stack Error:makefailed with exit code: 2 gyp ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:270:23) gyp ERR! stack at emitTwo (events.js:87:13) gyp ERR! stack at ChildProcess.emit (events.js:172:7) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12) gyp ERR! System Linux 4.2.3-2-osmc gyp ERR! command "/usr/bin/nodejs" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd /opt/retrosmc/home/pi/RetroPie/roms/node-virtual-gamepads/node_modules/ioctl gyp ERR! node -v v4.2.2 gyp ERR! node-gyp -v v3.0.3 gyp ERR! not ok
anybody any clue to how to solve this mistery? Would be nice to simply connect my phone and start playing…

sudo before

btw performance on those virtual controls is horrible ive tested myself its better to get a cheap xbox controller or ps4 controller

1 Like