Problem installing Retrosmc

I have been following this [HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

I have OSMC installed on my Pi and I can log into it through Putty but when I comes to this step -

wget https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh

It fails and I get this error
GnuTLS: A TLS fatal alert has been received. GnuTLS: received alert [0]: Close notify.
Unable to establish SSL connection.

Can anyone help? Thanks.

1 Like

Is osmc updated completely?
Also your firewall/router could be blocking encrypted connections.

1 Like

Thanks for the reply.

I have the latest version of OSMC 2015-10-1. I tried to manually update but I already had it.

I turned off Windows firewall and my router firewall and tried again but no luck. Although it lets me use this command and download a different file
wget -O /dev/null http://speedtest.wdc01.softlayer.com/downloads/test10.zip (but that also works with both firewalls on)

osmc@osmc:~$ wget https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh
converted ‘https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh’ (ANSI_X3.4-1968) -> ‘https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh’ (UTF-8)
–2015-11-19 17:37:58-- https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 62.252.172.241
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|62.252.172.241|:443… connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.

There is definitely something wrong with either your OSMC installation or your internet connection on HTTPS connections.
As a workaround (but that might lead to issue later down the install) just change https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh to http://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh in the installer.

I tried what you suggested (just http) and it didn’t work. I am going to reinstall OSMC.

Working OK here:

osmc@rpi2:~$ wget https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh
converted 'https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh' (ANSI_X3.4-1968) -> 'https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh' (UTF-8)
--2015-11-21 10:51:18--  https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 23.235.43.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|23.235.43.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 12072 (12K) [text/plain]
Saving to: 'install-retrosmc.sh'

install-retrosmc.sh                     100%[==============================================================================>]  11.79K  --.-KB/s   in 0s

2015-11-21 10:51:18 (34.1 MB/s) - 'install-retrosmc.sh' saved [12072/12072]

Possibly a Github mirror problem. I would give it 6-12 hours then try again rather than wiping and reinstalling, it’s unlikely to be a problem with OSMC, more likely a server issue at one of the Github mirrors or a firewall problem.

(I notice that I’m redirected to a different mirror than you)

I have been trying again, I really want this on my Pi.

Last login: Wed Jan 13 13:15:05 2016 from 192.168.0.6
osmc@osmc:~$ wget https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh
converted ‘https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh’ (ANSI_X3.4-1968) -> ‘https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh’ (UTF-8)
–2016-01-13 13:21:23-- https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 62.252.172.241
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|62.252.172.241|:443… connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.

Still the same problem that I had before

Try wget -N https://raw.githubusercontent.com/mcobit/retrosmc/master/install-retrosmc.sh or sudo apt-get install ca-certificates and after that the wget again.

Sorry to re-open an old thread, but did you manage to find a solution, Hypnotic?

I am having the exact same issue and cannot figure out how to fix it! I’ve tried all the suggestions already listed here

Even if it is inconvenient, I’m thinking about moving the current installer away from github as that seems to be the main issue here.

1 Like

I am aware this is an old thread however, I also had this issue and my solution was to manually configure my IP address within osmc and use googles DNS settings rather than automatically obtaining them, dont ask me why but i always have issues with my isp’s DNS settings so opt for googles.

Hello I’m new to the forum I’ve installed this script on a Raspberry pi 3 and everything works fine except wifi. I can’t get retropie to scan for ssid’s or it won’t show the ipaddress even though it is connected. if i run the connect to network command i get this error:
iwegetid: command not found.
Could anybody please help me out?

You don’t need to connect to wifi in retropie. Just connect wifi in kodi and it will be available when starting retrosmc, too.

Edit: You are using OSMC with retrosmc, right? Not plain RetroPie?
If you use a retropie image, this would be the wrong forum.