[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

Hi.

I was wondering. I have Retrosmc working perfectly, from installing it from command line and SSH.

Is there any possibility it would work if I set up a shortcut to the install .sh script in OSMC? Likewise the RetroPie Configuration .sh script.

I have the Launcher addon working perfectly, just wondered if this was possible at all, either through a shortcut or a bash script, Advanced Launcher, or any other way.

That is not easily possible and will not really save any time as the procedure would be to shut down kodi and bring up the commandprompt to show the menu.
Might be easier just to enter the menus from emulationstation.

No problem i get that, but is it possible? Ive tried through Advanced Launcher and that doesnt seem to work, nor does it want to work through the Shortcut.

Have i configured something wrong somewhere?

As said, you would need to use a modified version of my retropie script to shut down kodi and start the menus on commandline.
As long as kodi runs, it will take focus.

is there one available? or what would the commands be so i can add them to try it out? Sorry im just desperate to get this working. As said, i have it working perfectly if i install from command line, but i just wanted to simplify it a little and have the user click a button in OSMC to install. The launcher is a fantastic element and all my kids love it! Thank you for what you do!

As said, it is not that easy.
To be more convenient, the install would need to be packaged as a deb package to be made available in the appstore. Or as a kodi addon.
This is not really possible in a clean way.
If you want to try, do it.
All my scripts are available at github.
You would need to launch the install-retrosmc.sh script with a method similar to the retropie.sh script from a shortcut in Kodi.

For the initial install without the need for ssh, you would need to package it as an addon or deb package.

Be aware, that you need to navigate on the commandline without a keyboard as most users won’t have one attached.

Good luck.

Hi,

First of all, thank you for this amazing tutorial ! It works great !!

However, I have trouble to configure the WiFi inside RetroPie … No network found … Am I the only one getting this issue ?

Thank you for your help,

Enjoy!

No need to configure wifi or other network settings in retropie.
If you are connected in osmc, thats all you need.

1 Like

Indeed thank you, I didn’t try … sorry

However, I tried to pair my PlayStation 3 controller but it didn’t work … when I remove the cable, the controller doesn’t sync with the raspberry. I search into the topic but I don’t really see answers. Could you help me ?

Unfortunately I cannot help you with that as i don’t have the hardware. There are multipüle threats and posts about this and I think someone has had a solution. Please use the forum search function.

Hi, thanks for the guide.
I followed entire guide but now i have a “little” problem:
when i launch retropie from direct add-on present in the programs of Kodi, the program starts but i only see retropie menu and configure gamepad, i can’t see any emulators on the screen.
Another thing, when i try to enter in retro-config (to modify partitions, international settings etc…) black screen appears and after a few seconds the system back to retropie configuration screen.

What could be happen? I mistake anything? i could forget to do something?

Thanks for all

Hello,

If you have not copied any roms to the reaspective folders, the menu will only show the retropie menu.
Copy roms to /home/osmc/RetroPie/roms/systemname/ to make the emulatormenues appear.

The black screen is because there is no raspiconfig in osmc.
Please DO NOT use retropie to manage any system settings. You might break your system!

Hi mcobit, thank you to reply so quickly.
I tried to copy MarioKart64.zip into /home/osmc/RetroPie/roms/n64 and reboot without results.
Now i’m on work, so i’m not sure if i copied into /RetroPie or /retropie.
I’m an amateur of osmc and retropie but i do not already understand one thing: after your guide to install retropie on osmc, is the system ready to play with anyt emulators? Just copy correct rom into correct folder?

Thanka a lot for your help

Normally it is “complete” with the standard emulators.
For more exotic ones, you have to download them manually via the retropie-setup script.

Edit: Try to unpack the zip and only putting the rom into the folder.

Sometimes the zips come packaged with other files that won’t let the emulator recognise the rom.
Depends on where you got it from. Also consider that some emulators might not be compatible with every rom format.
Please refer to the retropie documentation or the documentation of the emulator you want to use.

Why did you delete the post?
Does it work now?
What did you do to make it work? Might help others if you post your solution here.

I forgot the .cue files, that’s why i did not see any emulators.

Tested it with krypton but Kodi crashes if I try to open retrosmc
On the screen I can see “file not found” but I can not see the name of the file.

osmc@osmcwohn:~/RetroPie/scripts$ ./retropie.sh
chown: cannot access ‘/usr/bin/emulationstation’: No such file or directory
./retropie.sh: line 25: /usr/bin/emulationstation: Permission denied

the file is indeed missing.

We are not really there yet, but try to run the installer again and check for errors while installing.
If emulationstation is missing, that has nothing to do with the version of kodi.

Did the retroppie setup script pop up?

@mcobit Thanks for your great work!

I saw that mupen64plus-libretro now supports cheats, see christmas commits: see Github

Any idea how to use cheats (to fix mario kart multiplayer speed errors) frome here: Github cheats

This is what I get:

I press Enter then

Waiting some time an then