[HowTo] rtorrent instead of transmission (rewritten and tested)


sleep 60 add that :wink:


You should wait for the filesystem mount targets in systemd instead.


SSH into your device and do this:

sudo nano /etc/systemd/system/rtorrent.service

Under Description line add these two lines

After = remote-fs.target network-online.target
Wants = network-online.target

To save changes and exit: CTRL+x


Installed as per the sctipt above. It appears all went ok, but when I try to use the web interface (http://localhost/rutorrent) i get ‘file not found’ error in my browser. Any ideas how to fix this?


Since strethc upgrade i haven’t tested the script which was made for debian jessie.

The script devloper has gone for to Docker installation:

Here is a link where the developer, talks about it: https://github.com/Kerwood/Rtorrent-Auto-Install/issues/184


Many thanks for help. Has anyone managed to successfully deploy rutorrent on Vero4K with Docker option?

I managed to install Docker, following Duncan’s post here: Docker support

Then, finally following this guide https://github.com/Kerwood/Rtorrent-LXC I even managed to install the rtorrent+ allegedly rutorrent.

The problem is I am unable to launch webUI. I don’t even know what address should I use in my browser? Obviously htttp://my.vero4k.address displays only kodi web interface. I tried using different ports: 80, 8080, with no joy.

Oh, maybe this can help when I try to run rutorret the following error occurs:

root@osmc:/home/osmc# sudo docker start rutorrent
Error response from daemon: driver failed programming external connectivity on endpoint rutorrent (e7464d15e607426f43fa8f5c076dffb5b2a8320ac8d21de99aef5afa75016a5e): Error starting userland proxy: listen tcp bind: address already in use
Error: failed to start containers: rutorrent

If someone was able to tame rtorrent on vero 4k, please let me know how it was done;) all help much appreciated!:wink:


since i dont have it installed i dont know where to change port which eever webserver that comes with the docker package. What i have done, since stretch, is to use debians rtorrent and flood node.js server, was a bit to setup but works properly screened, both processes.

Edit: Read that it was apache, but there was some instructions here https://github.com/Kerwood/Rtorrent-LXC where you say 8181:80, which i guess is where you point the webserver to another port.


I didn’t understand half of your post… but;), see following errors I encountered ever since trying to get this working:

root@osmc:/home/osmc# sudo docker create --name=rutorrent
-v /home/docker/rutorrent/config:/config
-v /home/docker/rutorrent/downloads:/downloads
-e PGID=1001 -e PUID=1001
-e TZ=Europe/London
-p 80:84 -p 5000:5000
-p 51413:51413 -p 6881:6881/udp


Error response from daemon: Conflict. The container name >"/rutorrent" is already in use by container >“70607159724c23d31b6fb386545c5df7380a55bfba01bdd7ae2568e>4de2205cc”. You have to remove (or rename) that container to be >able to reuse that name.

I feel this is really simple to fix as both Docker and rtorrent/rutorrent ui appear to be installed with no errors.

It seem it is a configuration issue but then again, I’m a noob;)

I really want to get utorrent working as transmission has limited torrent management options.

Many thanks for help.


another stab in the dark 80:84, should be like 8192:80. then you should be able to connect to your web-ui with http://ip.of.your.osmc-device:8192, change to your lan ip:8192, if that doesn’t work try the otherway around, like 80:8192.

Never worked with docker contianers so i’m just guessing


You already have a Docker container called rutorrent


docker ps -a
docker stop …
docker rm …

docker run -d -p 6881:6881 nivepl rutorrent


Sam, much appreciated you joined the conversation.
So I get the following:

osmc@osmc:~$ sudo su
root@osmc:/home/osmc# docker ps -a
CONTAINER ID        IMAGE                   COMMAND                  CREATED             STATUS                     PORTS               NAMES
70607159724c        linuxserver/rutorrent   "/init"                  3 hours ago         Created                                        rutorrent
409371317bef        kerwood/rtorrent-lxc    "/startup.sh"            3 hours ago         Exited (1) 3 hours ago                         rtorrent
a7dec196251b        docker                  "docker-entrypoint.s…"   4 hours ago         Exited (125) 4 hours ago                       rtorrent1
2f6a2d1a7271        armhf/hello-world       "/hello"                 4 hours ago         Exited (0) 4 hours ago                         nervous_austin
root@osmc:/home/osmc# docker stop …
Error response from daemon: No such container: …
root@osmc:/home/osmc# docker rm …
Error: No such container: …
root@osmc:/home/osmc# docker run -d -p 6881:6881 nivepl rutorrent
Unable to find image 'nivepl:latest' locally
docker: Error response from daemon: pull access denied for nivepl, repository does not exist or may require 'docker login'.
See 'docker run --help'.


As far as I understand, “…” is container id of rutorrent.


Yes. It’s meant to be substituted.


So what now?


Well if you have trouble to understand the instructions given above there is not much to be done.
But let me try once more any hove

run docker ps -a to find out the Container ID of your rutorrent (in the above case it was 70607159724c

Run docker stop <CONTAINER ID> in above example docker stop 70607159724c
Run docker rm <CONTAINER ID> in above example docker rm 70607159724c
Run docker run -d -p 6881:6881 nivepl rutorrent


Even I had trouble getting the docker combo to work, but it didn’t. Installation doesn’t give me any error. ip/rutorrent/ loads the rutorrent interface but does not load rtorrent. I’m guessing could be due to apache2 or apache port error. It uses port 80. Earlier versions of kodi on osmc was on 8080, but i guess the newer ones are on 80. There could be other reasons too but i’m not sure.