[HowTo] Spotify-Connect support via Raspotify (LibreSpot)

I have no clue what this mess is with your preamp but it looks like if you go through the documentation I linked for librespot you should be able to find arguments that will change what audio device is being controlled and that should (I think) get you to where you wanted to be.

Hmm, I actually did not find that much in that documentation. I did not try PulseAudio, because I read that installing PulseAudio will destroy the sound in Kodi, which is not what I want.

I actually read about Spocon (GitHub - spocon/spocon: SpoCon - A Spotify Connect Client for Debian , Ubuntu and Raspberry Pi based on librespot-java) but I don’t know how to install in on Vero4K. add-apt-repository is missing and the Spocon-website lists only Ubuntu-repositories which I could manually add to /etc/apt/sources.list but which would not make sense on Debian.

Does anybody know if unofficial Spotify plugin for Kodi does work on Vero4K? (GitHub - kodi-community-addons/plugin.audio.spotify: Unofficial spotify plugin for Kodi)

I said “device”, not mixer. You said you got the argument to set the audio level but it did not change the actual volume. Perhaps your changing the volume on the analog output which is not the device your connect to?

Did I say that? Then I didn’t describe it well enough, sorry. When adding the argument to set the audio level it does change the actual volume correctly (since I added --enable-volume-normalisation as you recommended). My problem is that even with reduced volume I have distortions, which I do not have when playing music in Kodi (also with reduced volume).

I tried the --device option before. I tried 0 / 1 / 0,0 / 0,1 / 1,0 / 1,1 / 2,0 / 2,1 and the only working device is 0,1. On all other devices I get

ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
ERROR:librespot_playback::audio_backend::alsa: Alsa error PCM open -2
ERROR:librespot_playback::player: Could not start audio: Alsa error: PCM open failed


ERROR:librespot_playback::audio_backend::alsa: Alsa error PCM open -16
ERROR:librespot_playback::player: Could not start audio: Alsa error: PCM open failed

So I guess I have chosen the right device?

Perhaps you could changing it directly via alsamixer or amixer and see if you can find something that works there.

This guide for Vero 4K should be really updated, just ****** up some hours…
Yes you need raspotify v0.12.
Also if you add


to the Service entry in /lib/systemd/system/raspotify.service, the service will recover after it failed when you started to play something in Kodi.

1 Like

Dear, I have installed Raspotify as reported in this faq but as you can see on the following screenshot it is not available. Why? thanks a lot.

osmc@osmc:~$ systemctl status raspotify
 raspotify.service - Raspotify
   Loaded: loaded (/lib/systemd/system/raspotify.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2020-12-17 10:39:13 CET; 16min ago
  Process: 670 ExecStartPre=/bin/mkdir -m 0755 -p /var/cache/raspotify (code=exited, status=0/SUCCESS)
  Process: 671 ExecStartPre=/bin/chown raspotify:raspotify /var/cache/raspotify (code=exited, status=0/SUCCESS)
 Main PID: 672 (librespot)
   Memory: 788.0K
   CGroup: /system.slice/raspotify.service
           `-672 /usr/bin/librespot --name raspotify (osmc) --backend alsa --bitrate 160 --disable-audio-cache --enab

Dec 17 10:39:13 osmc systemd[1]: Starting Raspotify...
Dec 17 10:39:13 osmc systemd[1]: Started Raspotify.
Dec 17 10:39:13 osmc librespot[672]: [2020-12-17T09:39:13Z INFO  librespot] librespot (raspotify v0.14.0) 6aac8a6 (20
Dec 17 10:39:13 osmc librespot[672]: [2020-12-17T09:39:13Z WARN  libmdns] Failed to register IPv6 receiver: Os { code
lines 1-14/14 (END)

Hi, I have the same problem, I think after some latest version of OSMC raspotify stopped working. I have been trying to troubleshoot this problem for quite a long time (few months). I can get working librespot(rasberrypie spotify speaker) but I can’t get working raspotify. Raspotify works for librespot like a service what is started after system startup. If you can’t get raspotify working, same as me… I just use librespot and I need to start it manualy everytime I want get it working. With command like this librespot -n "Living room" -b 160. It would be great if they can fix it, but I found noone with similar problems, I guess not many ppl using OSMC with raspotify…dunno.

Hey pulham…

Just trying to search for my problem…
I had the exact same set up as you in early summer but for now the Spotify Addon does not work. Is yours still working…how?

Many thanks,


It still isn’t working. I have not found a solution.

Working from yesterday! Spotify - No sound - #7 by sam_nazarko
My solution was to re-install OSMC Vero 4k Jan 2020 build with latest 1.1.58 marcelveldt build. So far, so good!

Good luck!


I had the same issue some time ago. Now i‘m using airplay so i‘m not too up to date with that topic. For me was the solution to use version 0.12.0 from github.


Newest OSMC release is not working with 0.12, but with the latest 0.16 it’s totally fine, there is even a ±15sec forwarding.


Anyone has any experience with Matrix builds? I’ve upgraded last week and came to the discovery today that the service still seems to be running, however i can’t see the device on my phone anymore.

Works fine for me on matrix Rpi 4

actually got it running via the older tutorial:

thankfully i still have the appkey

Does anyone got this Raspotify package to work on the Vero 4K+ (Kodi Matrix, v19.3) ?

I’m very new to Kodi / OSMC, and I tried to follow the instructions in the first post of this thread.
I installed the Raspotify package (latest version, which is 0.31.3 as of this writing), and tried to connect from my Android phone’s Spotify app (Premium account), but it didn’t work; it did display a device named “Raspotify (osmc)” in the Spotify Connect devices list, but when I select it, the song stops and also it doesn’t actually connect to it. If I have the music stopped, it appears to actually connect to it (I get the green icon of connected device), but as soon as I try to play a song it instantly disconnects/pauses. So in short, I could not get anything to play via my Vero.

I also tried to follow the manual install instructions from the Raspotify GitHub repo - after first uninstalling (purging) the package installed as per this thread - but the outcome was the same as described above.

When checking the status of the Raspotify service, I got the following output:

osmc@osmc:~$  sudo systemctl status raspotify
* raspotify.service - Raspotify (Spotify Connect Client)
   Loaded: loaded (/lib/systemd/system/raspotify.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2021-12-05 13:12:31 EET; 3min 14s ago
     Docs: https://github.com/dtcooper/raspotify
 Main PID: 4872 (librespot)
    Tasks: 1 (limit: 1620)
   Memory: 668.0K
   CGroup: /system.slice/raspotify.service
           `-4872 /usr/bin/librespot --name Raspotify (osmc) --device-type speaker --backend alsa --bitrate 160 --disable-audio-cache --enable-volume-normalisation --volume-ctrl linear --initial-

Dec 05 13:12:31 osmc systemd[1]: Started Raspotify (Spotify Connect Client).
Dec 05 13:12:31 osmc librespot[4872]: [2021-12-05T11:12:31Z INFO  librespot] librespot 0.3.1 bbd575e (Built on 2021-11-26, Build ID: a6e0Ery3, Profile: release)
Dec 05 13:12:31 osmc librespot[4872]: [2021-12-05T11:12:31Z WARN  libmdns] Failed to register IPv6 receiver: Os { code: 19, kind: Uncategorized, message: "No such device" }

osmc@osmc:~$ apt list raspotify
Listing... Done
raspotify/unknown,now 0.31.3~librespot.v0.3.1-19-gbbd575e armhf [installed]

I’ve just revisited this way of running Spotify connect because it’s way better than the old way.

It is working for me now, I am on the Dev build btw.

I do have the same issue where it’s showing as Librespot(osmc) not appearing to use the config that i have in the config file.

They have completely rebuild since version 0.31.4 you should purge and reinstall.

config file has changed to /etc/raspotify/conf

see the Wiki for more options:

i had the same error message it’s now fixed with the update and updating config file.

1 Like

just dropping this here for if anyone else is expereing issues with Spotify:

Spotify connect skipping songs - Plugins - Volumio

update hosts file to reflect ap-gew4.spotify.com

has solved it for me.