[HowTo] YouTube - Work around 'daily limit exceeded', 'unknown kind' - Method 1

Next time. Attempted to log out of the YouTube plug-in. It wouldn’t let me. So I tried to delete it. But to do that, I had to also delete the Classic Movies plug-in. Then created the “blah” folder using Filezilla, And deleted the userdata/addon_data/plugin.video.youtube folder. Then reinstalled the plugin from the zip file found at. [quote=“geedee, post:1, topic:13368”]
And then, did the double log-in. The plug-in works now. I will try later tonight after a reboot and see if it’s permanent. (Hopefully better than my car brake problem.)

I think that the Youtube addon is not working anymore popping up this alert “project marked for deletion”; the issue seems that big g disable the API key of the addon; to fix it is very not easy process, but it worked for me following these steps (I did not uninstall it anyway as stated as first step) :
Anyone has a better solution?

Car brake problems!!:fearful: Hope you can get those resolved sooner than later bud!!

hopefully the youtube issue is also fixed

I have been following that thread closely and am waiting to see when big G pulls the plug on the current API.

One of my buddies ran into the same issue yesterday so I’ll be trying one of the these other methods to fix his system. If I can get it working I’ll document that as the next method!!

Last night I used the method explained in that kodi forum thread, which @dentaku65 refers to.

It worked for me, but it’s not simple.
I would assume that it’s the best option, since someone else won’t be using the same API key.

That thread has a link to a modified version of the addon, that evidently will occasionally require logging in and out. (to acquire a new API key from a pool)
For that reason, I figured that the custom API key method, while more complicated, is a better long term option.

Based on all the “tinkering” I have done with the “unique API key” method so far I find it to be a much more effective solution, but it is not an easy one. I think I already have 4 different docs written up and now of them looks simple and straightforward :frowning:

I will try and simplify the whole process and write up a doc on it, but I doubt I’ll be done with it in the next cpl of days. With work and life stuff … earliest I’d be able to provide a doc for testing and validation would be friday

I did this and is working; first uninstall YouTube Addon, if there are other addon dependencies unintall them all (I had to uninstall GoPro, Bin@ural and Music Box), then uninstall Youtube addon (if you try to uninstall the addon if there are some dependencies the system alerts you), then delete the userdata/addon_data of YouTube
rm -r .kodi/userdata/addon_data/plugin.video.youtube/
Download/install the Youtube addon of raspberryrabbit available here:

Github code here:

Reinstall your dependencies addons if any (you’ll have your untouched data back)
It works fine and you’re not obliged to sign-in to use it

I still do not understand why Kodi official repo do not use raspberryrabbit as Youtube addon



Umm… .kodi\userdata\addon_data is the addon settings directory, at least in OpenELEC, surely also in OSMC. Surely the zip contents should go into .kodi\addons\plugin.video.youtube instead?

Hmmm … Did I fat finger something here or did I screw this up??? Let me go back and revisit my notes …

I have been swamped (read in between the lines dumped on) at work these past few weeks. I am back now and will get back on this … using a PI3!!!

After struggling with this for a week or so I have realized this is a temp fix and not worth the hassel. I’ll be working on the API fix for this today and tomorrow as that is a better solution (even though it is more involved)

Tried this method last night, followed it to the letter. It allowed app functionality, aside from the one feature I was hoping would work.

When I go to “Browse Categories” and try to run “Recommended for You” I still get the “Unknown Kind” error.

Any ideas?

From what I remember you have to sign-out and then sign-in again to fix this error. You’ll have to authorize the app/plugin twice when you sign-in agin.

most everyone has stopped using this method as you have to sign-in every now and then to get a new api key from the pool.

I wrote up a another method, based on info gathered from other posts here and on other forums, where you create your own api key. It is a more involved process but since I went to that method I haven’t had to sign-out.

I’ll find that doc and post it over the weekend

I cleaned up the doc for the 2nd method and have posted it under the howto section.

Link to that article > Method-2

Thanks to you.
It’s now working fine.

Well, after a long time, I did download anc install Raspberry Rabbit’s plugin. However, I could not delete the previous plugin settings. Obviously, there’s no way to delete it from inside OSMC. I managed to log into OSMC through SSH, but it could not find the specified directory, listed in the OSMC File Manger as:


…but my SSH client reported back that the directory does not exist. Is there any better way to get that deleted? Thanks.


I am using OSMC on a Rasberry Pi3.
How do I log in to Youtube, I know this may sound a silly question but the browser supplied doesn’t let me log in and there seems to be no way of installing a proper browser.


Have you downloaded the latest Youtube addon? If so, there is an information, after You click Log In button, to go to www.youtube.com/activate on a computer, laptop or mobile and enter data that is shown on Your TV screen.

I never though of logging on using something else, as Homer Simpson would say “Doh”