I broke my ability to control my Vero 4K+ via infrared

Hello good people.

Long time use of my Vero 4K+, love it. Been controlling it sucessfully via a Harmony Elite for years.

Today I stupidly tried to pair my Bluetooth headphones. Went into MyOSMC, Bluetooth. It was buggy/laggy as it often is, but I’m fairly sure I enabled Bluetooth.

EDIT: The bluetooth page was super buggy, with some text overlaying other text, and super laggy/freezing. I’m not sure exactly WHAT I did within that page :frowning: I totally noobed it, should have just backed out without trying to blindly “enable bluetooth”.

Then the Vero froze. I waited several minutes… nothing.

Power cycled Vero, came back up… but no control via my Harmony remote. I have no idea where the original remote is.

I’m connected via Putty… what can I do?

Thanks in advance. :slight_smile:

Is/was it connected via Bluetooth?

Use bluetoothctl to pair.

I’m unsure… I think it controlled the Vero 4K+ via IR. Have never paired anything Bluetoothy in the past.

EDIT: I’m actually almost CERTAIN my Harmony remote was controlling the Vero 4K+ via infrared. But now it no workey. :frowning:

bluetoothctl just gives me:

agent registered

Try devices. If anything shows up type remove XX:XX:XX:XX:XX:XX for each of their addresses.

Then to connect anything, make it discoverable, then:

scan on
connect XX:XX:XX:XX:XX:XX

after “bluetoothctl” I then entered “devices”, and get “no default controller available”

Try power on.

i tried “power on”, got “command not found”

I fixed it!

Found my original RF remote, which worked once re-paired.

Navigated to MyOSMC then Network, Bluetooth, disabled, Bluetooth… didn’t help.

Checked Remotes, and disable RC6 was checked. I certainly didn’t choose to check that, but once unchecked… IR remote now works!

My guess is that when the Vero “froze” it was just video that was frozen, and that I must have accidentally “flailed in the dark” and turned off RC6.

1 Like

UPDATE: It’s actually a bug. I went back into MyOSMC > Network > Bluetooth and switched bluetooth back on.

IR remote stopped working. Used my RF remote, navigated back to remotes… disable RC6 was checked again!!!

IT’S A BUG! Someone tell Sam. :slight_smile:

It’s not clear to me: are you trying to use an IR remote or a Bluetooth remote? The two operate separately.


To be clear… I was trying to pair my bluetooth headphones. I have discovered that if I enable bluetooth, “disable RC6” is somehow also enabled. And that prevents my infrared remote from working.


This might be one for @anxdpanic to check out.