I can´t access internet with my Vero 4K+

I’m from Sweden so it’s probably a little language problem just hehe

I have a NAS server connected to Vero 4K and I plan to have movies and music on the disks.
But I want to be able to replace them via my computer.
But as it is now I can only read from the NAS from my computer.
It seems that the right to write does not exist.
Whether the error is in Vero or NAS I do not know.
Probably not in NAS as Vero can write to it.

NAS = Network Attached Storage
So if we understand the same a NAS never would be “connected” to a single device but to your network.
Or do you mean a USB disk that is directly connected to the Vero?

If it is a NAS how do you access from Vero, how from the Computer?

I have this:

And it’s connected directly to Vero.

Am I thinking wrong
Should I have NAS connected to the router and then map it to Vero?

That is not a NAS (no network) but a USB Raid system. So it is ok to directly connect it to the Vero and share from there.

So now need to figure out why can you not change the files from PC.

  1. How are you exactly connecting to the drive from the PC?
  2. Can you show the output of ls -lah /media on the Vero

osmc@kodi:~$ ls -lah /media
total 72K
drwxr-xr-x 6 root root 4.0K Mar 26 07:53 .
drwxr-xr-x 23 root root 4.0K Mar 25 13:02 …
drwxrwxrwx 1 osmc osmc 8.0K Mar 25 03:19 1TB
drwxrwxrwx 1 osmc osmc 4.0K Mar 24 14:33 H:
drwxrwxrwx 1 osmc osmc 12K Mar 20 23:29 MUSIK
-rw-r–r-- 1 root root 232 Nov 21 2017 README
drwxrwxrwx 1 osmc osmc 36K Mar 24 22:35 USB13

Ok and how do you access it from the PC?

Also maybe post ls -lah /media/1TB and lsblk -f output

osmc@kodi:~$ ls -lah /media/1TB
total 176K
drwxrwxrwx 1 osmc osmc 0 Mar 12 07:59 $RECYCLE.BIN
drwxrwxrwx 1 osmc osmc 0 Mar 12 07:38 - BACKUP -
drwxrwxrwx 1 osmc osmc 4.0K Mar 11 21:33 - BILDER -
drwxrwxrwx 1 osmc osmc 160K Mar 26 07:06 - MUSIK -
drwxrwxrwx 1 osmc osmc 8.0K Mar 25 03:19 .
drwxr-xr-x 6 root root 4.0K Mar 26 07:53 …
drwxrwxrwx 1 osmc osmc 0 Mar 14 07:58 System Volume Information
osmc@kodi:~$ lsblk -f
-sda1 ntfs USB13 68B2DF1BB2DEED16 /media/USB13 sdb -sdb1 ntfs 1TB AA1E02631E022941 /media/1TB
-sdc2 ntfs MUSIK E4D0F518D0F4F1A2 /media/MUSIK sdd -sdd1 ntfs H: 4AA402AAA4029899 /media/H:

Ok, so far looks good.
So the only open question that is still not answered:

through my network
PC -> Switch -> Vero


so in the way \\<IP-of-the-Vero>\share?
Assuming you are using osmc user and respective password to login?

When I´m writing this \IP-Vero\share I get “undentified faoult”

I´m accessing Kode trough Explorer and networkplaces “kodi”
When I´m opening that I have 2 maps… Music libary and Video Libary.

That is not accessing via Samba but via UPNP which is just a view of your Library not your files.

So let us first come back to a previous question, did you really installed the Samba Server on Vero?


Hello again :slight_smile:
I have now solved the problem by placing the ICY box on the computer and then mapping them up in Veron,
See if itis possible to play 4k movies through the network later.

Thank you for your help <3