I can´t access internet with my Vero 4K+

I have tried both DHCP and fixed IP.
When I try to use Wifi it finds no connection.
But I can access to Veron on my home network.
Kodi version 18.5

When you login via SSH what are the outputs of

route
ifconfig
ping 8.8.8.8
ping google.com

I´t seems to work but I can´t download anyting

You mean Addons?
Can you try to download something and the upload logs via grab-logs -A

What did you try to download to make it easier to find it in the logs?
Also as you can upload the logs it indicates Internet Access is not the problem.

1 Like

I missed that… I shall do it later… must work :frowning:

I think you need to be clearer about what exactly is the problem. In your first post, you wrote:

but you have provided test results for the wired connection – which appears to be working – and the log only shows a wired connection being used.

There are also two occurrences in the log of Kodi aborting, eg:

Mar 23 23:27:24 Kodi mediacenter[689]: /usr/bin/mediacenter: line 210: 807 Aborted sudo -u osmc MALLOC_MMAP_THRESHOLD_=8192 LIRC_SOCKET_PATH=/var/run/lirc/lircd $KODI --standalone -fs

so it’s unclear what we’re dealing with,

Sorry about that… it´s 2 problem I have :slight_smile:
Now…
wired connected and try to get the function “Skin Shortcuts” and get “installation failed”

https://paste.osmc.tv/ufuzoruril

Can you try from command line
wget http://download.osmc.tv/kodi/addons/leia/script.skinshortcuts/script.skinshortcuts-1.0.17.zip

osmc@Kodi:~$ --2020-03-25 12:15:26-- http://ftp.acc.umu.se/mirror/osmc.tv/osmc/download/kodi/addons/leia/script.skinshortcuts/script.skinshortcuts-1.0.17.zip
-bash: --2020-03-25: command not found
osmc@Kodi:~$ Resolving ftp.acc.umu.se (ftp.acc.umu.se)… 194.71.11.165, 194.71.11.173, 2001:6b0:19::173, …
-bash: syntax error near unexpected token (' osmc@Kodi:~$ Connecting to ftp.acc.umu.se (ftp.acc.umu.se)|194.71.11.165|:80... connected. -bash: syntax error near unexpected token (’
osmc@Kodi:~$ HTTP request sent, awaiting response… 200 OK
-bash: HTTP: command not found
osmc@Kodi:~$ Length: 496010 (484K) [application/zip]
-bash: syntax error near unexpected token `(’
osmc@Kodi:~$ Saving to: ‘script.skinshortcuts-1.0.17.zip’
-bash: Saving: command not found
osmc@Kodi:~$
osmc@Kodi:~$ script.skinshortcut 100%[===================>] 484.38K --.-KB/s in 0.07s
-bash: script.skinshortcut: command not found

Then I tryed tu install it from osmc zip arkiv and get “install failed”
https://paste.osmc.tv/imayujidih

Should I install with Putty ?
Wich command ?

This all looks fairly strange.
As you haven’t setup too much, may I suggest to do a fresh OSMC install?

how do I do that ?
Reset kodi on next reboot… ?

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

But maybe just once more confirm if the download from command line worked as it might jsut been copy/paste issues.

Now after doing a reinstallation it works :slight_smile:
Thank you very much: D

The only thing left now is to be able to distribute the hard drive from kodi to the network so that you can exchange and delete movies from a computer.
Right now I can only see the files.

Install Samba Server from App Store

Done that, but can only watch and start the movies from the computer.
I want to be able to delete and upload new movies via the computer

You should be able to do that. What happens if you do that?

I have a nas-server connected to Veron and I want to be able to exchange files on the disks.
Now I can just watch and play them through my computer.

If you have a NAS, why do you need to move the files back and forth on the Vero? I’m sorry but we aren’t really understanding what you are talking about and what watching and playing through your computer has to do with anything?