I can't get transmission to install

I am very new to LInux/ raspiberry pi. I have installed OSMC on to my Rasberry Pi 2 model B. I had transmission installed but when I would try to change settings using “sudo nano /etc/transmission/settings.json” i would just get a blank page. I uninstalled transmission with the hopes that reinstalling it would correct this issue. Now I can’t reinstall Transmission. I have tried installing through the app store in OSMC and via SSH terminal. I get “error installing: armv7-transmission-app-omsc (2.8.4-11)”.

What should I do? Please respond to me like I know nothing.

Did you perchance try and install Transmission via an alternative source (not the App Store first)? If so, what steps did you follow?


Here is where the OSMC installer puts the settings file

I manage to get transmission to install but wiping my SD card and starting over from scratch. Now my problem is my SSH terminal is running crazy slow. What can I do to fix that?

try also SSH from your Android mobile/tablet (VX Connectbot)
Slow terminal never experienced even when Pi was unresponsive to remote

Hallo Sam

I have the same problem and yes I did install Transmission from a different source. I installed it whit a apt-get install transmission-daemon command and I removed it with apt-get remove transmission-daemon. Now I can’t install armv7-transmission-app-osmc. In terminal I get

Unpacking armv7-transmission-app-osmc (2.8.4-11) ...
dpkg: error processing archive /var/cache/apt/archives/armv7-transmission-app-osmc_2.8.4-11_armhf.deb (--unpack):
 trying to overwrite '/usr/share/transmission/web/images/favicon.png', which is also in package transmission-common 2.84-0.2
dpkg-deb: error: subprocess paste was killed by signal (Prekinjen cevovod)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any suggestions on how to fix this problem? I really wouldn’t like to make a fresh install of osmc because of this.

Thank you

dpkg -l | grep transmission

apt-get remove --purge any packages listed

Then reinstall OSMC transmission with apt-get -f install

1 Like

Whoow that was fast! I’m trying it now… Thank you :slight_smile:

Worked like a charm. Thank you again :slight_smile:

Indeed, worked like a charm, i only signed up here just to say thanks to you for this tip