I can't install any program (no space) RPB 3

I can’t install transmission or anything else, because it says I have no free space on disk.
I am using the App Store to install transmission, or FTP, or SAMBA.
It has happened several times (every time).

I install OSMC in USB Pendrive mode (I run “osmc-installer.exe” and choose USB Stick mode; it writes without errors on the SDCard. After this, I launch the rasp with the SDCard and the Pendrive plugged, so OSMC can install the components it needs on the pendrive).

I tried deleting partitions, and re-allocating SDCard and Pendrive in FAT partitions, but always with the same result: No space to install new programs, althoug OSMC runs and plays movies…
By the way: my pendrive is two times faster than my SDCard.
If I install OSMC just on the SDCard, same problem arises, I can’t neither install anything.

After the installation I find this:

SDCARD:
hxxp://i.imgur.com/A1nOKBK.jpg

PENDRIVE (it is EMPTY):
hxxp://i.imgur.com/buzce7e.jpg

Both:
hXXp://i.imgur.com/REj4sLo.jpg

I am using the raspberry Pi 3 (I am newbie with the Rasp, and I’ve decided to embellish her with OSMC). I am newbie too with linux, so I can barely use SSH.
I am using a monitor and a bluethooth keyboard (both working well with OSMC).
I am trying with the two latest versions of OSMC.

Best regards

SSH into your box and provide logs with grab-logs -A

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

1 Like

osmc@osmc:~$ grab-logs -A
grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory
Logs successfully uploaded.
Logs available at http://paste.osmc.io/ihehogogaz

Ok, this looks like the last try you have done with an SD Card only install, or?
This would not work as your SD Card seems to be 1G only!
So if you want to do this you would need to choose the USB install in the installer. This will install the boot system on the SD Card and then during first boot on the Pi with the Pendrive installed it would then format the pendrive to install the root file system on it. After you have done that please post another log file.

Last comment even with a 2G pendrive you will not be able to do much. Also as you mentioned you installed transmission where are you going to write the files from transmission as they definitely will be bigger than 2G.

====================== Diskspace =================== qZy25Yas
Filesystem Size Used Avail Use% Mounted on
devtmpfs 362M 0 362M 0% /dev
tmpfs 367M 5.1M 362M 2% /run
/dev/mmcblk0p2 681M 609M 23M 97% /
tmpfs 367M 0 367M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 367M 0 367M 0% /sys/fs/cgroup
/dev/mmcblk0p1 240M 20M 220M 9% /boot
/dev/sda1 1.9G 0 1.9G 0% /media/PENDRIVE
tmpfs 74M 0 74M 0% /run/user/1000

---------------------- Diskspace END --------------- qZy25Yas

It seemed to me that it doesn’t do the USB install even if I chose it.

Transmission files are bigger than 2 GB??? :s
I tried too with SAMBA or with the FTP server, but no free space either.

Logs available at http://paste.osmc.io/awowiwogas

Ok the reason why it is not installing on the USB Stick we need to check.

But that you can not install any app in the current moment with only the small SD card is normal.
My comment with transmission was that any file that you plan to download will most likely be bigger than 2G.

1 Like

I will download torrents to an external HDD.

Even I am starting to think that it would be a good solution to use an external 3,5" HDD as OS drive.

If everything went fine and we can solve the problems, do you think I could use a 64 MB SDCard to boot?

I am going to try now with another pendrive.

Well using a bigger good quality card to boot (8G is minimum recommend) you would for sure be better off than any USB install.

I have tried a different pendrive (8 GB), and it doesn’t make the installation, even I can play videos I had on it (it is not formatted).

Maybe osmc installer doesn’t work properly, and it would be better if I “burn” the image manually on the SDCard?

****EDIT:
Between the Images I can’t find the one to make the installation on the pendrive. Does it exist or is it a work that must be done by the installer?

I have formatted my PC (1 year without formatting). And now it seems to work.
Pending further testing, solved.

Thanks @fzinken for your time :slightly_smiling:

Not sure if the installer works wrong. If you make several installations, the installer can choose wrong files. In my case it chooses files to make the installation on the SDCard instead of the files to make it on the Pendrive.

Maybe the problem was solved when I formatted the PC because the temporary files (downloaded and uncompressed files) were erased in this way, and the installer didn’t have to choose.

I keep testing.

Unfortunately what you say makes no sense.

There is no difference between the images for SD and USB installs - there is only one image. When you choose a USB install a preseed file is written to the SD card by the OSMC installer. This means on first boot in the Pi it knows to format a USB drive and install the main operating system there.

It sounds like you are just not selecting USB install correctly as nobody else has reported a problem like this.

The log file you provided earlier in the thread was clearly an SD card only install - and because it is a small SD card you were running out of room. Your USB drive was only being mounted as a media drive.

1 Like

Hi
I tried maybe dozens of times. Pendrive install only worked one time, after I formatted. Now it keeps not working for me.
I am using so a sdcard of a friend. But if you want any log, let me know.

You can see in the image up there how I chose the usb option to install, please.

Please run the the installer one more time and choosing USB install respectively. Than BEFORE inserting the card in the Pi, check on the SD Card the content of the file preseed.cfg and post them here. AFTER you then run the installation (including first step setup) on the PI (BEFORE installing any addon or APP), shutdown the PI re-insert the SD card in to pc and post ‘install.log’ file from the boot partition here.

Hi
I can’t find the “preseed.cfg” file.
This is all I got in the SDCard: