I cant install samba service form AppStore

This is my kodi log file:

I tried

sudo apt-get purge samba
rm -r /etc/samba

and install again

and other things but i cant install it.

Upload full logs.

Did you install Samba outside of App Store before? That will cause conflicts.


Yes i tried intall samba by
sudo apt-get install samba
but i removed it

full logs: http://paste.osmc.tv/ederigerow

Purge all dependencies of what samba brought in.

sudo apt-get purge samba
and waht more?

I brought RPi 2 days ago xD, im a little noob on this xD

Not sure off the top of my head.

Reinstallation will be easiest if you only got the device two days ago.

can i reinstall only OSMC?, i would like dont reinstall recalbox and raspbian

Check APT History log, and purge all dependencies of ‘samba’

If I install samba, it automatically installs other packages:

osmc@osmc:~$ sudo apt-get install samba --dry-run
Reading package lists... Done
Building dependency tree        
Reading state information... Done
The following extra packages will be installed:
  libasn1-8-heimdal libfile-copy-recursive-perl libhcrypto4-heimdal libhdb9-heimdal libheimbase1-heimdal libhx509-5-heimdal libkrb5-26-heimdal
  libroken18-heimdal libwind0-heimdal python-crypto python-dnspython python-ldb python-ntdb python-samba python-tdb samba-common-bin
  samba-dsdb-modules tdb-tools update-inetd

If you run sudo apt-get autoremove they should be removed if nothing else needs them.