I think my 4K has died

A couple of months ago I came downstairs to see my 4k with a red LED.

I ignored it until this week. I have bought a new power supply (same spec but from Amazon), tried connecting it to my laptop, but nothing.

When connected to the white USB, there was nothing at all. No LED and no detection by the laptop.

Any ideas or is it time to say goodbye?

Many thanks.

Edit: the connection from my laptop was USB C to USB A; read another thread on here that USBC won’t work. Have ordered a new USB A TO A cable.

What power supply did you try using?


Hi Sam,

It was this one - I could get it next day.


And you definitely got the 5V 2A one?


Okay, that’s a compatible PSU. I was concerned it might be 12V as there are a few options on that page.

Try the USB-A when it comes and let us know.

Will do :+1:

Hi Sam,

The USB-A cable has just arrived.

Connected to laptop and have a red LED - device recognised as ‘GX-CHIP’

This means that the eMMC is corrupted.
It may be possible to revive the device.

I suspect you experienced a power surge which may have damaged the device.

Okay, how do I go about reviving it?

I’ve seen mentioned a process elsewhere on here.

Many thanks.

Just flash with a image compatible for your device.
That means, create a bootable usb drive with the image for your device,
Connect this usb to the white usb connector on vero, and power up the device.


I have tried the suggestion from @kari0ca but no luck, unfortunately.

Reading some older similar threads, I have seen that there may be a guide to recovering from this situation. Please can you forward a copy to me?

Many thanks.

I will do so in a few minutes.

1 Like