I think my PSU may be crapping out...?


I got my Vero 4K + back in March 2019 and have been absolutely loving it since. It’s been rock solid, day after day after day.

So imagine my shock last evening when my unit simply switched off. No super high load, nothing fancy. I power cycled it a couple times, and nothing. I scrounged around for a USB A–>A cable to try powering from that, but no love. Then I tried powering via USB with an C–>A cable, and nothing.

I let the unit sit for a bit, staring at it, willing it revive. Got online and went through the forums here. Prayed a little. Tried to calm my wife.

And then I grabbed a junky power strip, plugged the Vero into that, and appeared to get a boot sequence. Hooked up my Ethernet and HDMI cables, and all was back to normal. We finished the program we were watching with no further trouble.

But now I’m wondering whether it might be best to replace this PSU. Am I living on borrowed time? I’ve made no other changes to my setup prior to this event, and the Vero has been plugged in to a high quality surge protector that services three other devices, none of which have had any trouble.

Thoughts? I hate to do a system reinstall if I don’t have to, but that wouldn’t be the end of the world, obviously.

Thanks. And Happy New Year!

If it didn’t boot at all with the USB A-A it might not be a PSU issue. It could be an issue with CPU cooling.
Anyway suggest to watch it and if unsure just get a backup PSU.

Some time agao @sam_nazarko provided some links how to order them within the osmc shop, see his post


Other way would be to get one somewhere else, specification: DC 5V, min. 2A, center positive, coaxial power connector male with OD 5.5mm and ID 2.1mm

1 Like


Did you have any power outage recently?


Not that I’m aware of, no.

No, I couldn’t find an A-A. I guess maybe this could be a heating issue, but I’d be surprised by that.

I’ve ordered a new PSU from the shop here and will just swap that in when it comes. Everything ran fine last night, but of course there’s a nagging worry now that I’m living on borrowed time. :grinning_face_with_smiling_eyes:

Still waiting on my new PSU but figured I’d see if I can diagnose this issue in the meantime. So I enabled debug logging and started playing a movie (streaming via ethernet from my media drive). Played for quite a while and then the screen went dark. Looked like it had shut down, but it wasn’t until I shut off the power to the unit that I got a notice on my TV that “it looks like OSMC is off.” I tried to SSH in prior to powering off, but the connection timed out.

So when I toggled the power, I got the initial red light for a second or two, then the blue OSMC splash screen…except the OSMC logo, which is usually in the middle of the display, was in the lower right corner of the TV. It displayed that way for a second or two, then went black. Never booted. If/when I can boot the unit again, I’ll see if I can grab the log file.



Just powered it on again and am stuck on solid red light; SSH unavailable.

–EDIT 2–

Didn’t catch when it happened, but the Vero eventually powered down. I wonder if this’ll even be captured in the logs if there’s no boot?

Sounds like what others reported on failing power supply.

You can find my old thread… both my Vero boxes PSU died days apart. I just ordered 2 from Amazon.

1 Like

“You can find my old thread… both my Vero boxes PSU died days apart.”

I did come across your thread when I was researching. That was pretty crazy! Do you recall which PSU you ordered from Amazon?

1 Like

Here @nicheplayer 5V 2A LED Power Supply 10W Power… https://www.amazon.com/dp/B0863J9RLW?ref=ppx_pop_mob_ap_share

This PSU has a wrong connector!

Required specification: DC 5V, min. 2A, center positive, coaxial power connector male with OD 5.5mm and ID 2.1mm

Do not use a charger as a replacement for the original power supply, as these often do not have a stable voltage.

1 Like

Ahh good to know. It’s worked for both of my Vero boxes. Could you post a link of the preferred PSU?

You can grab them here;


1 Like

Great news! My replacement PSU arrived yesterday.

Bad news? I can’t connect it to my Vero 4K+.

Looks like this one should work, @Adrian97c ?