I wonder if I have lost my library?

I just upgraded from XBMC. I followed the instructions to export my library from XBMC and chose single file. When I looked however, it was actually a directory structure. I did it again, with the same result, so I assumed all was well and did a fresh install.
Now, I find I have nothing to import (I scp’d the directory structure over)

Can I recover from this?


Do you still have the old database?

New versions of Kodi usually use different version numbers for the databases, so it may still be intact.

I have a full backup of the xbmc filesystem, so the answer is “probably”. Where will I find it and how can I tell what the version is?

Actually, I may have found it.
On the backup, and on the new install, I have ~/.osmc/userdata/Database and the backup has the same filenames as the live system. It has a few more; which I guess are older databases.

Do I just stop mediaserver and copy the databases over?

If you have backups of known working databases then sure.

To be clear, your MyVideosZZ.db both have the same values of ZZ?

Yes, they have the same ZZ. I’ll give it a whirl and report back

That seems to have worked OK. Thanks for the help.