Image slow down or freeze with some medias

Hello,

I’ve had this problem since at least January, maybe since I have the Vero 4K+ (I bought it a year ago). The problem was the same before the March update and is still present with the last update (this October).

On some media (mainly non-fiction shows, like 90 % of the time), at some point during playback, the image slow down or freeze, while the audio is still OK, then, after a few seconds (10 seconds to one minute maybe), the media jump a bit forward and image/sound are synchronised, then it does the same things a few minutes later.

Sometimes it is once or twice during an episode, sometimes it’s almost continuous.

I’ve enabled debug logging and played a file this morning. The slow down/jump appeared at least 4 or 5 times. Here is the log: https://paste.osmc.tv/olefuwixow (I think it happened the first time at 2020-10-27 10:47:25.289). [Edit: new log without upnext addon spam: https://paste.osmc.tv/wayozodube.]

Some notes:

  • I’ve all my media on the same hard drive (some with this bug, most play fine).
  • With hardware acceleration - amcodec deactivated, I haven’t this bug, but the image is not “fluid” (looks like there are tiny freezes).
  • I’ve tried changing several options, but I didn’t see any change (I haven’t kept track of those tests as I don’t understand all the settings, but I can try again some if needed).
  • If I show player debug information during playback, I see that during the slow down “aq” drops from 99 to 0 while “a/v” rise, then the jump happens (don’t know if it helps).

I don’t know if I just missed a simple option or misconfigured something or if it’s something else…

Thanks!

Your logs are flooded with

2020-10-27 10:57:34.896 T:3768533216   DEBUG: CAddonSettings[service.upnext]: trying to load setting definitions from old format...
2020-10-27 10:57:34.898 T:3768533216   DEBUG: CAddonSettings[service.upnext]: loading setting values
2020-10-27 10:57:34.901 T:3768533216   DEBUG: CAddonSettings[service.upnext]: loading setting definitions

Try to disable the UpNext Addon to see if that solves your issue.

Thank you for your answer.

I’ve installed this addon about 10 or 15 days ago. I’m going to uninstall it as it annoys me more that it’s useful anyway, but I’ve had the bug long before that.

Please provide a fresh log showing the issue again. It will be much easier to read and seek issues without the spam from the squeeky addon.

Here is a log without upnext (I played the same file): https://paste.osmc.tv/wayozodube

The bug happened at least once, I think it’s at 2020-10-27 16:19:50.526 in the log. It is the same error as in the previous one:

2020-10-27 16:19:50.526 T:3595206880  NOTICE: CVideoPlayerAudio::Process - stream stalled pts:404.606 clock:404.609
2020-10-27 16:19:50.527 T:3526230240   DEBUG: CVideoPlayer::HandlePlaySpeed - audio stream stalled, triggering re-sync
2020-10-27 16:19:50.527 T:3526230240   DEBUG: CVideoPlayer::FlushBuffers - flushing buffers
2020-10-27 16:19:50.528 T:3516600544   DEBUG: CAMLCodec::Reset
2020-10-27 16:19:50.529 T:3595206880   DEBUG: CDVDAudio::Flush - flush audio stream
2020-10-27 16:19:50.530 T:3595206880   DEBUG: CDVDAudio::Pause - pausing audio stream
2020-10-27 16:19:50.606 T:3516600544   DEBUG: CVideoPlayerVideo - CDVDMsg::GENERAL_SYNCHRONIZE
2020-10-27 16:19:50.606 T:3595206880   DEBUG: CVideoPlayerAudio - CDVDMsg::GENERAL_SYNCHRONIZE
2020-10-27 16:19:50.606 T:3526230240   DEBUG: CDVDClock::SetSpeedAdjust - adjusted:0.000000
2020-10-27 16:19:50.606 T:3516600544   DEBUG: CAMLCodec::SetSpeed, speed(0)
2020-10-27 16:19:50.606 T:3595206880   DEBUG: CDVDAudio::Pause - pausing audio stream
2020-10-27 16:19:50.609 T:3245764832    INFO: CFileCache::Process - Source read didn't return any data! Hit eof(?)
…

It is the same file but it happened at a different time (about 1 min 30 the first time, 6 min 50 here).

Try changing your UI refresh rate to 60 (it is currently 24) and see what that gets you. I think the problem is that your display has very limited modes it operates in so it is currently being forced to do things like trying to output a 1080p@30 video to 1080i@24. I wonder if with your display if you might get better results using 720p60 as your UI.

1 Like

Thanks @darwindesign. I set the UI refresh rate at 60 (1080i@60) and play the same file again, I don’t see the “stream stalled” error in the log, but I wasn’t in front of the screen (have to work…). I’ll watch it again as soon as I can (and maybe try 720p60 too).

I had set the resolution at the max for my TV (a ~12 year old full hd plasma that I quite like), but I don’t understand the full logic behind those settings (what will the Kodi produce, what will the TV display…).
In Display > General > Whitelist, I have only a few option (480p, 576p, 720p@50/59,94/60 and 1080p@23,98/24), does OSMC/Kodi detect the available resolutions for my TV there ?
(I’m just curious here. :wink: )

Yes the tv sends a so called EDID to the vero to tell it what it can or can’t do.

1 Like

You can see what resolutions and frame rates your TV is advertising support for in your logs…

====================== Display Cap =================== g0gjk991
480p60hz
576p50hz
720p50hz
720p60hz
1080p24hz
1080i50hz
1080i60hz
---------------------- Display Cap END --------------- g0gjk991

A simplified explanation of how this works is that if you have a resolution mismatch then between your source and display then the picture will be rescaled and that can cause a soft image or sometimes artifacts. Using a whitelist allows for OSMC to send lower resolution content to your display so that upscaling is done there instead instead of in the Vero/RPi. Many (most?) TV’s have superior scaling capabilities. This gets a bit more complicated when you factor in the frame rate. If your source and display have a mismatch where the frame rate of the source is not the same or an even multiple of what your display can do at a given resolution then you will have problems getting fluid motion as individual frames will have to get thrown away or duplicated to keep everything in sync. In your specific case your TV does not support 1080 in progressive mode in a frame rate over 24fps. The Whitelist does not allow you to select interlaced modes (I think their is a good reason for this but that is more of a Grahamh question that I don’t remember the details of) but the UI resolution is also included as part of the whitelist. With your old setting 1080p30 content was being forced to output to 1080p24. By changing your UI to 1080i60 I believe allows this to send the source at a perfectly doubled frame rate but interlaced.

As for running the UI in 720 that would be a suspicion that your display is not actually capable of 1080 but allows for that input for compatibility reasons. If this is the case then setting the lower resolution should give a better picture.

1 Like

Thank you @k2u3 for the info about EDID.

And thanks a lot @darwindesign for your answers. I’ve now watched a few shows which had the bug and it’s gone! Thanks a lot! Thank you for the clear explanations, I like to learn new things. :slight_smile:

Unrelated to the bug, I went into more details about the resolution. I’ve looked in the TV’s manual and learned that it should be capable of displaying 1080i60/50 and 1080p60/50/24 (and not only 1080p24).

So I’ve plugged the Vero directly to it (instead of Vero -> Soundbar -> Tv), and OSMC show me 1080p50/59,94/60 in the whitelist.

I checked my soundbar manual, and it says it is compatible with 1080i60/50 and 1080p60/50/30/25/24. But when it’s Vero -> Soundbar -> TV, the max in the whitelist is 1080p24…

I guess something is not optimal. I tried switching cables, but it’s the same (both cables from Vero to TV show all resolutions). I don’t know if I should try another setup.

You could try forcing it and see what happens. You would SSH into your Vero and then…

sudo cp /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap /home/osmc/.kodi/userdata/disp_cap

sudo nano /home/osmc/.kodi/disp_cap

(add in missing entries that your TV manual says are supported)

sudo systemctl restart mediacenter

EDIT: Fixed commands

I successfully edited the file, bot nothing changes.

You don’t get the new options in your display settings?

No, the whitelist doesn’t change. And I still cannot set the refresh rate at 50 or 60 hz with 1080p resolution, only in 1080i, like before.

Here is what I added in the disp_cap file (the last two lines):
image

(Still in /home/osmc/.kodi/, should I copy it back to /sys/devices/… ?)

Sorry I guess I pulled from an mistaken post.

mv /home/osmc/.kodi/disp_cap /home/osmc/.kodi/userdata/disp_cap

sudo systemctl restart mediacenter

1 Like

Nice! It works. And the TV shows correctly 1080p60hz as input if I select it.

Thanks a lot for your help and explanations! I feel like having a new device. :slight_smile:

Last question: should I set 1080p60, or 1080i60 for the UI? Does it change something for the movies now that the Whitelist is more comprehensive?

You will want to avoid interlaced entirely if you can. If your TV is taking 1080p60 then that should be the best UI setting.

Well noted. Thanks again for everything!