[IMPOSSIBLE] Any tips on getting OSMC/Pi to output digital audio my TV will pass along?

Hi guys, I’ve got an old Rear Projection HDTV. It’s supposed to automatically pass on any digital audio it gets via HDMI to a S/PDIF out to the audio receiver.

I’m not actually sure if this works at all. I’ve never seen any digital audio passed on. If anyone has any tips on how to test this, any settings I can try that may help?

Screenshot from my TV Manual:

Sounds like it is Dolby Digital (AC3) only, so DTS won’t be supported.
So, change setting to advanced, and go to system/audio settings.
Enable passthrough and AC3 capable receiver. Leave DTS disabled.
Set number of channels to 2.

If you have a Pi2 then enable AC3 transcoding and that will allow multichannel output of other formats (like DTS/PCM/FLAC) as AC3. This setting is not recommended on Pi1 due to the increased CPU load.

1 Like

I don’t see the settings you’re talking about. I see…

Audio output device: HDMI
Number of channels: 2
Output Configuration: Fixed/Best Match/Optimized
Limit sampling rate: 44.1/ 48 /88.2/96/192
Stereo upmix:
Maintain original volume on downmix:
Boost center channel with downmixing:
Resample quality: GPU accelerated/High/Medium/Low
Keep audio device alive: 1 Minute

I’ve also noticed some audio settings in the Pi Config section of OSMC settings.

Soundcard Overlay
Enable LIRC GPIO support
Enable SPI support
Supress all overlays

I don’t really know what any of that means, though.

Don’t set “Fixed”. That is not a default option (default is optimised) and stops passthough/transcode from working.

I changed it. Is there a reason I’m not seeing the settings you mentioned earlier?

Did you change settings level to advanced/expert (lower left)?

I did, yes. One or two extra options showed up but only those I listed above. What version are you guys using where you get the options popcornmix mentioned?

Can you post a photo of the audio settings screen?

Sorry for the confusion earlier. I found them and enabled them as suggested. So far no luck getting any digital audio to my receiver. I’m going to test the S/PDIF in on my receiver to make sure it’s working before I put all the blame on my TV.

Just hooked up a Blu-Ray player up to my TV via HDMI. The TV got audio fine but wouldn’t pass along anything to the receiver.

After doing some searches I found a thread that summarizes what TV manufacturers say that they’ll pass through to digital audio out jacks. Answer: Only digital audio from QAM channels. link

The only audio most - if not all - TV manufacturers pass on from HDMI inputs is Analog Stereo.

If the Pi had a S/PDIF out like the Blu-Ray, I think my troubles would be solved.

Starting new topic to look for digital audio out add-on board.

Look for an iqAudio or HifiBerry board

I had this issue as my receiver isn’t HDMI. You can grab something like this:

I ended up going for a HDMI switch which had a toslink output, it wasn’t this one - but one similar:

You do have to add a config line to get the pi to ignore the TV panels audio edid data:


If your receiver doesn’t support DTS weird things happen to the audio. But most seem to support AC3. It is cool to note that the Pi 2 will do AC3 transcoding - something I shall have to try :smile:

It does vary with TV manufacturer. See here.
Some TV’s can pass AC3 through optical. DTS support is much rarer.

I stand ever so slightly corrected.

Details can make significant differences around here.

I think it would be safer for people to assume their TV doesn’t have the capability to do this unless they know for sure that it does. “The exception that proves the rule” type thing.