Incorrect/Blank TimeZone Setting

Hello:

Have two rpi2 with both on the latest OSMC, for some reason one is showing the incorrect time. Have gone into System->Appearance->.International and the country setting is correct, but it does not allow me to change the Time Zone or TimeZone Country, as a matter of fact both settings are blank. Any suggestions or modifications to one of the *.xml files.

Anyone?

Not sure – might be worth stopping Kodi, moving guisettings.xml and restarting it.

How can I post the xml code, bloody editor mucks it all up.

You don’t need to? Just move the file.

Yes, understand that, put just wanted to post a snippet of the code in the forum. Editor mucks it up. What are the opening and closing statements to post code in a post?

You would have to use the “Preformatted Text” button that is </> button.
But as Sam wrote it doesn’t help if you post the file. Stop Kodi, rename/move the file, start Kodi

Thanks, will try that. I have already renamed the file, restarted and it still is exhibiting the same problem. Wanted to post a copy of the locale setting of the GUIsettings.xml if anyone can see something wrong.

There can not be anything wrong if it just cleanly was recreated.
I think showing the screenshot of System -> Apperance -> International would make more sense

You need to stop Kodi before moving the file.

Here is the OSCM box that displays the correct time relevant to the time zone etc.

Here is the box that does not. Note that the Time Zone Country is black text and empty, same with the Time Zone.

Well, appears the latest update fixed the issue. not sure what it was. Was going to do a reinstall, but fixed now.