Incorrect sound format for LOTR second movie

I have a strange problem with my Lord of The Rings extended edition on blu-ray. The first and last movie work just fine, but both disk on the second movie has incorrect sound format resulting in no output audio.
I have the BD ripped 1:1 to disk as iso files and play them using my Vero 4K+.
The disks/movies that work correctly shows that the sound format is DTS-HD MA 6.1.
The disks that fail for the second movie (disk 3 and 4) incorrectly shows up as Dolby Digital+ 2.0 and Dolby Digital+ 3.1/4.1 respectively.
Some of the commentary sound tracks works on those two disk, but none of the main ones.
The same iso files play just fine with correct sound format in other players as for example PowerDVD.
Any clue to what could be the cause for this? I tried to rip the disks a second time, but I don’t think the issue is with the rip but rather some software issue on the Vero 4K+.
Oh, by the way. I have the latest version just released this May, and the issue has been there as long as I’ve had the Vero 4K+ (must be a few years now, and I have always updated to the latest version). It also was an issue in the previous major version, where I also tried the experimental version of OSMC that supported 3D frame packed BD.

In order for anyone to be able to clue into the issue your going to need to provide a bit more information. If you could provide debug logs by rebooting twice, enabling debug logging, play a file that is experiencing the issue, then upload logs, and finally post the url that is returned in this thread.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC.

You can also create the mediainfo-output of the affected media file on the OSMC device:

  1. login via SSH, user osmc, password osmc
  2. if not already installed: sudo apt-get update && sudo apt-get install mediainfo
  3. cdto the directory containing the video/audio material in question
  4. since mediainfoonly needs to read the header information of the file data, copy the first 4 Mbytes of the media file to a new file:
    dd if="<media file>" of=purgeme.bin bs=1024 count=4096
  5. upload the decoded media information using
    mediainfo purgeme.bin|paste-log
  6. publish the returned URL here in this topic
  7. remove the created media file snippet
    rm purgeme.bin

Thx for your help.

Please ignore darwindesign has just pointed out to me, mediainfo doesn’t have iso support.

Regards Tom.

Thank you for the quick response.
Here are the logs:

I tried to play this file:
Lord of the Rings, The- The Motion Picture Trilogy (Disc 4).ISO

Not sure if it’s relevant, but I just wanted to mention that the logs are from my secondary Vero 4K+ box connected directly to a TV. Sound output is from the TV speakers.
My main system is in use right now, so couldn’t pull logs from that one. That system has a proper receiver and surround system where the Vero 4K+ is directly. Regardless the result is the same. No sound is output on both systems.

I’m not sure what your intentions are @ClarksonPowell as you seem to just have registered to write this single reply with information that clearly is incorrect.
All 6 discs has the same audio format, so your suggestion that Vero 4K+ does not support disc 3 and 4 is not relevant.
I appreciate that you try to help, but I think you must have misunderstood most of what you are writing.

It’s a bot - I’ve seen similar weird responses popping up on forums lately


@jensotto: Your logs show us that you are trying to play something from the ISO file in norwegian language.

But the logs does not match the issue you state since the mediacenter settings is stereo only with no passthrough means all audio is converted to 2 channel PCM:

<setting id="audiooutput.channels" default="true">1</setting>
<setting id="audiooutput.passthrough" default="true">false</setting>

whereas your connected LG TV understands PCM (limited to 2 channels only), AC-3 and DTS

CodingType MaxChannels SamplingFreq SampleSize
DTS, 6 ch, 44.1/48 kHz, MaxBitRate 1536kb/s
AC-3, 6 ch, 32/44.1/48 kHz, MaxBitRate 640kb/s
PCM, 2 ch, 32/44.1/48/96/192 kHz, 16/20/24 bit

I think this was a test or a workaround to be able to hear anything at all. Typically you should configure the audio setting of the Vero in this setup to use

number channels = 2
allow passthrough
AC3 capable
enable AC3 encoding
DTS capable

but I think with current data it is hard to find the root cause. Is there a way to rip the BDs again?

How did you rip this? The audio bitstream seems corrupted.

I use MyMovies and AnyDVD. I can try to rip again.

@JimKnopf I’ve uploaded logs from my other system that is connected to a surround receiver that does support passthrough:

I’ll try to get a new rip soon, but I’m not very optimistic in that it will make any difference as I’ve done new rips before.

@jensotto If you start playing the ISO, do you see a menu or does the playback start immediately?

For disc 3 i get a choice for selecting language. For disc 4 the movie starts directly.

Hi @jensotto , since this interests me, I borrowed LOTR extendend edition (German, English, Magyuar/Hungarian) from the local public library (set consisting of 6 BDs).
For tests I created complete images using dvdfab and OSMC plays them perfectly. Since OSMC currently does not support JAVA-based BD menus, I either have to select the suggested main film from the displayed menu or, as expected, I can select the correct film from the playlists, but I have to know the correct mpls number, which is often in the form 08XX.mpls.

Can you please post a screenshot of the menu you see here?

Currently I think you are playing the wrong playlist. I don’t know whether this is due to the software you use, which may not handle some obfuscation protection mechanism properly, etc. It doesn’t seem to be a general problem with OSMC.

1 Like

You are absolutely correct @JimKnopf
There is another title with exact same length and chapter number in the Select from all titles that plays the correct sound. I did not even consider trying to browse through those other titles.

The one that fails to play proper sound has title 1689. The one that works is title 100. Same number of chapters and duration on both titles.

Is there a way to change the default assignment?

Thank you for discovering this.

No, it’s up to the decryption software (at your site anydvd) to remove fake playlists if the BD is using obfuscation protection. Obviously anydvd is not doing a good job with this BD while dvdfab sorted all the wrong ones out.

1 Like