Incorrect video information displayed

Hi, I’ve scrawled back through 3-months worth of these forum questions and can’t find anyone with a similar issue…
So, this began after the update in March '20 and I’ve since installed the June ‘20 update but still have the same ‘problem’. Okay, it’s minor but would be nice to fix.
I have an external hard drive I plug into my Vero4K full of film files. Recently I’ve done some updating from H264 files holding 1080P video to H265 with 4K (UHD). So naturally I am replacing the 1080 films with the 2160 films on the hard drive, yet the film ‘data’ on the left-hand side underneath the thumbnail isn’t updating…
My new 4K file will still state 1080P (as prior) and also the H264 won’'t show as H265. It’s as if the VERO is hanging on to the old files info and won’t let go! It DOES update the file size though!
It’s no big deal really, as these files play as 4K, but it’d just be nice to be able to instantly see which are the 4K files.
And it does the same thing if I previously had a 720P H264 and have recently upgraded it to a 1080P H264; still states that the file is a 720 and not 1080.
Any ideas?
Or should I just re-install a pre-March 2020 update, as it worked just fine before then?

Does playing one of the problem files for a minute or two result in the info being correct when you return to the menu?

This is a Kodi-specific “problem”, not OSMC.

When an item is scanned into the database, its properties are read and the video / audio information is stored in the DB. If you change a file, it will see the file size change because that is read real-time; I don’t believe it is stored in the DB.

To update the video / audio flags in the interface, you have a few options:

  • Play the file. You don’t have to play the whole thing; just a few seconds should be enough.
  • Delete the item from the DB then scan for new content.
  • Clean the entire DB, then rescan everything after making all your changes.

Hi ActionA,
No, that no longer is a solution.
It used to work that way, ie. pre-March 2020 update.

Hi DarkKnight,
I’m not a tech-head whatsoever… you’ve lost me. What’s the DB?

Playing the video file doesn’t work. It used to, pre-March 2020 update.

@Eraserhead The idea is to remove the movie from the library and then afterwards update the library:

  • instead if playing the file press the context button (3 horizontal lines), choose maintain or so and remove/delete the movie from library but do NOT delete the file
  • update the library (with OSMC skin you find that in the sidebar menu)

DB = database. Kodi stores its library of metadata in a database.

@JimKnopf - Thanks, but I don’t see the option you’re referring to?

What if I just factory reset the whole box?
Surely that’ll sort it out?

resetting the box will do nothing for you. This change was made over on Kodi for a reason I don’t recall off hand (you could search the issue threads on Kodi’s github if you want to know more) and this behavior is intentional. If you have a single file you want to update you can press the ‘i’ button to bring up the information screen and then click on the refresh button and this will update the information. If you want to do an entire series at once the refresh doesn’t work (I don’t know why) and you would do as JimKnopf stated and highlight the show, press the menu button to bring up the context menu, select “manage” and then “remove from library” and then “yes” to confirm you want to remove the library entry. If you have the option enabled in settings to allow file deletion, it will also ask you if you want to delete the files themselves and obviously you want to make sure you say no to this. If you are going to do this procedure it would probably be best to not have file deletion enabled to prevent accidents. You can then update your library so these files are scanned in again but with updated info. You can hold down the menu button to bring up the slide-out menu (which is what you posted above).

To avoid this situation in the first place you may be better off not using the same file path for the updated files. If you tweak the file name or folder path at all Kodi will see this as a new file so you could scan in the new files which would give you duplicates that will inherit watched status. If you remove the original versions you could then run a clean library which would remove the original entries but leave the new files.

Replies very much appreciated one and all. @darwindesign, I tried the ‘i’ button but it did nothing. No obvious reset option there. I’ll take a look at what else you suggested later - to be honest it’s all very baffling to me, file paths, etc.
I have become my father, on his knees in front of the telly trying to set the Betamax timer to record Top of the Pops on Thursday…
Ultimately, it’s no big deal - just odd that it was fine for a couple of years, replacing files and getting updated info as expected and now it does this. Ah well.

Are you using something other than the remote that came with your Vero? If your using your TV remote via CEC then likely the info and context menu are not accessible without tweaking your key-maps for your specific hardware. With the OSMC remote the ‘i’ key will bring up a fullscreen information window which allows you to view extended info as well as refresh and select artwork.

In a nutshell if you have a file at
TV/duck tales/s01e02.mkv

you could remove that and put an updated file instead at
TV2/duck tales/s01e02.mkv

`TV/duck tales/s01e02-update.mkv

and in both of these examples the file would get picked up as a new file because it is not the exact same file path. You would then have two entries in your library for this episode; the old one that doesn’t work because you deleted the file, and the new one that has the updated info. You would go to settings>media>library>video library>clean library and that will remove all entries from files that no longer exist.

There were objections raised about this change for the exact use case you bring up here. The Kodi devs decided to make the change anyway. Unfortunately we have no control over this. The workaround if you have working remote buttons is significantly less difficult that getting rid of the blinking 12:00 on a VCR.

Another option would be to name the files like this:

TV/duck tales/s01e01.1080p.mkv


1 Like

@darwindesign - I am using the remote control that came supplied with the Vero 4K.

@JimKnopf - Huge thanks for taking the time to snap those pictures and add a little photoshop. I ran through your instructions, but I don’t get a ‘Manage’ option as you do.

I’m presuming all this file renaming business means plugging the box into my Mac, which is something I’ve never done before. I’ll maybe give it a try.

End result solution though; I simply plugged my external hard drive into my Mac and the updated ‘problematic’ files I simply added a space at the end of the filename and this has worked!

A simple solution for a simple man :cowboy_hat_face:

Are your sure you had been in Library view not File view?

You’ve to do a short press on the context button not a long press. :wink:

No idea to be honest. I just followed those instructions. I’ve fixed the issue now, in my own (probably not the best) way; good enough for me!

1 Like

If you don’t mind I would like to understand the nature of the issue with the remote. Could you please reboot twice, go to settings>system>logging>enable debug logging> and enable that option. Once that is done go back to the home screen and navigate into the “movies” section and press in this order…

menu (just press and release, don’t hold it down)
menu (just press and release, don’t hold it down)
long-press menu (hold down menu button for one second and then release)
long-press menu (hold down menu button for one second and then release)

…once you have done this can you go back to the home menu, open My OSMC, go to log uploader, enable all configs and logs, and then click upload selected logs now. After a delay it will pop up a screen with a url. Please post that url in this thread. You will then want to go back into your settings and turn debug logging back off.