Increasing max volume

Im really enjoying the Vero 4k so far. The only issue I cannot get round on my setup is that the Vero 4k seems to have a much lower max volume than my previous configuration (Pi2 with the HiFi Berry DAC+ Pro).

My speakers are maxed out along with the audio in the Vero 4k and the sound is about 2/3 of what it was previously. I am using the 3.5mm audio jack. Is there a way to increase the max volume without affecting audio quality?


sudo apt-get install alsa-utils

And adjusting in alsamixer.

1 Like

Thank you Sam, this worked. For anyone else using the audio jack, the setting is DAC Extra Digital. I increased mine from 0 to 18db.

This thread can be marked resolved thanks.

1 Like

This works and is definitely the easiest solution.

However, I had some issue with this. At 18db, my mp3 music sounded a bit distorted. Easily solved by going down to 6db. But then some movies became hard to hear (original problem). Got a bit tiring having to use alsamixer to keep toggling as required.

Finally got a 192 KHz DAC for 20€. Feeding it the optical out from the Vero 4K has solved all my problems. The audio quality also does seem to have improved …

File this as an alternative workaround.


Did you have to change any settings to get an output through your DAC as I have had the same issues and am now greeted with silence!

Does your DAC support multichannel formats such as Dolby? If not, you need to disable passthrough.

But simple 2 channel audio will play regardless of the settings.

All that I am trying to do is pass a flac file from a vero 4k through a toslink via a DAC to a 2 channel rac input in a hifi amp. Sounds simple but when you are a technophobe like me simple things to those in the know are somewhat more challenging for the rest of us.
I suspect that as my dac has only rac outputs it is not multichannel (see above!).
How do I go about disabling passthrough (whatever that might be).
Any help is greatly appreciated.

the alsamixer solution used to work for me, but it doesn’t anymore after the july update.

the value of the DAC Extra Digital Gain item (which was reset to 0db after the update) doesn’t change when attempting to alter it using alsamixer. dmesg displays the message It has risk of distortion! each time i attempt to alter the value. it doesn’t seem to matter if the mediaserver service is runnning or not.

does anyone have similar issues and maybe an idea why the value can’t be changed?

Hi @sfera

Just to confirm: you’re using the analogue out on the device?

I’ll check this out. There have been a few audio improvements, some of which have come from upstream. I’d be happy to produce some test builds for you if you’re willing to give them a try, but it might take me a couple of days to backtrack and see what’s changed.



yes @sam_nazarko, i’m currently using the analogue audio jack (with an audio 2.0 channel configuration in kodi in case it matters). i would be happy to help any way i can.


First, thanks for confirming the dmesg output, that’s very helpful.

Secondly, am I right in thinking the value does go up in alsamixer, it’s just not doing anything when changed?


Should be fixed in

I’ll get this built for you now


i have this configuration in alsamixer:
Item: DAC Digital [dB gain: 3.75, 3.75] Item: DAC Extra Digital Gain [0dB]

the item i want to alter is DAC Extra Digital Gain. the value of 0db does not change at all when i attempt to alter it using the up/down arrow keys.

the setting of the DAC Digital item can be altered in range of [-116.25, 3.75] db.

you’re too fast. :slight_smile:
thank you

The change I have made should permit you to make changes and hopefully that will work. I’ll ping you when it’s ready

I do apologise about the unexpected change, but there are plenty of positive changes in this update and I hope you see some of the benefits


there’s no need to apologize. regressions are to be expected now and then, and you provide excellent support.

Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

unfortunately, the change didn’t help, the issue persists.

dmesg does not display any susipcious messages anymore when i attempt to change the value using alsamixer.

these packages were affected by the upgrade:
The following NEW packages will be installed: vero364-image-3.14.29-29-osmc:arm64 The following packages will be upgraded: armv7-splash-osmc vero364-kernel-osmc:arm64

the system waited indefinitely while shutting down, displaying the message "A start job is running for Store Sound Card State", so i had to plug the power cord out (i am logging in via SSH). this also happended when rebooting after applying the july update.

a stack trace involving the sound card was displayed while shutting down, but i don’t know how to capture it since i was already disconnected.

manually running sudo alsactl store does not return (the command does not finish, ctrl+c doesn’t help) and produces a similar call stack:
dmesg --human:

what i failed to test previously after installing the new build was if there is sound at all during playback. there is none…

You can downgrade for now (sudo apt-get install vero364-image-3.14.29-28-osmc).
Still looking in to this.