Infinite buffering on Vero 4K

After an update, it buffers forever on all videos.
I created a debug log:
I’m getting lots of “video codec returned error”.
I tried a force update to the latest OSMC “OSMC_TGT_vero2_20201227.img.gz”, using both USB
and microsd. It just flickers “Please Stand by” until I give up and reboot without card (30 min.)

The staging build is currently in a non working state. Please ssh into your machine and run the following command.

sudo apt-get install libamcodec-osmc=1.6.0-5

and make sure you hit “y” to enable the downgrade. Once you have done that hopefully it should start working again. You will also want to edit your apt sources and remove the buster-devel line at the end so you will stop getting staging updates.

sudo nano /etc/apt/sources.list

Thanks, that fixed it.
I must have enabled devel some time ago and forgot. Do this explain why I couldn’t “update” using the microSD and/or USB?

If you just put the gz file on the drive then that doesn’t work. There is an program to make installation media on the download page.

Completely unrelated to any of this, you should set refresh rate switching to on start/stop in your player settings.

I put the .img file (unpacked the .gz) on the drives using rufus 3.13. Rufus usually works fine for linux boot images.
I’ll look at changing the refresh rate as you suggest.

Just a FYI. vero2 isn’t the correct image for a 4K. It should be vero3.

1 Like