Infrared responding intermittently

Hi @sam_nazarko,

I’m a huge fan of the Vero4k, I have three - one for each of the televisions in the house.
Two of the three are using the supplied external Infrared (3.5mm) extender and were both working well until recently (the other is using CEC with the TV remote).

One unit has recently stopped working correctly, in the GUI the infrared (Logitech) remote works but now loses a few key presses. When playing media the remote is almost useless and can take up to 20 presses to respond.

I’ve tried swapping the external Infrared adaptor (3.5mm) and remotes, but the problem persists, which makes me think it’s either hardware or software on this particular unit.

All three Vero4+ devices are running the same version of software as follows:

root@kodi-mediaroom:/home/osmc# uname -a
Linux kodi-mediaroom 4.9.113-64-osmc #1 SMP PREEMPT Mon Feb 28 02:52:02 UTC 2022 aarch64 GNU/Linux 

root@kodi-mediaroom:/home/osmc# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 10 (buster)
Release:        10
Codename:       buster

root@kodi-mediaroom:/home/osmc# grep Kodi .kodi/temp/kodi.log | head -3
2022-04-22 19:21:53.119 T:2615     INFO <general>: Starting Kodi (19.4). Platform: Linux ARM 32-bit
2022-04-22 19:21:53.119 T:2615     INFO <general>: Using Release Kodi x32 build (version for Vero)
2022-04-22 19:21:53.119 T:2615     INFO <general>: Kodi compiled 2022-03-08 by GCC 8.3.0 for Linux ARM 32-bit version 4.19.152 (267160)

root@kodi-mediaroom:/home/osmc# grep VERSION_ID /etc/os-release

I’ve ordered an external USB Infrared adaptor which I expect to resolve the problem, but I would love to hear if you have any suggestions on troubleshooting or debugging the failure of the Infrared?

I’d be surprised if it’s a hardware issue. There’s a know performance issue with IR during playback (IRQ isn’t serviced in time) and we have some improvements in a new kernel which will be released in the near future.

I suspect some of your other units are still on the 3.14 kernel and your problematic unit is on the 4.9 kernel, as that’s where the regression was seen.

As an aside, unless your device doesn’t have LOS, you won’t need to use the external IR receiver and by attaching it you can have a performance reduction as we have to cancel out multiple signals to prevent duplicate presses.

Have you changed the batteries on the Logitech or tried a remote that works well on the other devices on the affected device to rule out a remote issue?