Instability on RPI2

Hi.
I have the latest version of OSMC installed on a RPI2, not overclocked.
The RPI is always on and - when I actively use OSMC - I did not find any sort of instability. In fact, I love it :slight_smile:
The system is connected to a samsung tv via hdmi and I use CEC.

However, when idle / not actively used, something does happen and I can’t find anything in the logs.
specifically sometimes:

  • I come back home and realize that OSMC is stuck at the weather page (1st page).
  • the system is stuck at the reboot process (system is scheduled to reboot every day at 2AM)
  • SSH would not work
  • [edit] osmc starts, starts updating library and then the sad face shows up, and starts osmc again (in a loop)

I"m not sure what else should I do to troubleshoot… ideas?
syslog, dmesg, osmc logs via the menu, … ?

Thanks!
antani

Enable debugging and provide grab-logs -A

Also are you sure that you don’t have a power problem or a faulty SD card?

How are you scheduling the system to reboot ?

i have an entry in crontab to do a sudo reboot (or just reboot, I don’t recall and can’t check right now) at 2AM.
Not sure if this is the right way of doing that.

I have been out of the linux world for a long time and realized that many things changed in the last few years, especially with installations on “smaller devices” (RPI2, WDMyCloud, jailbroken ATV2, …): crontab, runlevels and initd, systemctl, …

I wish I could do that but the system reboots at some point (more below).
[edit] just realized that dmesg does mention something about btsync. I’m going to try to disable it and post back results [edit]

The SD has been mounted on a virtual debian and checked with fsck. everything seems fine.
Power supply may be an issue but I’m not sure how to check. I disconnected everything besides hdmi and eth.
I also ordered a 2.5A 5.5V from amazon that should arrive today (current is 5V at 2A).
Finally, on sunday night I installed the latest osmc update from the osmc interface.

since last time this is what happens:

  • system boots, shows OSMC splash, then weather page (my 1st) and starts updating library. once I was able to get to the next menu and played a video. It stopped within 30 secs and froze the picture. I had to disconnect the power.
  • However all the other times (20 attempts so far) did not go as far: during library updates it shows the sad face, and then reloads OSMC, in a loop, until the below happens.
  • then the OSMC interface gets partially covered by an output similar to dmesg and system freezes. I need to disconnect power again.
  • the above occurs also when i disable mediacenter (sudo systemctl stop mediacenter)
  • i have btsync that starts at boot but i was not able yet to disable it. yesterday however i was able to kill the PID and the behaviour above still occurred.

I was able to capture on SD a very late dmesg output before it died. see here
http://pastebin.com/XHENK81V
I think the concern starts at sec 87.
Even though i was not able yesterday to capture it yesterday I noted errors/warnings in dmesg mentioning CPU 1, 2, (and 3?).

any ideas?
thanks!
antani

update:
Compared with a standard OSMC installation, my machine does the following:
1- couchpotato
2- btsync
3- inotify on the folder that btsync uses
4- mounts NFS share where all media is stored

I rebooted and disabled 1,2,3. Didn’t try on 4 but I don’t think it’s related.

OSMC started, updated library, sad face. Then the OSMC screen got partially covered (at first, then completely) by dmesg-like output (see new pastebin on dmesg)
SSH was still working. I executed a ‘top’ and saw that kodi.bin was at 100% CPU even though nothing was showing on screen.
The little rainbow square on top right did not show (the one used for undervoltage) at all during the session.
I restarted with systemctl the ‘mediacenter’ process but nothing happened.
kodi.bin still at 100% with nothing on screen.

Probably 2 minutes later system died with a bunch of output on dmesg. I believe now other processes (not btsync as earlier) are mentioned.
I tried to capture dmesg as late as possible but this is as far I was able to go. Some other output showed up before system froze [http://pastebin.com/Hkut7d18]

not really sure where to go from here besides reinstalling everything…

The is really something wrong, are you overclocking?
Maybe reinstall is your safest bid. Maybe just before that when you get in with ssh just provide a grab-logs -A

From your system journal you have major instability problems, so much so that I don’t really know where to begin.

The first thing I would do is a completely fresh install. If you still have problems, try a fresh install on a different SD card. If you still have problems after that I would try a different power adaptor.

What you are seeing is not software problems, it’s either major file system corruption or a hardware fault. I have never seen a log so full of kernel errors before.

What you are seeing is not software problems, it’s either major file system corruption or a hardware fault. I have never seen a log so full of kernel errors before.``

LOL. this made me laugh :smiley:

Will do. A new SD is coming this way as well as a power adaptor.
Will keep you posted!
I read the other thread about December updates and RPI2. I use a Transcend SD for now: do you think I need to use mmc in the config file?

thank you for your time!!

If you do a fresh install of the November release and update to December it will now stay on the mmc driver automatically, so you shouldn’t have that issue.

I will reinstall in the next days. I was able to post an early log as below. logs are ordered from the first (with fewer errors) to the last before near-death (mayhem). Only the first was generated by a grab-logs that completed successfully. I had to control-C the other three after 10+ mins they were running.

http://paste.osmc.io/lopoyefeci
http://paste.osmc.io/gaxuwiwiwo
http://paste.osmc.io/ifamipukov
http://paste.osmc.io/qucafeqeke

hope it helps…

Update:

  • I installed on the same SD (Transcend) the 2015-11 version through the OSX installer. I kept the same power adapter.
  • first boot did not last 5 secs. Kernel panic and system died. screen showed syslog on screen up through 5 secs and then died.
  • replaced the power adapter and installer started on screen (formatting device…). No progress during the formatting screen after several minutes.
  • rebooted and screen would only show a rainbow square (full screen, not the small on the top right for undervoltage). no progress whatsoever.
  • rebooted multiple times and same thing.

At this point I need to try with a new SD (unfortunately, arriving Monday :frowning: ).
I will try first with old power adapter and new SD and then replace the power adapter if needed.

Stay tuned.

PS funny how I started this post when instability was not frequent and then it snow-balled somehow :slight_smile:

the thing gets more complicated.
I found on old microsd (512mb). I use the OSMC installer on OSX selecting the USB installation (as I imagine 512mb are not enough). Installer concluded successfully on OSX.
Once I plugged the sd into the RPI and connected the power, I only see the fullscreen rainbow square, same as noted above.
I tried with both power adapters. Sure that it’s possible that this SD was faulty too, but at this point i’m not sure anymore.

Is there any way to “test” whether the RPI hardware is at fault here?
the CEC menu of the samsung tv does recognize “raspberry” as source so there is some communication occurring somehow.

thanks

That normally indicate that you got the wrong image (e.g. a Pi2 image on a Pi1) or that your SD card or SD Slot is totally busted.
Get the new SD Card, get the right Image, get proper power and everything will be fine

one more. I tried to disconnect even the ethernet cable. At the first attempt, the OSMC installer loaded and the countdown started (the one to replace the content in the USB drive). It stopped at 15 secs and system froze.

Many other attempts and only got the rainbow square.
One more attempt and it went to kernel panic within the 5 secs, similar to be the above.
Will try with new SD once I get it but the system is failing on both SDs I tried so far.
If still not working, will buy a new RPI and try with the same SDs and see if working.

thanks

Update finally!
it appears the RPI2 is dead. I tried with a new SD and I had the same result: rainbow square in fullscreen.
Moved the same SD to another RPI2 and everything worked :frowning:

I looked at the old RPI a bit better and it appears that the lower side of the board is brown in a couple of spots… right where the main chips are :frowning:

thanks for the help!