Install addon which is not in a repo

Firstly, the Vero 4k+ is absolutely amazing!
If I had only known earlier about it I could have saved me some disappointments and stress.

I had a few other boxes before and on one of them (as well as on Kodi on PC) there is a screensaver called “Stars” or “Starfield”.

I wanted to install this screensaver but it is not showing up in the repo. I think the Vero 4k+ should be capable of running it since there are other screensavers in the repo which, I think, have the same requirements.

Can anybody please tell me how to install this screensaver?

Try this:

Thank you for your fast reply.
I have tried it this way and downloaded the zip files from here

and here

I’ve tried both the


as I don’t know which one would be the right one. But upon installing via System/Add-ons/Install from zip-file, the pop-up at the top of the screen tells me that it could not be installed as the zip-file has invalid file structure.

Did I use the wrong zip-files or what else could be the problem?

Looking at the link, it says: To download this Add-On, we highly recommend you do it via the user interface in Kodi. Simply look for the “Get More” button in the Add-Ons menu.

Have you tried that?

I have looked everywhere but there is no “Get More” button. It is supposed to be in the “Lefthand sidebar menu” “depending on what part of the Add-ons section you are in”. But it doesn’t show up at all, no matter in which section I am.

Maybe the skin you are using. Switch top another to see if it appears

Usually I’m on Aeon Nox Silvo. Now I’ve tried Estuary and the OSMC standard skin.
No button. :frowning:

Have you changed skin view to expert?
Or have you got overscan on on your TV?

and no overscan.

The main problem is still that I can’t install ANY zips downloaded from both links (official Kodi addons) posted above.
For ANY zip it says “invalid file structure”.

If you are trying to install screensavers, you MUST use the one for your platform. I just tried installing a Linux one on my OSX instance, and I get the same message about invalid file structure. The MacOSX version installs fine from zip. Only Screensaver and PVR add-ons are like this. Everything else is written in Python and is (most of the time) platform independent.

I believe because OSMC is its own architecture that the OSMC folks have to compile and make those available. Looking at my OSMC install, it looks like some of the screensavers are available, but not all of them. And Stars is not one of the available screensavers. To get to the screensaver addons, go to Settings > Addons > Install from repository > Kodi Add-on repository > Look and feel > Screensaver.

After install you also have to enable the screensaver. Go to Settings > Interface > Screensaver and then set the screensaver you want in Screensaver mode. In most skins that last screen where you set the screensaver also has a GET MORE button where you can download screensavers for your platform from the repo. I’m not sure why you aren’t seeing that button. Here’s a screenshot from Estuary where the GET MORE button is there to the right.

Ah yes, of course, I have this button but the addon not showing up there was the problem in the first place and why I started this thread.

Your explanation about the different architectures makes it clear now.

Hopefully it will be compiled for OSMC sometime.