Install Any VPN, including Windscribe


#1

I know there are numerous mentions of “install VPN” in the General Discussion, Help and Support and How To sub forums. I have read most of them. I also tried the “Brian Hornsby” method. However, I cannot get past this common error as reported by a fair number of community users: “An error has occurred whilst trying to connect OpenVPN. Unable to connect to OpenVPN management interface.”
Admittedly, I am not an advanced user. My skills are limited to some familiarity with Linux commands, SSH functions and a general ability to read and follow a set of instructions. I am a 69-year-old retired accountant who has used computers since the days of paper tape and punch cards. I am an “early adopter” of technology products and love futzing around with PCs and networking gear. But after days of reading and trying to get my Windscribe VPN credentials properly installed and working using the OpenVPN program addon on my Vero 4k, I have to wave the white flag and beg for help.
While I know the advanced users in this community do provide very wonderful help to us less experienced users, I and many others seem to get tripped up by the slightest lack of technical knowledge when attempting to follow a given set of instructions. “You installed the VPN server; you needed to install the client. SSH the file to the directory with your config settings, edit out the spaces and you’re good to go.” might just as well be: “Fire up your cold fusion reactor and teleport to the dark side of Kuiper Asteroid Belt.”
Any help that a kind user can provide to me would be greatly appreciated. A successful set of instructions accompanied by helpful answers to my dumb follow-up questions which then leads to my precious Vero 4k connecting to the internet through my paid-for VPN provider will be greeted with a generous donation to your beer fund or charity of your choice.


#2

Hi,

If you happy working with the commandline:

https://osmc.tv/wiki/general/accessing-the-command-line/

This should help:

https://www.raspberrypi.org/forums/viewtopic.php?t=201688

Thanks Tom.


#5

Hi, Tom . . .

Thank you very much for your prompt reply. I am pretty comfortable using the command line. I do have to occasionally Google commands but the from the search results I can usually figure out the proper syntax for the Linux command I need to run.

Here is the error message when I ran the command from Step 1:

Reading package lists. . . Done
N: Skipping acquire of configured file ‘main/binary-arm64/Packages’ as repository "https://repo.windscribe.com/debian stretch InRelease’ doesn’t support architecure ‘arm64’

Tom, this message may be due to the fact that I am using putty from a Windows 10 Pro computer to communicate with my Vero 4k via the command line.


#6

No, it’s not caused by using Putty from Windows.

I suspect you’ve added a repository. What’s in your sources.list?

cat /etc/apt/sources.list

#7

Well I guess he followed these steps

@ptgay49
Remove the repository you added in these steps and follow the Kodi install steps


#8

I received the following output when I executed the cat command:

deb http://ftp.debian.org/debian stretch main contrib non-free
deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://apt.osmc.tv stretch main


#9

If you followed the instructions that @fzinken linked, then please do this:

ls -l /etc/apt/sources.list.d

#10

In reference to the instructions that @fzinken linked, I stopped at step 1 because of the error message I received,

Here is the output from the ls -l /etc/apt/sources.list.d command that you suggested:

total 4
-rw-r–r-- 1 root root 52 Jan 8 23:03 windscribe-repo.list


#11

Then remove that file with `sudo rm /etc/apt/sources.list.d/windscribe-repo.list

After that follow


#12

Thank you for all of your suggestions today.

I ran the command sudo rm /etc/apt/sources.list.d/windscribe-repo.list without any problems.
Continuing with STEP 3, I have tried everything to move my .ovpn file from my personal computer to the Vero 4k for hours without success. I used SSH, pscp, psftp, a flash drive inserted in the Vero 4k, my Windows personal computer and a personal computer running Ubuntu 18.04. All attempts resulted in either Access Denied or Permission Denied.


#13

Which Step3?

Copy the file to /home/osmc and the use sudo cp to copy where ever you want it to be.


#14

Again, I have to thank you for hanging in there with me for the last however many hours.

After taking a break for several hours myself, I jumped back in this evening and stumbled upon a Kodi Program Addon named “VPN Manager for OpenVPN”. It offers a wizard for setting up a VPN service on Kodi devices, including my Vero 4k. I had to run the wizard several times before I got all the settings and file locations figured out. However, I now have my Windscribe VPN service running, running automatically upon reboots and I even managed to create a choice of two Windscribe server locations that I can toggle on or off.

I would recommend this Program Addon to other members of the community to install their own personal choice of VPN service if you are not an advanced Linux/Kodi/OSMC user.

Again, I need to record a big thanks to user @fzinken. I know there is a process to officially thank you for all of your suggestions and assistance. I will research that and take the appropriate action. Having you lead me through this process was such a kind gesture on your part. Thanks again!


#15

No worries, happy to help.
So I assume if you refer to “VPN Manager for OpenVPN” you are referring to Zomboided which is linked in the Windscribe webpage or something else?


#16

I found this wizard on my Kodi Vero 4k device. It was located in the Addons section, specifically Program Addons.

I just investigated further and you are correct: the author of this Program Addon (“VPN Manager for OpenVPN”) is indeed Zomboided. It indicates that it is version 5.0.7. I must have missed the link on the Windscribe webpage. However, I seem to recall seeing what may have been Zomboided’s line-by-line instructions which I probably tried to use but was unsuccessful. His Kodi program, which offers a wizard as an installation option, is very good. So kudos and thanks also to user @Zomboided!