Install Crystalbuntu2 / Kodi - instructions for OSX or Windows users

Thanks @wrxtasy!!!

Got everything installed, however when i try and enable AirPlay I am getting “Failed to Start” message?

This link is broken

Where can I find the instructions?

nvm. I scrolled through my old terminal commands and found the code.

sudo wget https://dl.dropboxusercontent.com/u/27641650/Crystalbuntu%20ATV1/Kodi14.2.Install.sh && sudo chmod 755 Kodi14.2.Install.sh && sudo ./Kodi14.2.Install.sh

it worked! I just pulled the power cord and usb stick out and rebooted back into crystalbuntu/xbmc gotham… but the links to upgrade to Kodi Helix and install Kodie lsengard Alpha2 is not working anymore…

sudo wget https://dl.dropboxusercontent.com/u/27641650/Crystalbuntu%20ATV1/Kodi14.2.Install.sh && sudo chmod 755 Kodi14.2.Install.sh && sudo ./Kodi14.2.Install.sh

Can you provide the link for the Isengard update script?

I have made a new thread here: Progress at last, where I will be keeping users updated as OSMC development progresses.

Hi, first let me say KUDDOS!!! And thanks for the great step by step!! But as a total newbie to both the ATV and this stuff, how long exactly is a couple of hours? Lol, sorry but I have been letting it go for about 6.5 hrs now and nothing has popped up in the terminal window since I did the last step prior to upgrading to helix.
BTW if it helps, I am on a Macbook Pro 2,1 running OSX 10.7 and I couldn’t get Cyberduck to connect so I used filezilla instaed.

Hi wrxtasy - thanks for all your great work. Can you please post the script for the Kodi Isengard Alpha2 upgrade?

@wrxtasy - I havent inserted the CHD BCMxxx12 card into the ATV as yet. Can I add it after this whole tutorial is successfully completed? Or do I have to add it in between the steps somewhere?

Hi, my first post here. Many thanks wrxtasy!

I was wondering why the display reponse time was so so slow where the display only responds quite a long time after the remote control was clicked. It used to be pretty smooth before when I was using Dell u2913w (29") display. Now I changed the display to Dell u3415 (34"), which is the only change than before. I tried by changing the resolution to down to 1920*1080. But it’s still the same lagging lagging… Pleasse advise. Thanks.

I am using ATV1 running Crystalbuntu2 on the internal hard drive.

You could try turning this setting off:

Settings > System > Video output > Vertical blank sync > Disabled

I can’t seem to find a working link to upgrade to 15.2. Did I miss it?

Why not just use OSMC which has 15.2?

Sam

I prefer to have the install on the hard drive rather than on a USB sticking out of the back of the unit

OK.

Keep your eyes peeled then, because that may not be far off.

1 Like

@sam_nazarko - Is OSMC for ATV 1 finally out?

It’s been out for two months. See OSMC's November update is here - OSMC

Hi Sam,
do you mean the unfinished HD Install or am I missing something. Today I done a manual upgrade on the ATV1 which was the Nov 22nd version, What was that updating ?. My ATV1 is working fine after putting the HD install image directly onto a 256gb Msata ssd and attaching internally. Looking forward to the finished article,** I can see that you have been busy all over the Xmas and deserve all the praise for the work you’ve already put into the ATV1, so keep up all the good work Sam, and Best of luck to you and all the crew for the New Year.

Updates are usually released every month. (current one is from December)
A list of changes in each update is posted here: https://osmc.tv/blog

Sam meant that OSMC was working on the ATV1 since November. (USB Install)
The HDD install is not ready.