Install failed Hardware is faulty message

So i have a raspberry pi 3 all working fine with OSMC and koi. Tried to plug it into another Tv and kept getting no signal. Moved it back to the TV it was originally on now doesn’t work on that either. Redownloaded OSMC and put on a new SD card now getting the following message install failed. Please contact support. Hardware is faulty. So i redownloaded it again to the original card still same message…please help

i have tried reformatting the card, used a different card, wired connection is what I use but still not working :frowning:

I’m aware of the problem. It will be resolved shortly. Stay tuned.

Try downloading the latest image from our website. Delete old ones or using the OSMC Installer, when asked to download the image again, do so.


I’ve tried the image posted on March 21st (2017.03-1 51f49d7fab751e05be2a0c4576e9d96f) for the PI Zero W and I’m also seeing a “hardware is faulty” message. I had the February build working on my Pi Zero W before that and it installed fine (but didn’t have wifi, obviously), but when upgrading I saw this. I tried erasing my SD card and re installing, but saw the same message. Any clues as to where to go from here?


Are you definitely sure you’re running the latest image?

I believe this issue was resolved, and I rebuilt the images and didn’t have any reports since then. However, just to be certain, I’ve kicked off another build and that will be available on the website soon.

Please report back and let me know.


Yea, from my last message I’m talking about the latest image from the OSMC download page identified as 2017.03-1 with checksum: 51f49d7fab751e05be2a0c4576e9d96f

Is that not the latest?

  • Ben


Please check the website and try the new image.


Latest image works for me. Thanks!