Install help plz

Hello all and ty for any help giving as its greatly appreciated …first thing is i apologize for my extremely bad grammar

I am fairly new to the raspberry pi and osmc and i am trying to do an install …now what i am gonna ask might sound stupid but plz do keep in mind this is my first time ever even hearing about osmc so i again apologize for my lack of knowledge …

What i need help with is this …I used the newest osmc installer and i choose wired network and the newest version of osmc(i have tried earlier versions with the same result) it says it will auto boot and install then when its done it should boot up into xbmc ,…my problem is it seems to be doing everything right except the very last part …it doesnt boot into xbmc but instead boots to a black screen with the osmc letters in the top left corner and the time and date in the top right hand corner rest is black no other icons no nothing and it seems to just sit here i dont know what to do next or how to get it t o boot into xbmc like its supposed to!

Some other info that could be useful to the situation is this …i am using the pi 2 and i am using it with the canakits equip and i have nothing but the network and a mouse and keyboard plugged in so it def does not seem like a equip issue

Well first xbmc is now called Kodi and the screen you see is the Kodi screen with the OSMC skin. You might have to increase the contrast to see the menu correctly.
If you reallu think it didn’t boot correctly try to ssh into OSMC and provide logs with grab-logs -A

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

normally i would just do what you suggest but as i said i get only a black screen that says osmc in the top left corner and it has the time and date in the top right hand corner … it does not say kodi nor xbmc it actually says OSMC and there is nothing else on the screen no settings menu in order to get to ip and no power button in order to exit or anything of the sort …i then thought maybe my tv was in the wrong apsect ratio and so i went threw all options and even with the screen at the smallest aspect ratio it is still showing the same black screen with the letters OSMC and the time and date in the corners other then that nothing so i have no idea what to look at next

this is the screen i am left at …and its the same wether i use wifi or a wired network the only dif between the two seems to be when i do a hard wired network the time and date are correct but when i do it wifi its shows what you see in the pic but in both cases there is nothing else on the screen to click and hitting esc does nothing at all

Please access the commandline as @fzinken advised before. Provide the resulting URL after issuing grab-logs -A command.

I have no idea how to ssh without knowing IP and as i stated i have no access to settings …

I read what @fzinken wrote and i would do that if i knew a way how because as of now this is as far as i can get and without knowing the ip i cannot ssh into the setup in order to grab logs or is there a dif way to get to the log files ,can it be done manually from an sd card reader and lookin on the sd card itself otherwise i have no idea how i am ssupposed to get to the logs without being able to get to settings to get ip…I am very sorry if i am missing something but i am just learning the pi.

Log into your router interface to determine the assigned IP address of the Pi. We’ve never seen your issue before, even with the thousands of users running OSMC. There is a bit of a learning curve here but what we are asking really isn’t that steep. If we can’t get in to see what the issue is then I don’t know how we can help you.

OK after trying for the last half hour to connect threw the router it seems it isnt connected to the pi at all …when i look at the connections to my router the pi nor osmc is listed and i am aware of all the connections and there isnt even one thats random that it could be all my connections are accounted for meaning the pi itself allthough having the right time loaded isnt connecting to the internet …so my best bet would be the issue is before the connect to the internet takes place

But you’ve said that a wired connection works?

yes thats what i thought because when i hook it up wifi it shows the time as jan 1 1970 but when i hook it up wired it shows the correct time …however im using putty to ssh but when i load all the connections that are to my router right now it only lists my main pc and my wifes pc as ethernet and then the rest are wifi and shows as 2.5ghz and its my android phone and two iphones as well as a printer there is no other ips in the router at all …only the connections i just mentioned so of course when i slap all these ips into putty just to try of course they all fail to connect …am i doing the install wrong maybe …i am using a fresh brand new 8gb sd card formatted to fat32 then using the osmc installer i pick wired and the newest release i then tell it to write it to sd card and it asks if i am sure and then it does its thing and i take that and put it directly into the raspberry pi and i boot up and it says its formatting then installing and then it reboots and comes to the screen you see above …nothing else can be done after that and i have tried installing an older version of osmc and still no go

There are other ways to get command line access.

https://osmc.tv/wiki/general/accessing-the-command-line/

Sam

This is what it said and i loaded it but im not sure about any of that other then the date is wrong

http://paste.osmc.io/iveqetehen

Well this is weird…do you have another SD card to test a fresh install ? I’ve never seen this bug before so i am guessing its some type of hardware thing. At first, change all your peripherals.(keyboard, wifi, sd card) and test again. I know its a long shot but at least you’ll know if any of them is causing problems.
Also how are you copying the image file to the SD? I am using Win32DiskImager-0.9.5-binary and never had a problem. Maybe your card is getting corrupted? I dont know.I am no expert. Just thinking what i would do if i was in your shoes. :slight_smile:
I’ve had some wifi problems of my own with previous osmc releases, and i am guessing they were all hardware related…but once they added support for my wifi stick, everything was fine after that.

1 Like

you executed the command wrongly, it is grab-logs -A with an upper case A not lower case

And definitely you are connected otherwise the upload would not have worked so just execute ifconfig to see the IP address you are using so that you can connect with ssh from here onwards.

First thing is i wanna just say thank you to those who replied I am very greatful for your help and I am very sorry for wasting your time …
I spent the better part of yesterday doing all i could to figure this out! After confirming with my friends raspberry pi it seems i was delivered a bum one so the fault here lies in the hardware most definately …The raspberry pi that was sent to me will not let the interface fully load …after many tries yesterday i was able to get it to boot once with a menu but it wouldn’t detect my mouse or keyboard and at that point i tried everything right down to dif brand sd cards with no luck at all but when i tried the installs on my friends they boot right into kodi like its supposed to so i am in the process of just returning this pi and grabbing a different one!
So again i apologize for the waste of time but its definately just my raspberry pi that is broken!

1 Like

No worries. At least you know now what’s wrong. :slight_smile: gl with the new one!