Install loop

Hello everyone,

I used the Windows OSMC installer to prepare my USB stick. I turned off the Vero 4k+ (by pulling the plug), inserted the stick, and then turned it back on.

It powers up showing the OSMC logo and the text Please stand by, then it shows the You have 60 seconds to power down before the device is formatted, then Formatting device, then Installing files and finally it ends up with Install failed: tar: corrupted files AND a weird OSMC installed successfully.

I do not know what to do. I have tried different USB sticks, re-downloading the image in the installer or downloading a disk image and then using it in the installer.

Edit 1: I forgot to mention that I try installing only the latest version from October.


Please provide the contents, of the USB stick.

Thanks Tom.

I have these:

23-Oct-20 17:45 24,518,656 kernel.img
23-Oct-20 17:45 112,640 dtb.img
19-Oct-20 15:30 237,448,752 filesystem.tar.xz


Please the OSMC installer Log? Should be in your user directory.

Thanks Tom.

For some weird reason it worked now. All I did was a third USB stick. Weird…

1 Like

It’s possible the download was corrupted or not written to the other USB drive correctly. I’m glad it’s working as expected now.