Install successful, but SAD FACE afterward

I dug out my old ATV1 that previously had Crystalbuntu on it (I do not have the CrystalHD card) and decided to update it to OSMC. The installation is successful. It will boot from the USB drive, do its thing, tell me to unplug, remove the USB drive, wait 10 seconds, and power on. I do exactly that (usually waiting 15 to 30 seconds). It comes back to the Installing screen, says it is successful, reboots… and then only flashes the sad face. I’ve tried the latest version of OSMC for the ATV1 (2017.08-1-HDD) and an older version that I found listed in an online tutorial (2017.03-1-HDD). Both result in the same behavior.

I CAN ssh into the ATV. I found a comment on another post about how to submit a helpful support request. Following those directions. Following those directions, my logs were uploaded to

In my continual troubleshooting, I restored the Apple TV operating system to 3.0.2 which was successful. I then started from scratch installing the latest OSMC for the ATV1 (2017-8). And… same thing as before. It just flashes the sad face. In case anything is different, I’ve uploaded the new logs.

I had this issue and it was the boot partition was read only, this was a solution:
To enable writing to the boot partition again, you need to ssh into osmc on your ATV1, and run the following commands:
sudo umount /boot
sudo fsck.hfsplus -f /dev/sda1
sudo mount -o force,rw /dev/sda1 /boot
Now that the parition is writable, you need to do the following commands to update the system.
sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot
Your system should then update and reboot.

I had ran those commands before, finding them in different comments to other posts on this forum, but perhaps not in that order. Running them again, in that order, did not change anything. Still flashing sad face. So, I started over, re-installed from USB, ran those commands, and after reboot, the OSMC logo came up, then just went to solid black. The OSD on the TV indicated it was receiving a 1920x1080p/60 signal. But it’s just black. After several minutes, I rebooted, and now have the flashing sad face again.

If I disable Kodi with the command sudo systemctl disable mediacenter, I don’t get the sad face. In stead, I just get the OSMC logo. Then, from SSH if I start Kodi by the command sudo mediacenter, the TV starts flashing the sad face again, and I get this output repeating in the CLI:

X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-4-amd64 i686 Debian
Current Operating System: Linux osmc 4.2.3-25-osmc #1 Tue Jun 6 17:37:42 UTC 2017 i686
Kernel command line: console=tty1 root=/dev/sda2 rootfstype=ext4 rootwait quiet video=vesafb intel_idle.max_cstate=1 processor.max_cstate=2 nohpet vga16fb.modeset=0 osmcdev=atv
Build Date: 16 October 2017 08:08:13AM
xorg-server 2:1.16.4-1+deb8u2 (Debian -- User Support)
Current version of pixman: 0.32.6
Before reporting problems, check
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Sun Oct 29 04:40:10 2017
(==) Using config file: “/etc/X11/xorg.conf”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
Fatal server error:
(EE) no screens found(EE)
Please consult the The X.Org Foundation support
for help.
(EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
Kodi exited with return code 1 after 0 hours, 0 minutes and 15 seconds

Any suggestions?

Try the July image.

Well, how about that!

Since I’m on satellite internet and don’t want to be downloading the same files repeatedly every time I run the installer, I downloaded the images and used the local file option in the installer. I did notice that the links don’t match with the files they link to. There is no July image, but there is a May or June, unless I don’t understand the naming convention.

2017.08-1-HDD links to 20171001-HDD
2017.05-2-HDD links to 20170615-HDD
2017.03-1-HDD links to 20170321-HDD

There are no other HDD images. I had been working with the 2017.08 (20171001) and 2017.03 (20170321) and those were both failing. For some reason I just hadn’t tried the 2017.05 (20170615) image. But, I just tried it and it’s good! It booted up into Kodi.

Should I still run the update commands from the CLI?

That’s great news Heath, good informative article.
Beware though, every time I updated via the OSMC interface it went back to smiley face!
In the end stopped updating and eventually changed box!