Installed Meg2 licence on osmc, a few troubles

I installed the mpeg2 licence and now the screen blinks repeatedly and any video I play , plays as a music file. Basically I get the movie sound and for video and i get music visualization on the screen.
Before the licence it worked flawlessly. No buffering, picture was awsome. Only reason for the mpeg licence was for me to get HD homerun and i read that i would need it for a better tv experience.
I installed licence thru osmc program.
I really don’t want to reinstall osmc. Took a long time to get it the way i wanted it.

When and where did you purchase this licence?

And no… your pi2 is not useless… rolls eyes

I bought the licence from the raspberry pi foundation ( http://www.raspberrypi.com/mpeg-2-license-key/ ) on 3/24/15. Im sure its not a lost but I dont understand what happened.
If I do a full install would it remove the licence?
I was very satisfied with OSMC on the Pi2. MORE then SATISFIED :heart_eyes: it was working flawlessly untill the mpeg2 licence was installed.
Thanks for the reply

Well remove the licence key then…

Also, please provide debug logs.

I know nothing about linux but I will do my research and post pics and debug logs.
Thanks

kodi.wiki/view/Log_file

Http://xbmclogs.com/phjzmvch
This is what I got. Hope this helps.
If not please let me know what I have to do.

<advancedsettings>
  <video>
        <defaultplayer>dvdplayer</defaultplayer>
        <defaultdvdplayer>dvdplayer</defaultdvdplayer>
  </video>
</advancedsettings>

Forcing dvdplayer will never use your codec. You need to allow OMXPlayer.

What do you mean by allow omxplayer?

Its check off

Do you really understand what all those advancedsettings.xml items do? The one I quoted there is forcing the use of DVDPlayer (MMAL) regardless of what the GUI indicates. If you want codec enabled HW acceleration you need to allow OMXPlayer by removing the quoted section from advancedsettings.

I don’t understand anything about advanced settings.XML. I will do some research and try my best to remove those settings. If I can’t I will definitely reply as soon as I can.
Thanks for the help.

How did they get there then? Setting cachemembuffersize to 0 is really a poor hack. Can you just paste your advancedsettings.xml? I’m betting we can just dump the whole thing.

The 0 cache I did thru the xfinitytalk maintenance. I was having buffering issues and since I did the 0 cache it never buffered again.
I don’t know how to get to my advanced settings.XML.

Careful. These kind of addons make all sorts of changes that can cause weird behaviour. I’d suggest trying with a fresh install (at least on a spare SD card), with your MPEG2 keys installed and letting us know if you still have issues playing MPEG2 content.

You can test your MPEG2 keys are ‘correct’ with the following command

vcgencmd codec_enabled mpg2

If you still have issues, upload logs via My OSMC -> Log Uploader and chuck the URL here

S

Thanks! you guys have been a GREAT help. I’ll do a fresh install on another sd card and see how that goes.
Thanks again.

Did a fresh install and just to see if it would work, I installed it back as close to the way I had it. I even did the xfinity tweak.
So far its working just fine. Here’s my log.
xbmclogs.com/pu70tujw4