Installer not seeing SD cards on OS X


#1

Device: Raspberry Pi Model B 512mb (SD card, USB);
Using OS X 10.11.

I had Raspbmc, and later OSMC, running fine on my SD card and USB up until two weeks ago, when a family member accidentally removed the USB stick from the Pi.
The Pi didn’t boot after this happened, so I decided to reinstall OSMC on the SD + USB.
Unfortunately, I can’t seem to install OSMC on to any card in any way, whether it be from the installer provided on the website or through the use of dd.
How can I solve this issue? My Linux PC and Windows PC are not available at the moment.

TL/DR:

  • OSMC installer not working on OS X 10.11
  • dd command not working either; no reaction.
  • sudo dd if=~/downloads/OSMC_TGT_rbp1_20150929.img of=/dev/rdisk3s1 bs=1m
  • What should I do now?

#2

Is 10.11 El Capitan?

We don’t support that yet

Sam


#3

Thanks for the quick reply Sam.
Some drastic changes were made to the ‘Disk Utility’ app in El Capitan, I guess that’s what’s causing the installer app to act up.

PS : Thanks for all your hard work and support over the years!


#4

We will fix OS X El Capitan support soon enough. it is tricky for me as I don’t have direct access to a Mac

Sam


#5

I hope you will find a solution to fix the installer soon Sam, more and more like us will upgrade to 10.11 in the upcoming days. We all want to enjoy the September release.
BR.
Xavier


#6

Hi

I have fixed the issue in Git, but I have no Mac at hand to compile the new installer on.

Sam


#7

Waiting on this too.
If you were to provide instructions on how to compile on a mac, I could give it a shot.


#8

This post is over a year old. Please start a new one if you are experiencing issues.

There were some problems with macOS Sierra, but the latest installer has support for it. If you continue to have problems, upload a full log.


#9

Oh oops didn’t notice. Was trying to be a good citizen and searched before posting.
Saw it’s the same issue.

Will open a new thread.
Where are the logs for the installer? (this post doesn’t mention those: How to submit a useful support request)


#10

Check out Testing OS X installer

Please describe your OS X environment as much as possible.

Cheers

Sam


#11

Hey, sorry, I dove into some output of diskutil and saw some weird stuff. Turns out the problem was with the physical micro-sd card to sd card adapter (contact issue with the RO toggle; it was not on RO, but read as if it was)


#12

Glad you got it solved