Installer won't install OSMC to ATV1 HDD

#1

I am trying to install OSMC on my ATV1. The installer gives me the option of a USB or HDD image, so I choose HDD. The screen that follows that asks where I want to install it with the following options:

on an SD card
on a USB stick
on an NFS share
on internal storage

The first option is already ticked, and it is not possible to select another option. Continuing anyway, I am asked where I would like to install osmc, so I choose the USB stick. Then the installer downloads the file and writes it to the 8GB USB stick. Inserting the USB stick in the ATV1 and plugging in the power, the installation proceeds as expected. However, it installs itself back to the USB stick. If I remove the stick and restart, I come back to the Apple select language screen and the back to my previous ATV content. Running from the USB stick is far too slow as well pointless, as I have no access to the HDD capacity of the ATV1.

I did try another USB stick (Toshiba 32 GB), but the ATV does not see it when restarting.

Also, there is no sound whatsoever. I have tried this on 2 different HDMI televisions.

What am I doing wrong?

Thanks for any help.

0 Likes

#2

Please take photos to clarify this.
For an HDD install, select the HDD Image and a USB stick. UBS will image the HDD.

Which version of the image did you use?

0 Likes

#3

First of all, thank you for your prompt reply!

I had made a long reply with 25 screen shots… But I tried yet another USB stick, and viola! It worked.

Now, I just need to solve the problem of no sound. :slight_smile:

Thanks,

JJS

0 Likes

#10

I encountered the same problem as you when installing. Can you help me to solve how to install OSmc to Apple tv’s hard disk correctly? My e-mail is mczhipeng@me,com

0 Likes

#11

OP wrote that using another USB stick helped. Have you tried this solution?

0 Likes

#12

These four options cannot be selected
on an SD card
on a USB stick
on an NFS share
on internal storage

0 Likes

#13

That’s intentional. Just write to usb

0 Likes

#14

But in the installation process, the USB is pulled out and the Apple TV power is turned off. After 10 seconds, the power is re-plugged in.

0 Likes

#15

Are you trying to install to USB or HDD?
Make sure you select the correct image

0 Likes