Installing a2dp package had unintended effect

I was attempting to get Bluetooth working with my headphones, unsecessfully (pretty sure it’s the headphones though), but when switching audio back to hdmi there’s an issue. The volume works nomally for around a minute then without warning it ignores the volume set in Kodi, maxes it, and sounds distorted as well (this may be due to the loudness however as it plays through a device I leave turned way up and adjust though Kodi). If I switch back to pulse and right back to hdmi it works normally again, but the same issue happens after a minute or so each time.
I’ve tried disabling the Bluetooth adaptor entirely, rebooting multiple times, and a sequence of reboots/enabling disabling adaptors/changing sound devices to no avail.

I’m using a Vero 4K running the most recent update. The only additional packages are smb, ftp, and a2dp if irc.
I just reinstalled OSMC from the most recent image last Saturday and it all worked fine up until I installed the a2dp package this morning.

Is there a way I can rollback the changes made when installing the a2dp package so I can see if that would fix the issue?

Log files:

And I realized I have the command from Sam to remove from doing this back on osmc w/ Kodi 17.
Still, wondering why this is occurring.

The command I’m trying is
sudo apt-get remove —purge pulseaudio
Incase anyone else may need this.

It seems like this fixes the distortion/ignoring the volume limit set on Kodi.